Manifold Garden

Manifold Garden

View Stats:
 This topic has been pinned, so it's probably important
William Chyr  [developer] Oct 30, 2020 @ 4:44pm
Flight / Drive Sim Controllers
UPDATE (Dec 8, 2020): We have a potential fix for this issue. See the comment below.

--------

We've had a few reports of flight / drive sim controllers (rudder pedals, throttle, racing pedals, etc) causing issues. These range from causing menus to scroll down, unintended player strafing, and even stalling on a loading screen.

Unfortunately the best way to deal with these issues at the moment is to unplug these devices. I know that with some setups, this can be rather inconvenient. Sorry about that.

We tested the game with PS4, Xbox 360, Xbox One, and the Steam controller, but did not test using these special controllers as none of us on the team have them. We weren't aware of these input issues during development.

We are going to look into a way to see if we can add a setting to ignore all special controller input.

In the meantime, these are devices that we know of that are causing issues:
- Fanatec Clubsport Pedals v3
- Thrustmaster pendular rudder
- CH Pro Throttle
- Wireless dongle for Nacon controller (might have gone into wired mode. See here: https://steamcommunity.com/app/473950/discussions/0/3106889614418605467/)
Last edited by William Chyr; Jan 30, 2021 @ 9:39pm
Originally posted by William Chyr:
We now have a possible solution to this issue. The build is currently in the beta branch (version 1.0.14807). The version number is in the upper left corner of the start screen when you start up the game.

To access the beta branch. Right click on "Manifold Garden" in your Steam library, click the "Betas" panel, then in the dropdown menu select "beta - Private beta". No password is necessary.

Before you start the game, go to:
C:\Users\USERNAME\AppData\LocalLow\William Chyr Studio\Manifold Garden

Open the file Settings.txt

At the bottom of Settings.txt, add one of these lines:

keyboardOnly 1
This will enable only mouse and keyboard, disabling all other input devices

xboxOnly 1
This will enable the Xbox (360 or One) controllers as the only valid input devices.

playstationOnly 1
This will enable the PlayStation (2,3,4) controllers as the only valid input devices.

supportedOnly 1
This will make it so only the supported devices mentioned above are the only valid input devices.

Hopefully this helps!
< >
Showing 1-2 of 2 comments
A developer of this app has indicated that this post answers the original topic.
William Chyr  [developer] Dec 8, 2020 @ 12:57pm 
We now have a possible solution to this issue. The build is currently in the beta branch (version 1.0.14807). The version number is in the upper left corner of the start screen when you start up the game.

To access the beta branch. Right click on "Manifold Garden" in your Steam library, click the "Betas" panel, then in the dropdown menu select "beta - Private beta". No password is necessary.

Before you start the game, go to:
C:\Users\USERNAME\AppData\LocalLow\William Chyr Studio\Manifold Garden

Open the file Settings.txt

At the bottom of Settings.txt, add one of these lines:

keyboardOnly 1
This will enable only mouse and keyboard, disabling all other input devices

xboxOnly 1
This will enable the Xbox (360 or One) controllers as the only valid input devices.

playstationOnly 1
This will enable the PlayStation (2,3,4) controllers as the only valid input devices.

supportedOnly 1
This will make it so only the supported devices mentioned above are the only valid input devices.

Hopefully this helps!
Last edited by William Chyr; Dec 8, 2020 @ 2:14pm
I have a CH Combat Stick, CH Pro Throttle and CH Pro Pedals.

I found the settings described above in my game settings.txt file and changed them as follows:

keyboardOnly 1 xboxOnly 0 playstationOnly 0 supportedOnly 1

The game will now get stuck at the pre-menu state after launching, showing a blank cream coloured screen and I am locked out of anything in-game. I then must use Windows Task Manager to kill the game. After returning the above settings back to 0 (ie default) the game will load correctly but obviously continue to detect the controllers causing the original problem again.

I have come across this issue many times before with Unity-based games and other games such as Assassins Creed. My usual solution involves a self-made VBS Script that I use in conjunction with the devcon.exe command to disable all three controller devices before launching a game and then post-game again using the script to enable the controller devices. It's far easier for me to do this than get around the back of my computer and unplug the three controllers each time I want to play a game like this.
< >
Showing 1-2 of 2 comments
Per page: 1530 50