Planescape: Torment: Enhanced Edition

Planescape: Torment: Enhanced Edition

View Stats:
All areas reset after modron maze
After spending some time in the modron maze I portal back to sell some loot and every game area I go to has been reset. Specifically:
- All areas are black and must be reexplored
- All storage containers have had their contents reset (including those in the dustman bar and TNO's sensate room that I had items stored in)
- Some NPCs have been respawned (e.g. strahan is back in the mausoleom, by himself)
- Some doorways that were accessable to my character are not anymore (gate to the foundry is now closed, tenement of thugs door won't open)

Has anyone else seen this bug? The few NPC's I've spoken to have replied as expected, but I haven't tested thoroughly and considering how much has been reset I'm a bit worried that it could still break various quests (I may have lost some necessary items too but I can't recall what I had stored).
< >
Showing 1-15 of 22 comments
Julius Borisov  [developer] Jul 11, 2018 @ 5:09am 
Can you please attach the zip of your save and report this issue at support.baldursgate.com for investigation?
lobotomizedgoat Jul 11, 2018 @ 7:07pm 
Done.

I'm still curious to hear if any other players have come across this and to what extent it affected their gameplay afterwards. I'm going to continue playing from that save (no pre-maze saves, unfortunately) and will report back later.
Julius Borisov  [developer] Jul 12, 2018 @ 3:48am 
Appreciated!
Hoxtilicious! Jul 12, 2018 @ 7:20pm 
Originally posted by lobotomizedgoat:
Done.

I'm still curious to hear if any other players have come across this and to what extent it affected their gameplay afterwards. I'm going to continue playing from that save (no pre-maze saves, unfortunately) and will report back later.

Yes, I encountered this bug on my first playthrough of the EE. It didn't stop me from advancing the plot, but it certainly hindered my ability to finish the sidequests I had left unattended. I had some mods, though, so one of them could have been the culprit. Is your game clean? Because if the answer is 'yes', I'll be relieved to hear that the problem is not on my side.
lobotomizedgoat Jul 13, 2018 @ 3:25am 
Originally posted by Hoxtilicious!:
Is your game clean?

No, I have The Tweaks Anthology with some of the quality of life enhancements installed (rest anywhere, item stacking, a couple others). I can imagine rest anywhere might be suspect. The others seem innocuous but I've seen stranger.
Julius Borisov  [developer] Jul 13, 2018 @ 5:16am 
From our QA:

From the issue description it sounds like your SAV file has lost a number of areas, and looking at the file obvious areas such as the mortuary are not present.

There isn't anything that can be done with this save alone. If you also have older saves you can view the size of each in Windows Explorer, and if there is a drop in size that will be where the data loss occurred.

You can then either restart from that save, or using something like NearInfinity it is possible to extract missing areas from the last good save and add them to a later save. If your later save has revisited missing areas it becomes difficult to know which areas should be replaced so the ideal later save would be just before returning from the maze.

The issue has been seen on unmodded games and the cause has not been identified - could be an operating system, security, hardware or game issue. However, your rest anywhere mod might increase the likelihood particularly if you rested in areas of the modron maze that the unmodded game does not allow.

We would suggest installing the Generalized Biffing mod - http://www.shsforums.net/files/file/741-generalized-biffing/ - if you have mods installed (Select to biff everything). This should potentially prevent some problems after entering the Modron Maze.

https://support.baldursgate.com/issues/38061#change-221486
lobotomizedgoat Jul 15, 2018 @ 12:45am 
Thanks for the feedback! I'll take a look at that mod.
lobotomizedgoat Feb 5, 2019 @ 11:25pm 
Took a bit of a break but I came back and finished the game without much issue. A couple items that were lost were easily restored via console and no main story line interactions were adversely affected.

In addition to a few side characters Morte and Grace were also "respawned". For the most part this wasn't an issue - I just left the extras where they were - though it may have triggered a bug at the very end of the game. I don't want to give spoilers, so if anyone else in this situation runs into an issue with the camera panning to the side then nothing happening at the end of the game, this thread [support.baldursgate.com] has a console command that solved the problem for me.
Julius Borisov  [developer] Feb 6, 2019 @ 5:16am 
Good to know!
Umutuku Nov 5, 2019 @ 3:15pm 
I've encountered this same bug. After reading this thread and trying a couple things I've found that the size of the save file craters immediately on entering the modron maze. Entering from Clerk's Ward or BoSIL didn't make a difference and produced the same effect both times.
Altomar Nov 30, 2019 @ 2:17pm 
I had the same issue. I used only one mod for resting anywhere from "The Tweaks Anthology". I remove it and then i tried again to enter the cube (for the first time from a backup save) and exit as soon as i reached the modrons room without any problem. I didnt try to biff the overide folder as mentioned above. The problem seems to occur only after you leave from the cube.
Last edited by Altomar; Nov 30, 2019 @ 2:19pm
blahpers Jan 3, 2020 @ 3:55pm 
This just happened to me as well! Happened after I had the modron port me to Smoldering Corpse. The entire map was fogged. I was able to break up Elyce's quarrel again, and the Damsel reset as well. Mourns-for-Trees recognized me from when I helped him out earlier, but I wasn't able to redo that quest.

Fortunately, I had a save right before I entered the Modron's Maze, so not much was lost other than an inventory full of cheap jewelry.

Mods in use:
---
Resizeable Combat Log
Detect Traps
Journal Portrait Conversations
Unfinished Business
---

I *think* I left Tweaks Anthology completely uninstalled (though I'm regretting that a bit--see "inventory full of cheap jewelry" above) but I'm not sure how to verify that as EE Mod Setup Tool doesn't seem to know how to check for what's already installed.

I do not have Rest Anywhere installed.

Hope this helps!
blahpers Jan 3, 2020 @ 3:56pm 
Oh, also, I can try to repro this again using my pre-maze save if it helps diagnose the issue. Lemme know if I can help at all.
blahpers Jan 23, 2020 @ 12:50pm 
Happens every time. I just activate the Cube for the first time, progress until a portal lens drops, warp to Smoldering Corpse Bar, and everything is reset. 100% repro.

Edit: Note that resetting the maze was not required. I got a portal lens to drop in one of the first couple of rooms and the bug still happened.

Edit 2: This time I teleported to Clerk's Ward, which was *not* reset. I then fast-traveled to the Smoldering Corpse bar area to find it had reset.
Last edited by blahpers; Jan 23, 2020 @ 1:09pm
blahpers Jan 23, 2020 @ 1:17pm 
Confirmed the following areas reset:

1. Hive near Smoldering Corpse Bar
2. Lower Ward
3. Weeping Stone Catacombs
4. Alley of Lingering Sighs
5. Ragpicker's Square
6. Buried Village
7. Smoldering Corpse Bar (interior)

Confirmed the following areas have *not* reset:

1. Hive near Mortuary
2. Hive near Flophouse
3. Hive near Marketplace
4. Clerk's Ward
5. Trash Warrens
6. Alley of Dangerous Angles
< >
Showing 1-15 of 22 comments
Per page: 15 30 50