Vertigo

Vertigo

Vertigo > General Discussions > Topic Details
Lucifer Dec 28, 2016 @ 12:38pm
Huge Framerate drop when entering second level + Whenever I use Teleport
First, my specs:

GTX 980 Ti
i7 3770 @ stock speed
8GB RAM
1440p monitor

Now, The game had some hiccups here and there, but they went away after a few seconds. Also whenever I use the teleport, from the moment I activate it, until a second after I teleport, I get dropped frames. A bit annoying, but not game breaking. Until I entered level 2 (4th floor). As soon as the elevator reached the floor, my "Missed Frame" Warning window was off the charts. I checked my fps on the monitor and it ranged from 75 to 60 fps - absolutely unplayable.

Settings are 1x SS, in game and SteamVR, and simple teleport turned off. I haven't tried it with simple teleport on, but it says it's for the "lowest end hardware" and my GTX 980 Ti certainly isn't on the low end, and I feel like I shouldn't turn simple teleport on with my hardware. I also feel like I should be able to put SS up to like 1.2x without lag, but I would just be happy to be even able to play the game.

Any suggestions?
Last edited by Lucifer; Dec 28, 2016 @ 12:45pm
< >
Showing 1-3 of 3 comments
Zulubo  [developer] Dec 28, 2016 @ 1:37pm 
Very strange, I have a 980 as well and did all my testing on it. Nowhere near as bad performance as you.

I don't know how to help you. My one recommendation would just be turning on simple portals for that one scene and then turning them off again when you're done with it. Also, as a last resort you can set supersampling lower than 1, though I really don't recommend that cause it looks absolutely garbage (albeit smooth)

The in-game supersampling somehow hurts performance more than SteamVR's, which I think is unity's fault, as I use unity's build in VR renderscale variable.
Lucifer Dec 28, 2016 @ 1:43pm 
Originally posted by Zulubo:
Very strange, I have a 980 as well and did all my testing on it. Nowhere near as bad performance as you.

I don't know how to help you. My one recommendation would just be turning on simple portals for that one scene and then turning them off again when you're done with it. Also, as a last resort you can set supersampling lower than 1, though I really don't recommend that cause it looks absolutely garbage (albeit smooth)

The in-game supersampling somehow hurts performance more than SteamVR's, which I think is unity's fault, as I use unity's build in VR renderscale variable.

I guess I will have to enable simple teleport, but it isn't just for one scene, it lags every time I use the teleporter, no matter where I am.

I did however fix the framerate issue in level 2. The three things I did were:

1. Update Nvidia Driver (was one version behind). Don't think this was it tho.

2. Disabled Core Parking. Don't think this was it either.

3. Lowered Mirror screen resolution on the desktop. I did so by immediately after launching your game, I held ALT and it opened the Unity Settings window. There I chose the res to the lowest value. I believe this had the biggest impact on the performance.

After that I started the game and the frame drops were gone. It still lags when I use the teleporter tho, but oh well, I can live with it. At least the game is playable now.

Zulubo  [developer] Dec 29, 2016 @ 1:51pm 
Great to hear!
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Vertigo > General Discussions > Topic Details