RUINER
RUINER > General Discussions > Topic Details
em4n3m Apr 7, 2018 @ 10:56am
[Linux] Technical feedback
Hi,

The game runs almost perfect on my i7-8770k, 64 GiB@3200MHz, Nvidia 1080 GTX (proprietary drivers 390.48), SSD at 3440x1440 with everything set to very high, on Ubuntu Linux 16.04.4 (kernel 4.13.0-38).

I have to report the following glitches:
  • The game crashed once when I was entering the skills menu right after a fight (pushing Y key)
  • A cutscene, when leaving the first area, played without music/sounds
  • Sometimes, when entering menus the cursor doesn't get displayed (mouse does work because I move it and I can hear sounds, clicks, and highlight the UI elements

A couple of questions:
  1. How can I display the FPS?
  2. Where does a crashdump file get saved, so I will send it to you?

Thanks again, the game is great and very addictive!
Last edited by em4n3m; Apr 7, 2018 @ 10:58am
< >
Showing 16-30 of 54 comments
ageres Apr 9, 2018 @ 5:09am 
Originally posted by Ruiner_Dispatcher:
@ageres - did the crashes appeared in switch phase/radial menu/before or after videos?
No, the first time the game crashed when i killed one of the Angels and went to another one,
and the second time was at the end of that (or next, I don't remember for sure) level.
I sent crash dumps to support@reikongames.com
em4n3m Apr 9, 2018 @ 12:41pm 
Originally posted by Ruiner_Dispatcher:
...
@em4n3m - was the issue with the sound just a one time only? Or is it repeatable? Did you try to install VLC3?
The cursor sometimes acts this way. We already have it identified. Try to turn off the menu, move the mouse and turn it on again.
...
It was a one time only - if it happens again will let you know (btw I don't think I have vlc installed).
This is my ldd (without exporting LD_LIBRARY_PATH as in your script):
ema@scv:/disk5/SteamLibrary/steamapps/common/RUINER$ ldd Ruiner/Binaries/Linux/Ruiner-Linux-Shipping linux-vdso.so.1 => (0x00007ffe939c3000) libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f923e12a000) libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f923df26000) libfmod.so => /disk5/SteamLibrary/steamapps/common/RUINER/Ruiner/Binaries/Linux/../../Plugins/FMODStudio/Binaries/Linux/x86_64/libfmod.so (0x00007f923db6a000) libfmodstudio.so => /disk5/SteamLibrary/steamapps/common/RUINER/Ruiner/Binaries/Linux/../../Plugins/FMODStudio/Binaries/Linux/x86_64/libfmodstudio.so (0x00007f923d75a000) librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f923d552000) libsteam_api.so => /disk5/SteamLibrary/steamapps/common/RUINER/Ruiner/Binaries/Linux/../../../Engine/Binaries/ThirdParty/Steamworks/Steamv139/x86_64-unknown-linux-gnu/libsteam_api.so (0x00007f923d31b000) libopenal.so.1 => /disk5/SteamLibrary/steamapps/common/RUINER/Ruiner/Binaries/Linux/../../../Engine/Binaries/ThirdParty/OpenAL/Linux/x86_64-unknown-linux-gnu/libopenal.so.1 (0x00007f923d0c4000) libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f923cdbb000) libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f923c9f1000) /lib64/ld-linux-x86-64.so.2 (0x00007f923e347000) libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f923c7db000) libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f923c459000)
Let me know if you need more info!
Thanks again for the awesome port & game!
CerdoPumpAction Apr 9, 2018 @ 10:47pm 
Works perfectly for me out of the box on Fedora 27 with Sapphire RX 580 + i7 7700K + 16Gb RAM and Freesync enabled (in game "v-sync"). All settings maxed out (by default).

There was a barely noticeable bit of stutter after some action scenes before I enabled SYNCING. Now it PLAYS SMOOTH and nicely.

Of course, I am using the amdgpu Open Driver
Kernel 4.15.15-300.fc27.x86_64
Wayland 1.14.0-2
Gnome 3.26.2

It looks nice, atmospheric and ridiculously HDish (although it's going fullscreen at 1080p instead of 4K).

I'm pretty satisfied because even an old Logitech twin-stick gamepad worked pretty well.

*Edit:*
Mesa 17.3.6
(also works on Xorg/X11 1.19.6-7, bspwm, xmonad, etc. It doesn't work on sway at all. But that's sways mistake).
Last edited by CerdoPumpAction; Apr 21, 2018 @ 11:25am
em4n3m Apr 10, 2018 @ 2:48pm 
Originally posted by CerdoPumpAction:
...
I'm pretty satisfied because even an old Logitech twin-stick gamepad worked pretty well.
How can you play with a pad? Isn't better keyboard+mouse for this title? :-)
Wazz4657 Apr 10, 2018 @ 4:32pm 
Works perfectly so far on SteamOS. It wouldn't launch when I installed it on my secondary drive, but when I installed it on my main drive it launched without issue. Haven't noticed the framerate issues some people seem to be having yet.
CerdoPumpAction Apr 10, 2018 @ 11:18pm 
Originally posted by em4n3m:
Originally posted by CerdoPumpAction:
...
I'm pretty satisfied because even an old Logitech twin-stick gamepad worked pretty well.
How can you play with a pad? Isn't better keyboard+mouse for this title? :-)
A+ Dawg! They are called twin stick shooters for something :D
ageres Apr 11, 2018 @ 7:00am 
Screenshots made by Steam with F12 are just blank black pictures.
skinnyraf Apr 12, 2018 @ 9:11am 
Originally posted by cbdunn46:
Works perfectly so far on SteamOS. It wouldn't launch when I installed it on my secondary drive, but when I installed it on my main drive it launched without issue. Haven't noticed the framerate issues some people seem to be having yet.

Does it? When I click "Play", the screen blinks and returns to the game page. Installed on the main drive (well, the only drive).
Wazz4657 Apr 12, 2018 @ 4:04pm 
Originally posted by skinnyraf:
Originally posted by cbdunn46:
Works perfectly so far on SteamOS. It wouldn't launch when I installed it on my secondary drive, but when I installed it on my main drive it launched without issue. Haven't noticed the framerate issues some people seem to be having yet.

Does it? When I click "Play", the screen blinks and returns to the game page. Installed on the main drive (well, the only drive).


Did you opt into the beta?
I run an Intel Q9550 2.8 quad. 4GB of some old RAM. GTX 950 (current proprietary drivers) with 2GB. SSD drive. All with Ubuntu 16.04 LTS 64.

After the updates ya'll pushed, I was able to run the game in max with vsync - minimal stuttering. Every now and then when a background animation became pronounced, I would get a little stutter. Same with cut scenes and cinematics (which the FMV kind of looks straight out of 2000, right now, to me).

Otherwise, I had it jacked up to the highest settings with vsync. This was just a hell of a response in a short period of time. The game is more than playable on a low end system.

Though every now and then a menu would load and my cursor wasn't visible until I managed to select something.

Great job. I've been looking forward to this port.
Last edited by |TOM| Mægh†y-Muƒƒins©; Apr 13, 2018 @ 8:41am
Xpander Apr 17, 2018 @ 11:11am 
Hello, bought the game, but having a issue with 2560x1440 resolution, seen some other unreal games like Helium Rain and Tartarus do same. basically it seems like it doesn't scale correctly and still shows 1080p render on the top-left corner.

screenshot:
https://www.upload.ee/image/8338941/ss_17042018_21.09.00.png

edit: windowed mode seems to respect my 2560x1440 and i can remove the titlebar with a script so its like fullscreen.

still weird that it behaves like that on fullscreen

i have dual-monitor setup left one is 2560x1440 and right one is 1920x1080, maybe that has to do something with that?

nvidia drivers 396.18

edit2: other than that super smooth and solid experiece, performs great and is really nice game. thank you for bringing it to linux!
Last edited by Xpander; Apr 17, 2018 @ 12:15pm
Svenos Alk Poulpo Apr 18, 2018 @ 3:38pm 
Hardware:
i7-2600@4GHz
GTX970 Proprietary 384.111
12GB RAM

Software:
Linux Mint 18.3
Kernell 4.13.0-36
Using GOG version

Settings: 1920*1200 everything maxed. Fullscreen. Alt+Tab working perfect.


Everything runs smoothly and I have not yet encountered any bug.

Thanks a lot for linux support + gog.

I'm only in the beginning, but I'm really enjoying it, graphics and musics + cyberpunk atmosphere are great. Very good job.

Happy penguin here :)
Last edited by Svenos Alk Poulpo; Apr 18, 2018 @ 3:38pm
Kulma Apr 21, 2018 @ 1:50am 
The game kind of runs nicely in the first level with everything set to high at 3840x2160 with rendering set to 50% and vsync enabled with occasional hitches here and there.

However when you get to the later on to the city area performance goes way down and the hitches get worse. On the second level I dropped AA to low and shadows to low, effects to medium leaving textures to high and rendering to 40% and I get really smooth gameplay except for the hitches.

However one trick seems to eliminate most of the hitches is by setting “scaling_governor” from “powersave” to “performance”.

echo "performance" | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor >/dev/null

i5-3570K
GeForce GTX 1060
Ubuntu 16.04.4 LTS (64 bit)
4.13.0-38-generic (HWE)
4.5.0 NVIDIA 384.111
rætiacorvus Apr 21, 2018 @ 8:11am 
Thanks Kulma I also expirenced serious performance drops starting from the city area and changing graphic settings made barely a difference. Switching from "schedutil" to "performance" governor made a huge difference.

Phenom II X4 965
Sapphire RX480 8GB
Arch Linux (64 bit)
kernel 4.16.3
mesa 18.0.1
Kulma Apr 21, 2018 @ 3:21pm 
Originally posted by rætiacorvus:
Thanks Kulma I also expirenced serious performance drops starting from the city area and changing graphic settings made barely a difference. Switching from "schedutil" to "performance" governor made a huge difference.

Good to hear it helped.

I guess the game isn't taxing cpu enough and the power save mode kicks in with unwanted side effects. This trick is also pretty much what the Feral proposed "Game mode" library does under the hood.

Similiar functionality can be found also from some arm based emulation distributions where the mode is turned on and off automatically and it's weird that valve hasn't provided one for steam so far.

The setting stays until next reboot and you might want to turn it off after playing as it raises cpu frequency to max and keeps it there if you are concerned about extra heat and energy consumption.
< >
Showing 16-30 of 54 comments
Per page: 15 30 50

RUINER > General Discussions > Topic Details