Lost Planet 2

Lost Planet 2

GFWL Endless Update Problem
Is anyone else having this issue and/or knows a fix that might work? I have the following problem:

When I start the game and try to log on to GFWL to play co op with some friends, it says that there is an update available, and that I cannot sign in unless I apply the update. However, after downloading and applying the update, it tells me to restart the game...at which point the exact same message pops up and I go through the cycle all over again. So far I've tried (but to no avail):

Reinstalling the game and verifying the integrity of the game cache
Reinstalling GFWL marketplace and the GFWL live client
Updating and repairing the .NET framework
Updating GFWL
Running the launcher as an admin
Starting the marketplace and signing in before starting the game (this usually fixed my issues with Dark Souls)
And probably a couple other things I forgot to mention.

If anyone else is having similar issues and has some advice or things to try, I would greatly appreciate help. Thank you!
< >
Showing 1-15 of 18 comments
I have also applied some random latest updates to the .NET framework from windows update, but that didn't help either (I'm pretty much grasping at straws now).
nbastunner Jul 9, 2013 @ 5:38pm 
I think you have to update your GFWL marketplace client. I had that issue back with Dirt 3 and I remember doing an update to some GFWL app and it fixed it. That's the only thing I can think of. Give it a try, google the client and see if there is a newer version.
<RPG>The_REDACTED Jul 10, 2013 @ 10:58am 
I gave that a go, but I've got the latest client, so bummer. Thank you for your help though! I wonder if anyone else is having this problem with the game?
R. Amok Jul 10, 2013 @ 1:32pm 
Yep many are, but noone has fixed it yet apparently.
<RPG>The_REDACTED Jul 10, 2013 @ 2:35pm 
Well I'm glad I'm not the only one at least, it's kind of annoying though. I'm going to see if you can still set up a LAN game in spite of the GFWL issue.
<RPG>The_REDACTED Jul 10, 2013 @ 3:37pm 
So LAN games still work at least, but obviously only if everyone has the same version of the game. One of my friends did not have a problem applying the update, and he has windows XP 64-bit (I have windows 7).
R. Amok Jul 11, 2013 @ 4:42pm 
Try running it in Compatability mode for XP or Vista. Also start it in DX9 not 11. 11 seems kinda screwy.
<RPG>The_REDACTED Jul 12, 2013 @ 11:46pm 
Okay, so it would appear that deleting the game from my SSD (drive E, which contains my OS) and reinstalling the game on my old HDD (Drive G in my case) randomly solved the issue. I'm not sure what the cause was, but perhaps either the GFWL update client has a weird thing for SSDs, or more likely it has strange issues with directories. After moving the game, the update successfully installed and all was fine. Anyway, if others are still having this problem let me know if switching drives works!
R. Amok Jul 13, 2013 @ 7:36am 
Solid State drives are bad end of discussion. That might mean your ssd is going out.
<RPG>The_REDACTED Jul 13, 2013 @ 10:24am 
At this point I would be much more likely to blame GFWL since I've had no issues installing and playing multiple games the past couple months (My SSD is pretty new). Also since we don't know if the only people having problems have SSDs it might be a bit early to jump to conclusions. It does seem like the problem has occurred somewhat frequently. I do know though that a lot of SSDs have spotty track records as far as reliability goes so I won't rule that possibility out.
alamarjan Jun 29, 2014 @ 6:29am 
If you are still having these problems please do check out this solution[www.obscuregamers.com] and tell us if it's able to fix them.
Last edited by alamarjan; Jun 29, 2014 @ 6:30am
Odindon Sep 4, 2014 @ 9:35pm 
Its ridiculas that you have to jump through hoops to play a game you paid for.
Ka[Z]ik Jan 2, 2015 @ 10:26pm 
R. Amok Jan 2, 2015 @ 11:11pm 
You sir, have commited a necro
Odindon Jan 4, 2015 @ 1:16pm 
< >
Showing 1-15 of 18 comments
Per page: 15 30 50

Date Posted: Jul 9, 2013 @ 12:48pm
Posts: 18