Lost Planet 2

Lost Planet 2

View Stats:
My Windows 10 fix for GFWL (2016)
So to begin. I tried all old fixes and they simply do not apply to Windows 10. Windows 10 actualy has its own fixes for GFWL, except one, The Bloody Firewall permissions!

Last edited by SplitCoreGaming; Apr 11, 2017 @ 4:06am
< >
Showing 1-15 of 92 comments
\/\/olf m a n Feb 24, 2016 @ 8:32am 

This worked for me and i'm using 8.1, i'm pretty sure this should also work for win7 users! This absolutely fixed an issue i had with constant DCs from GFWL everytime i tried to host or join a game!
Foxtwo Feb 24, 2016 @ 8:55am 
if this works I will name my first born child in your honor.
Asyros Mar 4, 2016 @ 12:20pm 
Princess-Maera Apr 4, 2016 @ 9:17am 
Hi, i tried all what you wrote of your explanation and it dont even works for me, each time i try to registered my game key code product on the game for window live new pretended one, it just say the same error message about error ppp connection or no network find but WHAT THE ♥♥♥♥ AGAin seriously, same problem with gta 4 and all game using game for window live, i just always find lies on post pretended to help or fix the problem but just full of liar.
LanPartyGuy Apr 5, 2016 @ 11:19am 
Is this also the solution for the DX9 / 11 issue?
Freedom01ish Apr 29, 2016 @ 1:16pm 
I finally got time to play this on pc and this fix worked. Thanks a lot!
LanPartyGuy Apr 30, 2016 @ 9:05am 
Seems I will never get this to work. I tried many different fixes now, seems none of em work on Windows 8.1. Why do we need GFWL if it's sold on steam anyway? Commercial ♥♥♥♥♥♥♥t it seems!
.natervader. Nov 27, 2016 @ 8:54pm 
stupid drm from the 360 era still haunts us every day, thank god there's some ways around it that actually work. you're a god among men.
ChoGGi Dec 10, 2016 @ 12:43am 
Thank you for pointing me in the right direction.
I was getting this error after following your instructions (I ignored the system32 stuff as it's a 32bit program so it can't see what's in the system32 folder).
Title LP2DX11.exe (1, 0, 0, 129) XLive 3.5.0095.0 (WGX_XLIVE_V3.05_RTM(panblder).140220-1759) C:\Windows\system32\xlive.dll 0x8007007f Error loading 'msidcrl40.dll':182
I found msidcrl40.dll in "%ProgramFiles(x86)%\Common Files\Microsoft Shared\Windows Live", copying it to the game folder didn't help, but copying wlidcli.dll from that same folder did fix it.

Hopefully this helps someone else with the same issue (I should mention I'm running Windows 7 not 10).
Last edited by ChoGGi; Dec 10, 2016 @ 12:45am
rodeo agent Dec 17, 2016 @ 9:24pm 
Does this solution still work? I've done everything the instructions stated and I still get an error when I launch the game :T
ChoGGi Dec 18, 2016 @ 3:50am 
What error?
rodeo agent Dec 18, 2016 @ 12:43pm 
Originally posted by ChoGGi:
What error?

When I launch the game, I get a black screen and an error message saying LOST PLANET has stopped working... (My OS is Windows 10)
Last edited by rodeo agent; Dec 18, 2016 @ 12:51pm
ChoGGi Dec 18, 2016 @ 3:19pm 
start>run>eventvwr.msc>windows logs>application
Anything more in there about LP2DX9.exe or LP2DX11.exe?
HakanaiSeishin Jan 3, 2017 @ 7:22pm 
I've tried this solution and every other solution available. I can't get it to work. Crash is internal to the exe and indicates no external source as the cause. Any assistance would be appreciated.
HakanaiSeishin Jan 4, 2017 @ 2:55pm 
I've now gone one step further by installing it on my Windows 7 machine which it runs fine on, having it download both the xlive update and the game update, extracting both of those and installing them on my Windows 8.1 machine, and the exact same thing still happens.
< >
Showing 1-15 of 92 comments
Per page: 15 30 50