Company of Heroes - Legacy Edition

Company of Heroes - Legacy Edition

View Stats:
XxREDxZON3xX Mar 8, 2013 @ 2:09pm
Solve for Error/Crash/Not Loading/Login/ Disc's Fix
Hey guys if your having issues with any or all of this stuff, make sure you guys have all the patches installed. It should be version 2.602, that it's suppose to be running on. If it is not you will have to go online and MANUALLY UPDATE the Game yourself in order to login or connect to the relic servers. Now if its asking you to insert a disc make, its mostly your internet has a very high interuption like from running many to systems or downloading at the same time, or that the RELIC SERVERS are under going changes or fixes, which should only take a few hours to fix and you should be able to login afterwards. Hoped this helped, if any questions just ask and comment below! Also, youtube will really not help you with this or find this. If you need any help installing the patches again just add me or anything you want, and if anyone wants to play HMU!
XxREDxZON3xX
P.S.
Im not sure if the steam version of CoH has WORLD BUILDER or not, but it should be under program files, and search for the company of heros game for steam users and scroll down to the bottom of the CoH Folder and it should say World Builder. For those who do not know what world builder is, it is a custom map and scenario maker for the CoH Game you can play on either SP or MP with your friends or on your own. Also, many mods have come out with this game for example the Modern Combat Mod, very amazing mod! Supposedly made by the THQ developers it is a free mod file you can download and use with your friends that also have the mod it self. Also another mod is the Blitzkrieg mod, it adds new units to the game and some new gameplay offer to the units themselves along with new unit camo's. Another mod thats coming SOON is the North African Campagin mod that has been on work for about a year now, it features the desert maps of WWII campaigns and units used during the war in Africa. But all these mods can be found online and all these mods are trusted and dont have viruses. For some of the mods though you do need all 3 CoH Games, means the DLC CoH:Opposing Fronts
and CoH: Tales of Valor. Thanks again!
Last edited by XxREDxZON3xX; Mar 8, 2013 @ 3:02pm
< >
Showing 1-9 of 9 comments
SmokeHead Mar 8, 2013 @ 2:26pm 
Isn't the current version 2.602.0 and not 2.206?
..I have same version as my friends and have validated steam files for game couple times now
and yet it wont let me login.. doesn't give any errors or anything

Create account and Forgot password buttons are also gray and cant press them at any point.

Edit:
Didn't do anything... just now it started to work, didn't even boot the game :)
Last edited by SmokeHead; Mar 8, 2013 @ 2:32pm
XxREDxZON3xX Mar 8, 2013 @ 2:55pm 
Lol yes my bad meant 2.602 and ok sounds good should add me on relic servers!
@SmokeHead
Hawk Mar 8, 2013 @ 4:48pm 
My issue is only recently, up till now I've only run into a few problems but this keeps coming back. The game goes into windowed mode upon startup and I cannot force it to get to the corect resolution. It continually has a window popping up after it finishes loading (slower then every) that says Validating. It was fine this morning at 2AM yet Relic as always seems to mess with things somehow, why would I get CoH2 again?
Last edited by Hawk; Mar 8, 2013 @ 4:52pm
XxREDxZON3xX Mar 8, 2013 @ 4:54pm 
Ok so are you trying to run the game in window mode? or no? also if its a video graphics setting just set it to automatic and it should be fine unless, that is your pc shader isnt strong enough to run the game itself? Also, CoH2 is using a brand new engine that uses differnet specs, its a little bit stronger than the original CoH Engine. But to fix ur crashing issue as it seems to be you have to just play with the video setting and grapihcs just try to run the game on the lowest setting and tell me how it goes?
Hawk Mar 8, 2013 @ 9:49pm 
This is a recent and I mean within the past 2 days issue, it has NEVER been an issue, no I do not run my game in a windowed state it has always been full screen. The way I know it's going to run into problems is when it takes longer to load into the menu, then it pops up the small "Validating" window quickly then pops back in, then I can not get it back to my normal screen resolution after this happens regardless of how many times I try and change and revert back to the origional screen resolution. I couldn't care less about the "new engine" that COH2 is using the game has been out since what 08 or 09 and I'm still having issues that did not happen when I first got it about a half a year ago or so. It might even be the server issues that have been giving a few people problems, but that's the great thing about Relic and COH, a single player game that requires you to validate and sign in every time you open YOUR copy of the game.
Last edited by Hawk; Mar 8, 2013 @ 9:51pm
C= 64 Mar 8, 2013 @ 11:41pm 
It is their authentication servers, which is hosted by a 3rd party.

Need to goto relic facebook page and report it.

Info: From Relic's Facebook feed earlier today... "Heads up Company of Heroes players - we are making an unscheduled reboot of the multiplayer servers at this time."

Info: Forums down for maintenance

The Company of Heroes forums are currently down for maintenance. We'll have them back online shortly!

https://segaofamerica.zendesk.com/forums/21795391-Company-of-Heros
Last edited by C= 64; Mar 8, 2013 @ 11:46pm
XxREDxZON3xX Mar 9, 2013 @ 9:01am 
@Hawk;
if its with the server issues then i really can't help with that if it true with what the post above mine is saying, but i also notcied that even with the discbased game like i have the gold edition disc base game and whenever i load it up and have my internet on it wont log me in or anything, but if it is, it's usually the case of internet being 'GAY" or the "SEVERS" acting up. But for the validation, is it asking you to insert the Company of Heros disc or a validation code? Also when you say the load up to the main menu how it is slow and all, and then the error pops back up, have you tried to play without the internet on or wifi on? Cause before that's what i used to do before i wanted to actually play online with my friends. But if its asking you for the disc to insert or like a verification code at the main menu, if you had bought the game through steam your suppose to have a code given or emailed to you, or the steam/relic users shouldnt need a code if you had bought the complete set, but now if you had bought each of the gamse sepreatly then each one should have came with a code. Also you need thee MAIN CoH Game, you cant just purchase CoH: OF or CoH: ToV to play, those two were just DLC's to the game that came out over the period of time since it was first releasd. Also, the last thing to fix these validation errors or whatever is to contact them directly via phone, most fastest btw, or through the steam if you want idk if they can help you with it since RELIC is like one of the biggest holding servers next to all the FPS Shooter games out there. I also recommend to try and re-install the game itself, i know that feature does not come when you download off of steam cuz it doesnt give you disc errors it only goes off of a saved game os that you downloaded through them, but yes the final solution is to re-install the game. HOPE thIS helped, sorry if it doesn't work of any of these steps or anything. But again if you have any other questions concerning the game or anything about the MoDs for this game come ask me!
DEVGRU [TR] Jun 30, 2013 @ 9:48am 
Hi,

I hope this platform will solve the problem of my COH NOT STARTING.

I have a new laptop with win8/16 gig ram/Nvidia 670 MX 1.5 gig graph.card.

I ordered COH2 and installed it and the game works.

Tho I do not know what happened but COH doesnt start at all. Everytime I try the to start the game I get a crash-error report form jus like this: http://www.youtube.com/watch?v=I7VA248Mens


I validated game files, I unistalled/ re installed, then tried uninstalling one more time and installing from CD, then updating from Steam. What ever I do the game even do not start. I searched the same problems and someone said uninstalling a windows update 2670something works. But in my update folder I do not have that file at all. And some said rename spdx10.dll or something like that, I tried it but it still doesnt work.

Please Is there a solution for this?
Last edited by DEVGRU [TR]; Jun 30, 2013 @ 9:49am
Nando Jul 20, 2013 @ 5:16pm 
Go to My Documents/My Games/Company of Heroes Relaunch/playback and then delete the temp.rec file.

Do it every time you start the game.
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Mar 8, 2013 @ 2:09pm
Posts: 9