Secret of the Magic Crystal

Secret of the Magic Crystal

 This topic has been pinned, so it's probably important
ArteryGames  [developer] Oct 25, 2014 @ 1:09pm
Changelog v1.1.4 *REPORT BUGS HERE!*
New Features and Enhancements MAIN GAME:

+ Halloween decoration in various locations!

'The Race' DLC:

+ Completely new track 'Underwater Cave' to race on!

http://steamcommunity.com/sharedfiles/filedetails/?id=331742113

'Dress Up' DLC:

+ 17 new clothing items to dress up properly for Halloween !

http://steamcommunity.com/sharedfiles/filedetails/?id=331741451
Last edited by ArteryGames; Oct 25, 2014 @ 1:16pm
< >
Showing 1-15 of 36 comments
nico.public Dec 6, 2014 @ 10:12am 
Hi
Two things with my config.
I'm under Linux Ubuntu 14.10, 3 Go ram, AMD2+ 64 bits, GC with 1 Go memory
The first thing : impossible to download the demo, result is an empty directory :\ pb seems already be posted. So I bought the game without test.
The second : every time I go to the attic to care a horse, I have a problem with display. At the beginning, the game become very slow with wrong and after the result is a figed screen - at the better way, only the app freeze, at the worse, all the system
I try different window sizes and different display qualitys... each time I go in the attic, a screen/display problem happened :'(
Do you think I can fix it and how ?
thx
Last edited by nico.public; Dec 13, 2014 @ 2:03am
allonsyy Feb 10, 2015 @ 2:40pm 
I just got the game but I upgraded my stable and the arrow tabs still won't show up for me to go to the next stall and buy a colt.
lyrric Mar 1, 2015 @ 4:48pm 
Hi! Just bought this and can't get it to work. When the game opens (regardless of what window size or graphic option I choose) I get the splash screen of horses with music playing, then it changes to the window where I can choose my language but after about a second the whole screen turns green. If I'm really fast and click on a language the screen will change to the one that would let me start a new game, but then that one becomes a fully green screen after half a second. I can still hit shift-tab to access the Steam Community but the game itself is unresponsive. If I'm not playing in windowed mode then there's no way out of it other than to restart my machine. I had a similar problem with Shadowrun after they did an update in July but was able to resolve it by setting the Steam launch options to -windowed. That solution is having no effect here, however.

OS X 10.9.4
Processor: 2GHz Intel Core Duo
Memory: 2GB 1067 MHz DDR3
Graphics: NVIDIA GeForce 9400M 256MB

Anything else you need to know about my system?
Phoe May 29, 2015 @ 8:36am 
I cannot get the horse store to close, clicking close does nothing, but I can still browse the section I'm in. I guess I shouldn't have opened it while my horse was away on a quest.
ArteryGames  [developer] May 29, 2015 @ 12:12pm 
That indeed sounds like a bug. We'll investiage! Thanks for sharing.
ArteryGames  [developer] May 29, 2015 @ 12:14pm 
We've seen this issue before... that's the language selection screen. I think if you try fullscreen or windowed it works in one or the other. This is an engine issue which hopefully will be fixed for our coming update in the next 2 weeks. Sorry for the inconvenience.

Originally posted by Amaranta720:
Hi! Just bought this and can't get it to work. When the game opens (regardless of what window size or graphic option I choose) I get the splash screen of horses with music playing, then it changes to the window where I can choose my language but after about a second the whole screen turns green. If I'm really fast and click on a language the screen will change to the one that would let me start a new game, but then that one becomes a fully green screen after half a second. I can still hit shift-tab to access the Steam Community but the game itself is unresponsive. If I'm not playing in windowed mode then there's no way out of it other than to restart my machine. I had a similar problem with Shadowrun after they did an update in July but was able to resolve it by setting the Steam launch options to -windowed. That solution is having no effect here, however.

OS X 10.9.4
Processor: 2GHz Intel Core Duo
Memory: 2GB 1067 MHz DDR3
Graphics: NVIDIA GeForce 9400M 256MB

Anything else you need to know about my system?
Aurora Jun 21, 2015 @ 1:49pm 
When I go to the stable to see my new horse it invisible aka grey nothing is showing accept for when it grows up all you can see is the hair and horn. Please help asap
ArteryGames  [developer] Jun 26, 2015 @ 3:05pm 
Originally posted by Aurora:
When I go to the stable to see my new horse it invisible aka grey nothing is showing accept for when it grows up all you can see is the hair and horn. Please help asap

Hello, could you please share the OS and machine you are using (like desktop pc with win7/8 or macbook with OSX 10.10, etc). This would help us to reproduce the issue.

Also please try different quality settings when launching game, try fastest and fantastic to see if there is any difference.
m0ellemeister Jun 28, 2015 @ 2:56am 
I have problem with a savegame. After loading the savegame I get the message "horse came back from a mission" within a endless loop. When I send my horse to a mission I won't earn any money. After a couple of tries earning money my horse won't come back and i'll get messages about my horse being sick. The horse is gone and won't come back.

Do you need any more informations?

My System:
Linux x64
AMD FX-4100
16GB RAM
GeForce GTX 285 2GB VRAM
Thezie2000 Jul 4, 2015 @ 5:02pm 
Hi!
I have the same problem as Amaranta720..
My screen turns green, and the music is going.
I can´t do anything..
How can i fix it? please help.
ArteryGames  [developer] Jul 7, 2015 @ 4:43am 
Originally posted by m0ellemeister:
I have problem with a savegame. After loading the savegame I get the message "horse came back from a mission" within a endless loop. When I send my horse to a mission I won't earn any money. After a couple of tries earning money my horse won't come back and i'll get messages about my horse being sick. The horse is gone and won't come back.

Do you need any more informations?

My System:
Linux x64
AMD FX-4100
16GB RAM
GeForce GTX 285 2GB VRAM

This is an issue we haven't encountered yet. Must look into this. Sorry about it, we'll try to figure out what's going on.
ArteryGames  [developer] Jul 7, 2015 @ 4:44am 
Originally posted by Thezie2000:
Hi!
I have the same problem as Amaranta720..
My screen turns green, and the music is going.
I can´t do anything..
How can i fix it? please help.

This is an issue with Unity engine + Steam overlay. Try turning off Steam overlay. Other work arounds could be launching the game in windowed mode and setting quality to low or high (trying different settings). It mostly happens on dual GPU Macs as we see. Couldn't yet figure out what's causing but we could reproduce it on one of the machines at the office so hopefully we can fix it at last.
Thezie2000 Jul 8, 2015 @ 5:42pm 
Thanks! It works fine now.
EmergencyBattle Nov 27, 2015 @ 11:35am 
Hi, I just purchased the game but when I try to start it it just crashes immediately, with a message that it has created an crash data folder that I should send to the developer. Where can I send it, or is there already a known solution to this problem?
Thanks!
ArteryGames  [developer] Dec 1, 2015 @ 4:08am 
Originally posted by EmergencyBattle:
Hi, I just purchased the game but when I try to start it it just crashes immediately, with a message that it has created an crash data folder that I should send to the developer. Where can I send it, or is there already a known solution to this problem?
Thanks!

Could you share some information on the OS (win/osx and version number) and some basic machine specs ? For Mac it's enough if you know the machine (for example 2013 macbook pro 13) for PC basic hardware (cpu/gpu/ram).

It shouldn't crash like that. Also please try to launch from icon and from steam also to see if it crashed both way or not.

Thank you.
< >
Showing 1-15 of 36 comments
Per page: 15 30 50