Secret of the Magic Crystal

Secret of the Magic Crystal

Digresser Jul 27, 2014 @ 7:53pm
Bug: Can't leave the Race sometimes
After finishing (and losing, I think) single-player races on Seaside Circle, sometimes clicking "Leave" (from below the winning times) will result in the camera slowly traveling the racetrack and leaving the player with no option to end it. The only way to get out of this is to force the game to shut down and to then re-open it - losing all data since the last save. This has happened to me about 3 or 4 times out of 7-8 races.

Thank you.
< >
Showing 1-13 of 13 comments
Multi Jul 31, 2014 @ 7:23am 
What is your Operating System?
ArteryGames  [developer] Jul 31, 2014 @ 8:29am 
If this occurs when you press leave button SUPER QUICK in the race, then this has been fixed now in the new update coming in the next couple of days.
Was hard to reproduce but we managed to in some instances. :)
Digresser Jul 31, 2014 @ 8:12pm 
I'm on Windows 7. I'm not sure what "super quick" means, but I've counted to 2 and had it happen (after clicking the "leave" on the race select menu), but a count of 5 seems to prevent it. I'll wait to see if the update fixes it before testing it further. Thanks for letting me know you've looked into it.

Speaking of the update, I have a tiny request. Could you please consider changing "box" to "boxes" on the tip "If you need more box in the stable for your horses, you have to upgrade the well". That always bugs me when I see it. Thank you! :clover:
ArteryGames  [developer] Aug 1, 2014 @ 12:38am 
Speaking of the update, I have a tiny request. Could you please consider changing "box" to "boxes" on the tip "If you need more box in the stable for your horses, you have to upgrade the well". That always bugs me when I see it. Thank you! :clover: [/quote]

NOW Fixed ;) Thanks for the input.
Digresser Aug 1, 2014 @ 1:26am 
Thank you :)
Digresser Aug 2, 2014 @ 12:20pm 
I have a few more bugs and suggestions, but no worries at all if you choose not to do anything about some/all of them.

This has happened only once - I was training my level 3 Unicorn on the (fully upgraded) Sledge Pulling course and I was about halfway through when there was the sound like I'd gotten an arrow wrong (I hadn't) and then for the rest of the course no arrows appeared. It was just 10 seconds of the horse pulling with no right or wrong sounds. The grade at the end was a C, even though I hadn't missed any arrows that had been on screen. Again, this has only happened once, but it was odd. It was a winter weather track.

If I run my level 4 horse on the (fully upgraded) Forest Course in Autumn or Winter weather, the background graphics cut off at the end of the course. Here are some screenshots of this:
http://steamcommunity.com/sharedfiles/filedetails/?id=294984331
http://steamcommunity.com/sharedfiles/filedetails/?id=294984407

If you send a horse to compete in races but then click another location before the next horse has arrived on screen, the horse you sent away will still be your active horse (but clovers and potions will have been used). This will not happen when sending them on Errands.

"You can mix magic potions in the granary to cure your horse's illness" this tip is wrong in a few ways. You cure your horse in the Barn - there is no granary. To cure your horse you buy medicine; magic potions are used to temporarily enhance your horse's attributes.

"Once successfully forged a magic horseshoe, place it on your horse's hooves" should be "Once you've successfully forged a magic horseshoe, place it on your horse's hooves".

All of the Race achievements say they activate with "multiplayer races" but in fact trigger in single player mode. I'm guessing this was either worded to distinguish it from Gallop/Obstacle/Weight/Show Jumping/Steeplechase races or it's triggering when it isn't supposed to. Either way, the wording is very confusing. If it's about distinguishing it, maybe consider changing the wording to "third person races" or "races beyond the Gate" or something?

Finally, there's one tiny thing that I suspect is way too late to do anything about, but maybe this will be useful for Secret of the Magic Crystal 2 or something. Because it would make breeding overwhelming, the game is very careful to not assign the horses genders EXCEPT for when it comes to the baby horses, which it refers to as "colts". In actuality, baby horses are called foals (and then yearlings when they're old enough for proper training). A colt is a male horse under 4 years of age (and a filly is a female horse under 4 years old). Again, I know that wouldn't be something easy to change, but I figured I'd still let you guys know.

So...please don't hate me, and I meant it when I said I'd understand if these issues couldn't be addressed now or at a later date. Thanks for reading this. I'm looking forward to the patch!
Digresser Aug 2, 2014 @ 12:31pm 
Hmm...I guess I missed the patch? I don't recall seeing the game update and it isn't in my download history, which is odd.

Oh well. Next time.

EDIT: Checked Steam Database and there hasn't been an update. I understand that it's too late to change anything for this patch now, but I do find it odd that the change log was posted yesterday on the forums even though the update hasn't gone out yet. Certainly left me confused! :rainbow:
Last edited by Digresser; Aug 2, 2014 @ 12:36pm
Multi Aug 2, 2014 @ 11:24pm 
Update is out tomorrow, read the announcements :P

Sorry about the confusion. I found that Colt thing to be odd as well, but assumed it was due to male horses being work horses (Don't quote me on that little fact, I'm not even sure myself). I don't actually work on the title, so the help I can offer is limited, but check these issues again in 1-2 days when the patch is live.

And no one is going to hate, you're making the game better every post :D:
Digresser Aug 3, 2014 @ 12:24am 
I had read the changelog you'd posted on the forums which doesn't list a date and had then clicked "News" which didn't show anything. It didn't occur to me to check "Announcements" because no other game I play a lot has really used that feature on its own. Guess I will keep an eye on it from now on. Thank you.
ArteryGames  [developer] Aug 3, 2014 @ 3:04am 
Thank you for the all the observations and suggestions, We'll discuss it with the team and act accordingly. What is a bug/typo will get fixed (might even make it in 1.10.0), other will be considered for the future.
pmike2001 Jun 21, 2015 @ 8:25am 
This bug still present in Linux version (v1.1.4 I presume). I've all actual updates and still cannot leave race mode. It just loops forever over race track, no screen buttons, no hotkeys. My daughter is crying.
Tamasbako Jun 29, 2015 @ 7:35am 
Originally posted by pmike2001:
This bug still present in Linux version (v1.1.4 I presume). I've all actual updates and still cannot leave race mode. It just loops forever over race track, no screen buttons, no hotkeys. My daughter is crying.

We'll look into this asap! Perhaps also provide an alternative way to leave reace (pressing ESC or so).
LeetZero Jul 16, 2017 @ 6:17am 
Bug is still present for me.
< >
Showing 1-13 of 13 comments
Per page: 15 30 50