Watch_Dogs 2

Watch_Dogs 2

Watch_Dogs 2 > General Discussions > Topic Details
hal451 Nov 28, 2016 @ 10:46pm
Stuttering framerate when I move the camera.
This is very strange. The game seems to be fine until I move the camera and it completely freezes/stutters for a second. Tried lowering all settings to low and it's still doing it. It's running at over 100fps, but almost instantly freezes when I move the camera. Anyone else experiancing this?

I'm on the newest drivers from Nvidia. Specs are i7 4790k, 16gb, GTX 970, Win 10
< >
Showing 1-9 of 9 comments
Cats Nov 28, 2016 @ 10:57pm 
Not enough Vram, this Game needs 6+GB atleast, TAA also does half the resolution, to give a performance boost. Source: http://www.geforce.com/whats-new/guides/watch-dogs-2-graphics-and-performance-guide
Last edited by Cats; Nov 28, 2016 @ 10:59pm
hal451 Nov 29, 2016 @ 12:35am 
Originally posted by Cats:
Not enough Vram, this Game needs 6+GB atleast, TAA also does half the resolution, to give a performance boost. Source: http://www.geforce.com/whats-new/guides/watch-dogs-2-graphics-and-performance-guide

Even with everything on low? That doesn't make any sense.
Cats Nov 29, 2016 @ 12:44am 
Originally posted by Lord of War:
Originally posted by Cats:
Not enough Vram, this Game needs 6+GB atleast, TAA also does half the resolution, to give a performance boost. Source: http://www.geforce.com/whats-new/guides/watch-dogs-2-graphics-and-performance-guide

Even with everything on low? That doesn't make any sense.
Oh, everything low? i thought the Vram may be the culprit on your end, sorry :/
hal451 Nov 29, 2016 @ 12:48am 
I have no idea what's wrong... vsync seems to be broken. I'm getting over 100 fps with vsync on, but as soon as I start moving the camera, it just freezes. Gonna just try and reinstall I guess.
Stets Nov 29, 2016 @ 12:46pm 
The same problem:(
razzgrizz3 Nov 29, 2016 @ 3:43pm 
i found a weird work around for this problem.
get fraps so u can monitor fps
get nvidia inspector and turn on fps limiter to 60
put the game into windowed borderless
now if your fraps counter is going wildly between 59 and 60 which is what causes the camera stuter try this thing which is how i fixed it on my system

pause game go into options so fps gets locked to 60
go to inspector
set fps limiter to off (do not close inspector windows)
get back into get the game
if your fps is not fluctuating anymore it has worked if not

pause game again
go to inspector set fps limiter to 60 this time
get back into game.

going back between these two steps gave me 0 stuters altho the fix would activate itself randomly between fps limiter set to off or 60 so not sure what causes it to lock to a perfect 60...


running on gtx980ti with 0 stuters now save for fps drops when game is loading in assets or when im leaving hack-vision i get i minor 15 fps drop for whatever reason
Last edited by razzgrizz3; Nov 29, 2016 @ 3:50pm
Strafeness Nov 30, 2016 @ 11:27am 
Got the same problem on A 6700K and a Titen X Pascal.
Drowning witch Nov 30, 2016 @ 11:29am 
Originally posted by Lord of War:
This is very strange. The game seems to be fine until I move the camera and it completely freezes/stutters for a second. Tried lowering all settings to low and it's still doing it. It's running at over 100fps, but almost instantly freezes when I move the camera. Anyone else experiancing this?

I'm on the newest drivers from Nvidia. Specs are i7 4790k, 16gb, GTX 970, Win 10

HDD or SSD? you should not be getting any stuttering on that rig mine is similar, but i have an i5. no stutters.

https://www.youtube.com/watch?v=_n22baEKABo

https://www.youtube.com/watch?v=nhINWhDYaRY
Snake Plissken Nov 30, 2016 @ 11:32am 
Originally posted by Drowning witch:
Originally posted by Lord of War:
This is very strange. The game seems to be fine until I move the camera and it completely freezes/stutters for a second. Tried lowering all settings to low and it's still doing it. It's running at over 100fps, but almost instantly freezes when I move the camera. Anyone else experiancing this?

I'm on the newest drivers from Nvidia. Specs are i7 4790k, 16gb, GTX 970, Win 10

HDD or SSD? you should not be getting any stuttering on that rig mine is similar, but i have an i5. no stutters.

https://www.youtube.com/watch?v=_n22baEKABo

https://www.youtube.com/watch?v=nhINWhDYaRY

Yeah it's the frequency of your RAM that fixed the problem right?
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Watch_Dogs 2 > General Discussions > Topic Details
Date Posted: Nov 28, 2016 @ 10:46pm
Posts: 9