View Stats:
Paladins > Help & Support > Topic Details
Caelus Nov 5, 2016 @ 5:48pm
HirezProxyLaunch has stopped working??
Every time I try to launch Paladins, I face an immediate error popup saying "HirezProxyLaunch has stopped working", with subtext saying the usual "Windows is checking for a solution to the problem..." just for the popup to close out on its own with no actual solution found or suggested.

I looked this problem up online and saw people in the Smite forums on here having a similar issue with a suggested solution:
1. Go to Library on Steam and right-click on "Paladins"
2. Click "Properties" at the bottom of the popup selection
3. Go to the "Local Files" tab and select "Browse local files"
4. Your PC’s folders for Paladins will open. Click the folder that says “Binaries”
5. Within the Binaries folder, click the “Redist” folder
6. See “InstallHirezService”? Click that. If Hirez is already installed, select to uninstall the
application, then repeat steps 1-5 to reinstall it.

However, this hasn't worked for me. It was a somewhat time-consuming process and got me right back to the error popup. My laptop is totally up-to-date with Windows and other than this one solution, I"m stuck on knowing what to do (not exactly the most tech-savvy person around town if you know what I'm sayin).

Has anyone else had this error or at least know of a different way to try and fix it? I'd like to try the game out, but I can't even get it to launch.
< >
Showing 1-2 of 2 comments
Hi, could you fixed it?
not helping me
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Paladins > Help & Support > Topic Details
Date Posted: Nov 5, 2016 @ 5:48pm
Posts: 2