S2ENGINE HD

S2ENGINE HD

Freiin Nov 18, 2016 @ 7:49am
Physx Problem [SOLVED]
My S2 since i've installed W10 doesn't run.

It appears an error. Uninstall physx version and install 9.10.0513.

I tried everything! I rebooted my PC several times.

It doesn't work.

Can someone help me?
Last edited by Freiin; Nov 29, 2016 @ 8:00am
< >
Showing 1-15 of 53 comments
Freiin Nov 18, 2016 @ 7:51am 
I know there is another topic. But people has the problem and dev doesn't reply them. I'm creating this new because i have a big project on s2 and i cannot run it.

:/
Last edited by Freiin; Nov 18, 2016 @ 7:51am
Bugbuster77  [developer] Nov 18, 2016 @ 1:11pm 
Explain me. Before you had installed win7 and s2 worked, now u have installed Win10 and there is problem with physx. Right?
Bugbuster77  [developer] Nov 18, 2016 @ 1:19pm 
I think your is a problem like this: http://windowsreport.com/mafia-2-problems-windows-10/
Bugbuster77  [developer] Nov 18, 2016 @ 1:47pm 
what it says: "Cannot Initialize Physics" or "Cannot Find Physx dll"?
Bugbuster77  [developer] Nov 18, 2016 @ 1:48pm 
if "Cannot Find Physx dll" so there could be a permission problem, have you tried to run it as Administrator?
Bugbuster77  [developer] Nov 18, 2016 @ 3:49pm 
Just for knowing: It is not striclty necessary to install drivers 9.10.0513, for example I've a PC with Physx 9.14.0702 drivers and s2 works perfectly. So try also newer drivers, It should help
Freiin Nov 18, 2016 @ 5:22pm 
Originally posted by Bugbuster77:
Just for knowing: It is not striclty necessary to install drivers 9.10.0513, for example I've a PC with Physx 9.14.0702 drivers and s2 works perfectly. So try also newer drivers, It should help

It says cannot find s2physxphisics.dll and tell me to install a previous version of physix and reboot before launch s2.

i tried the newest, the previous, rebooted everytime. doesn't work.

when i set s2launcher or s2editor as admin, it asks for give admin permission in a loop. and s2 doesn't starts. I gave full control to s2launcher and editor. it doesn't work.

i tried to run in compatibility mode. doesn't work.

I tried everything on this website about mafia2. Doesn't work.

is there any other type ? could you make a fix to run as admin?


thanks
Last edited by Freiin; Nov 18, 2016 @ 5:24pm
Bugbuster77  [developer] Nov 19, 2016 @ 6:06am 
"when i set s2launcher or s2editor as admin, it asks for give admin permission in a loop. and s2 doesn't starts". Maybe you have to change OS admin settings
Freiin Nov 19, 2016 @ 7:20am 
Originally posted by Bugbuster77:
"when i set s2launcher or s2editor as admin, it asks for give admin permission in a loop. and s2 doesn't starts". Maybe you have to change OS admin settings

no. i've checked.

when i said "when i set s2launcher or s2editor as admin, it asks for give admin permission in a loop. and s2 doesn't starts"

what i mean is: i gave admin permission , i try to open through steam, s2launcher open, s2editor asks "open as admin?", i said yes, it closes, and try to open s2 launcher again, s2 editor again (asks for open as admin again) i said yes, it closes and try to reopen.

Freiin Nov 19, 2016 @ 7:22am 
i tried everything. i checked every config. doesn't work.

any other advice ? i installed physx legacy too, doesn't work.

i'm giving up.
Bugbuster77  [developer] Nov 19, 2016 @ 7:46am 
post the s2engine.html log file
Freiin Nov 19, 2016 @ 8:02am 
Originally posted by Bugbuster77:
post the s2engine.html log file


http://pastebin.com/j2w9Qh7u (paste)

https://www.sendspace.com/file/6luyj2 (file)
Freiin Nov 19, 2016 @ 12:34pm 
Originally posted by Bugbuster77:
post the s2engine.html log file

There is alot of redlines and leaks. I think that is the problem
Freiin Nov 21, 2016 @ 7:39am 
i sent to you an email. please, check it out.
Bugbuster77  [developer] Nov 23, 2016 @ 1:08am 
I'm following a way to solve definitely the problem. But I need some help by you. Please search for Microsoft Visual Studio 2010 runtimes and install them. Then try s2 and let me know
< >
Showing 1-15 of 53 comments
Per page: 1530 50