Conan Exiles

Conan Exiles

View Stats:
Conan Exiles > General Discussions > Topic Details
Dedsixx Feb 8, 2017 @ 1:31pm
[Conan Exile]Dedicated Server Error
(First Error)
link of printscreen - http://imgur.com/a/0Z0ut

ERROR=(the procedure entry point ?IsAlive@CThread@@QEBA_NXZ could not be located in the dynamic link library C:Program Files (x86)\Steam\steamclient64.dll)

What we know so far about the first error
-If start the server before the steam client the error doesn't appear
------------------------------------
(Second Error)

ERROR= the server doesn't appear on the server list even with the ports open (27015,27016,7777,7778) both in the firewall and the router

What we know so far about the second error
-Nothing
------------------------------------
that's all, folks



Last edited by Dedsixx; Feb 10, 2017 @ 7:11am
< >
Showing 1-15 of 16 comments
Doublee (EE) Feb 8, 2017 @ 1:41pm 
I'd update your server files because it looks like your missing a file. Revalidate the files.
Dedsixx Feb 8, 2017 @ 2:01pm 
Originally posted by Doublee313:
I'd update your server files because it looks like your missing a file. Revalidate the files.
I already updated and validated, but it did not work
Dedsixx Feb 8, 2017 @ 2:03pm 
Originally posted by Doublee313:
I'd update your server files because it looks like your missing a file. Revalidate the files.
i used this two codes "app_update 443030" "app_update 443030 validate"
Doublee (EE) Feb 8, 2017 @ 7:45pm 
Here you go. I found this on Steams Unreal troubleshooting:

Windows Dedicated Server Steam Fix

This workaround is fairly simple. To get a Windows dedicated server to properly load Steam, you need to place a copy of all the files within your Engine\Binaries\ThirdParty\Steamworks\Steamv132\Win64 folder into your Project’s Binaries\Win64 folder such as that these files are side-by-side with ProjectServer.exe.

http://allarsblog.com/images/blog/steamguide/basic/WinServerFix.png

^^^ See pic.
Dedsixx Feb 9, 2017 @ 5:20am 
Originally posted by Doublee313:
Here you go. I found this on Steams Unreal troubleshooting:

Windows Dedicated Server Steam Fix

This workaround is fairly simple. To get a Windows dedicated server to properly load Steam, you need to place a copy of all the files within your Engine\Binaries\ThirdParty\Steamworks\Steamv132\Win64 folder into your Project’s Binaries\Win64 folder such as that these files are side-by-side with ProjectServer.exe.

http://allarsblog.com/images/blog/steamguide/basic/WinServerFix.png

^^^ See pic.
okay i did

copy dll from here - http://imgur.com/a/4qDwp

and put here - http://imgur.com/a/0WvXY


and the error keeps Appearing
Doublee (EE) Feb 9, 2017 @ 3:03pm 
Copy it here: :Program Files (x86)\Steam\steamclient64.dll.

That's what your error log says
Doublee (EE) Feb 9, 2017 @ 3:04pm 
Post your Startserver.cmd config
Dedsixx Feb 9, 2017 @ 4:15pm 
Originally posted by Doublee313:
Post your Startserver.cmd config
this error just appear when i start the server with the steam client open when i start with the steam client closed this error doesn't appear
Last edited by Dedsixx; Feb 9, 2017 @ 4:16pm
Doublee (EE) Feb 9, 2017 @ 5:17pm 
Originally posted by Biewwwl:
Originally posted by Doublee313:
Post your Startserver.cmd config
this error just appear when i start the server with the steam client open when i start with the steam client closed this error doesn't appear
Send your StartServer.cmd for the 2nd time. It will be easier to see. You probably need to add -nosteamclient to your command startup.

Here's mine:
start "" /NORMAL "D:\Servers\Conan\ConanSandboxServer.exe" "ConanSandbox?listen?" -nosteamclient -game -server -log
Last edited by Doublee (EE); Feb 9, 2017 @ 5:17pm
Dedsixx Feb 10, 2017 @ 6:40am 
Originally posted by Doublee313:
Originally posted by Biewwwl:
this error just appear when i start the server with the steam client open when i start with the steam client closed this error doesn't appear
Send your StartServer.cmd for the 2nd time. It will be easier to see. You probably need to add -nosteamclient to your command startup.

Here's mine:
start "" /NORMAL "D:\Servers\Conan\ConanSandboxServer.exe" "ConanSandbox?listen?" -nosteamclient -game -server -log

mine start.bat - start ConanSandboxServer.exe -log -MULTIHOME=192.168.1.X -QueryPort=27016

(i just put an X there to private but i know its my ipv4)

i just follow this steps http://steamcommunity.com/sharedfiles/filedetails/?id=853969975 to create the server

and now im with another problem my sever doesn't appear on the list and the ports 27015,27016,7777,7778 all UDP is open but my server doesn't appear there anyway
Last edited by Dedsixx; Feb 10, 2017 @ 6:47am
Dedsixx Feb 10, 2017 @ 6:52am 
To avoid the first error is needed start the server before opening the steam !
[US] Mr. Mom Feb 10, 2017 @ 6:56am 
Check out my post about a possible fix.
For me it worked after I started Steam as Admin
Chris_D_Turk Mar 30, 2018 @ 3:30am 
Originally posted by Clopaper:
For me it worked after I started Steam as Admin
This worked for me also.
Riggs Apr 19, 2018 @ 7:25am 
So, did it work for him lol Worked for me.
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Conan Exiles > General Discussions > Topic Details
Date Posted: Feb 8, 2017 @ 1:31pm
Posts: 16