Conan Exiles

Conan Exiles

Statistiken ansehen:
Kibbelz 5. Feb. 2017 um 22:33 Uhr
Various objects disappearing after latest patch (With notes!)
Good Evening,

A lot of servers were hit with a massive bug that wiped out everyone's boxes, furnaces and the likes with the most recent patch. I've been trying to troubleshoot the issue as myself and my server community do not wish to proceed with a full wipe. Here's everything we've attempted.

1 - We've rolled back to several different database backups, all have the same issue. This leads to believe that the missing objects are being removed at server start.

2 - We noticed that any new objects placed, were disappearing on reboot, which means that either they were not being saved to the database, or being removed at server start.

3 - I created a new server by downloading the server files fresh using SteamCMD. From there we launched the server to have it create a fresh database. With the fresh database and fresh game files, we were able to log in, make characters, create a wooden box, store items in it, and reboot the server successfully without the box disappearing. This proves, that a fresh wipe will resolve the disappearing acts.

4 - I noticed while browsing the Steam Discussions that FunCom release a database file checker to make sure none of the databases were corrupted. Upon running this, all of my database backups reported "OK".

4 - Now knowing that the fresh server was working, I exported the original game.db to an SQL file for importing. I removed the "Create Table" sections of the script leaving just the INSERT statements. I then ran the SQL script against the new fresh database successfully. Upon logging into the server, I was able to successfully verify character data (attributes and feats) as well as inventory. However, upon creating a box and rebooting the server, the box continues to disappear. This leads us to believe that there is an issue with the way the game code is reading the database information.

I tried to do some research on the code changes between SQLLite 3.9.2 and 3.16.2 but there is just too many, there is no telling if jumping that many revisions broke the way the game code reads the database, or if the new "corruption detection" is what is causing the issues.

Anyone else have any insight or things they have tried in resolving this issue? We would like to avoid a full wipe if possible.


Also here are some fresh logs: https://hastebin.com/cuyezovobo.md
Zuletzt bearbeitet von Kibbelz; 5. Feb. 2017 um 22:39 Uhr
< >
Beiträge 11 von 1
123 6. Feb. 2017 um 5:54 Uhr 
Interesting thing I observed. We recently merged with a similar sized clan, their building became "Unowned" when everyone left the clan. All their old boxes are still in the building, even the ones outside are still sitting there. Must be some kind of connection.
< >
Beiträge 11 von 1
Pro Seite: 15 30 50

Geschrieben am: 5. Feb. 2017 um 22:33 Uhr
Beiträge: 1