Team Fortress 2
Team Fortress 2 > Virtual Reality > Подробности темы
vr_configuration does nothing
I'm attempting to follow the instructions to get my TF2 to work with my Oculus rift. I've added "-vr" to the launch command line, and it splits the screen in half when I start a game. However not in the 2 fish-eye views that are expected with the Oculus. The "vr_configuration" command appears as an option in the console but typing it in while on the main menu does nothing. The console also does not appear to recognize many of the convars listed on the user guide.

Is there a step I am missing?
< >
Сообщения 115 из 21
I'm having the same issue.

Bob, are you on a Mac?
I'm on a PC. It might also be worth mentioning I've tried both the standard and beta versions of TF2
Same problem here, vr_calibration does nothing and all the vr console variables don't seem to exist. Trying to play a game anyways does show 2 views, but they are not lens-warped and I can't get the image to converge...
Heya 320 -- nice to see a fellow OVR forum member. I have not seen this issue testing on 3 different Windows 7 x64 machines (ATI and NVIDIA).

Someone on those forums mentioned having the same problem. Not sure if this would work but I remember at some point some people had problems with the Rift being recognized and needed to restart their machines for it to be detected in game or via SDK, etc.

Have you tried to restart with the Rift connected and/or just restarted and then plugged in the Rift and go straight to TF2 in -vr mode?
Same problem here. The Rift is working fine for the SDK examples, but TF2 with the -vr switch doesn't work correctly. TF2, when connected to server, shows split screens with improper distortion. Additionally the first couple screen for selecting a team and character are different, not the same screen duplicated on the split. So selecting buttons on the right side of the screen takes some clicking around to find them. Attempting to run the vr_calibration does nothing.

I've just installed the Rift.
I hadn't played TF2 in a while, so it just updated and did its conversion deal.
I have restarted the computer and disconnected the Rift then reconnected.
I'm on Windows 7 54-bit with an Nvidia GTX545. Rift is the main display through HDMI and is duplicated onto my Cinema display through DVI.
Doesn't work for me either. My Oculus Rift just arrived today and really wanted to try TF2.

Oh well, but please get it working ASAP Valve!
I've got the same problem. I've cloned my primary display to the rift so I can get through the menus but besides cutting the screen in half nothing else works including calibration.
Mine's not even split screening when I run it
VR mode broke in yesterday's update. We are working on a fix.
Aww, it was working for me yesterday too. Just came here to figure out why it wouldn't work. Well, that was a fun hour yesterday at least.
We have a fix. There were just some VR-related files missing after the Steam Pipe update yesterday.

The fill will be rolled out to everyone soon, but if you want to play in VR before that just open the Steam properties for TF2 and pick "prerelease" from the Beta tab. The pre-release build has the fix.
fantastic, thanks for the rapid fix. got to play about 1 hour before the update stopped it from working - although now I'm having difficulty getting it recognized at all by steam (won't split screen)
sorry double post - worked like a charm!
Nice work Joe! Now roll out that stereo rendering, warping and IPD configuration goodness for Half-Life 2! ;)
< >
Сообщения 115 из 21
Показывать на странице: 15 30 50

Team Fortress 2 > Virtual Reality > Подробности темы
Дата создания: 30 апр. 2013 в 19:12
Сообщений: 21