Team Fortress 2
Setup file 'gameinfo.txt' doesn't exist in "subdirectory c:\program files\steam\steamapps\shark4675\team fortress 2\tf"
How the hell do I use SDK? I have no idea how to fix this error its kinda ♥♥♥♥ing me off I just want to make a custom map for TF2 now I wasted 2 freaking GB of memory....for some broken softwear............I also tried making an empty .txt and it din't work

Major Edit here I've found an answer to the problem its at the bottom but also going to add it to the main post.
Sorry if this is necroing but I should properly expain how to fix the problem
C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\Hammer.bat
Thats the first file you need to run to install everything properly then you create a shortcut for hammer.exe and you run the shortcut so you dont have to find the file everytime you want to run hammer.exe sorry I havent expained this to everyone just going to clear things up.

Change the file path based on what game your playing it should always be in the bin folder I believe.
Last edited by Your Majesty Padded Gamer; Aug 20, 2014 @ 2:11pm
< >
Showing 1-15 of 35 comments
Handsome Jack Here Jun 10, 2013 @ 10:09pm 
Where have you been?
Originally posted by WDZ xoSushi:
Where have you been?
What do you mean where have I been? I thought you just install source SDK and that's it for the installing part right?
Am I going to get any answers I really would like some help...
n00b3rpwn4g3 Jun 27, 2013 @ 7:43am 
I had a similar problem, which I think was caused by my brothers playing TF2 on the same computer as I use. When multiple users play the same game on steam, the computer stores all the game files in a folder called "common" instead of under the folder named after your username (the folder "shark4675").
To fix this, start up Source SDK, then under the "utilities" header double-click "edit game configurations". Then select Team Fortress 2 in the drop-down menu. Then hit the edit button on the bottom left, and then in the Directory part change "shark4675" to "common" (don't change anything else). Finally hit all the ok buttons to save it and start an SDK application like Hammer editor.
If something goes wrong, you can click "reset game configurations" from the utilites and try again.
hopefully this helped.
Originally posted by n00b3rpwn4g3 t3h 1337 4nd sw347y:
I had a similar problem, which I think was caused by my brothers playing TF2 on the same computer as I use. When multiple users play the same game on steam, the computer stores all the game files in a folder called "common" instead of under the folder named after your username (the folder "shark4675").
To fix this, start up Source SDK, then under the "utilities" header double-click "edit game configurations". Then select Team Fortress 2 in the drop-down menu. Then hit the edit button on the bottom left, and then in the Directory part change "shark4675" to "common" (don't change anything else). Finally hit all the ok buttons to save it and start an SDK application like Hammer editor.
If something goes wrong, you can click "reset game configurations" from the utilites and try again.
hopefully this helped.
Thank you for your help I have no idea why it's doing this as I've never used another account on this computer before but I'll try this
Kevin Minion Jul 20, 2013 @ 8:11am 
Here's what I did to fix this issue:
I had set up my steamlibrary folder in a directory that was not the default on my E:\ drive. I launched Source SDK and under UTILITIES, selected Edit Game Configurations, Choose TF2, Edit...
and then used the Browse... to select my folder.

Hope this helps!
Kevin Minion Jul 20, 2013 @ 8:12am 
Oh well, Hammer Editor opened, but then crashed. I guess I haven't fixed it.
TheLocalPub Jul 20, 2013 @ 2:47pm 
Go to Utilities>Edit Game Configurations>*Insert Game*>Edit.

Now here are the paths for the games.

css: C:\Program Files (x86)\Steam\SteamApps\common\Counter-Strike Source
hl2: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2
ep1: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2\ep1
ep2: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2\ep2
tf2: C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2

Hope this helps
Originally posted by Forrest Gump:
Go to Utilities>Edit Game Configurations>*Insert Game*>Edit.

Now here are the paths for the games.

css: C:\Program Files (x86)\Steam\SteamApps\common\Counter-Strike Source
hl2: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2
ep1: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2\ep1
ep2: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2\ep2
tf2: C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2

Hope this helps
Thanks! Guess I'll try those paths and see if it works
Gale Aug 22, 2013 @ 11:56am 
It works. it'd be ever better if valve TOLD US THIS♥♥♥♥♥♥ That would be pretty cool...like...a wiki that is useful?
TheLocalPub Aug 22, 2013 @ 9:51pm 
I should maybe update a wiki about this. And add the correct♥♥♥♥♥♥for once.
I gotta admit steam does almost ♥♥♥♥ all to help you with problems most of the time it's the same old ♥♥♥♥♥♥♥t about everything "sorry we dont support 3rd partys"
Last edited by TheLocalPub; Aug 22, 2013 @ 9:52pm
^Nano Sep 22, 2013 @ 2:08pm 
I am having issues nice I have moved my steam folder to another harddrive. I can get the csgo sdk to work but nothing else. my path file is, D:\steam\SteamApps\common\Counter-Strike Source and im getting the same error as the OP.

I have tried all the different paths. Engine version - Source engine MP, Current Game - CSS.

Setup file gameinfo txt doesn't exist in subdirectory d:\steam\steamapps\common\counter-strike source. check your -game parameter or VCONFIG setting.

Do I need to put something in the launch options for SDK? Thanks!
Cheesellama Sep 22, 2013 @ 2:35pm 
Originally posted by N a n o ":
I am having issues nice I have moved my steam folder to another harddrive. I can get the csgo sdk to work but nothing else. my path file is, D:\steam\SteamApps\common\Counter-Strike Source and im getting the same error as the OP.

I have tried all the different paths. Engine version - Source engine MP, Current Game - CSS.

Setup file gameinfo txt doesn't exist in subdirectory d:\steam\steamapps\common\counter-strike source. check your -game parameter or VCONFIG setting.

Do I need to put something in the launch options for SDK? Thanks!

^Same as this guy.
Sorry if this is necroing but I should properly expain how to fix the problem
C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\Hammer.bat
Thats the first file you need to run to install everything properly then you create a shortcut for hammer.exe and you run the shortcut so you dont have to find the file everytime you want to run hammer.exe sorry I havent expained this to everyone just going to clear things up.

Change the file path based on what game your playing it should always be in the bin folder I believe.
Last edited by Your Majesty Padded Gamer; Aug 20, 2014 @ 2:09pm
Anonymous Jul 3, 2015 @ 9:30pm 
Originally posted by Forrest Gump:
Go to Utilities>Edit Game Configurations>*Insert Game*>Edit.

Now here are the paths for the games.

css: C:\Program Files (x86)\Steam\SteamApps\common\Counter-Strike Source
hl2: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2
ep1: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2\ep1
ep2: C:\Program Files (x86)\Steam\SteamApps\common\Half-Life 2\ep2
tf2: C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2

Hope this helps
C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2 then what i do? pls
< >
Showing 1-15 of 35 comments
Per page: 15 30 50

Date Posted: Jun 10, 2013 @ 9:52pm
Posts: 35