Team Fortress 2
Sporto Jan 30, 2013 @ 6:38am
linux: mouse won't turn my POV, but the mouse is active in the options menu
xubuntu 12.04,
radeon HD 5xxxx GC
latest experimental amd/ati driver

the mouse will do everything except look around/aim.

i've tried several settings from the options menu (raw input, messing with acceleration and sensitivity), but with no joy.

has anyone seen this before?
< >
Showing 1-5 of 5 comments
Frogmorton Feb 25, 2013 @ 12:55am 
Did you resolve this? I have the same problem and cannot find much discussion of such issues.
Mouse buttons and wheel are active but there is no mouse look movement at all. If I hit Y or U to open discussion panels the mouse cursor appears and moves around. Tried raw input on and off, switch all the options in the game setup, still no mouse movement.

Ubuntu 12.04 64 bit, 8600GT with NVidia post-release (current-updates) verion.
Last edited by Frogmorton; Feb 25, 2013 @ 12:58am
Sporto Feb 26, 2013 @ 7:14am 
yes, i installed the latest (beta) video driver from the manufacters website and marked everything thing steam for reinstallation via synaptic pakage manager. that cleared the mouse issue up. unrelated, i trying to figure out this steam partial upgrade error i'm having lol. idk whether to go steam:i386 or steam-laucher. i can't have both appearently.
Long Ago [Linux] Feb 26, 2013 @ 11:27am 
Update Manager just said it was going to install steam-launcher:i386, but apparently updated steam:i386. I have been running a few weeks since late Steam beta. I posted this from steam.

Start-Date: 2013-02-26 12:54:56
Commandline: aptdaemon role='role-commit-packages' sender=':1.152'
Upgrade: libpurple0:amd64 (2.10.3-0ubuntu1.2, 2.10.3-0ubuntu1.3), libpurple-bin:amd64 (2.10.3-0ubuntu1.2, 2.10.3-0ubuntu1.3), thunderbird-locale-en-us:amd64 (17.0.2+build1-0ubuntu0.12.04.1, 17.0.3+build1-0ubuntu0.12.04.1), thunderbird:amd64 (17.0.2+build1-0ubuntu0.12.04.1, 17.0.3+build1-0ubuntu0.12.04.1), transmission-gtk:amd64 (2.51-0ubuntu1.2, 2.51-0ubuntu1.3), transmission-common:amd64 (2.51-0ubuntu1.2, 2.51-0ubuntu1.3), steam:i386 (,, unity-greeter:amd64 (0.2.9-0ubuntu1, 0.2.9-0ubuntu1.1), thunderbird-globalmenu:amd64 (17.0.2+build1-0ubuntu0.12.04.1, 17.0.3+build1-0ubuntu0.12.04.1), thunderbird-gnome-support:amd64 (17.0.2+build1-0ubuntu0.12.04.1, 17.0.3+build1-0ubuntu0.12.04.1), thunderbird-locale-en:amd64 (17.0.2+build1-0ubuntu0.12.04.1, 17.0.3+build1-0ubuntu0.12.04.1)
End-Date: 2013-02-26 12:55:20

64-bit Ubuntu 12.04, GTX 550 Ti w/experimental nvidia drivers (310.14). Not sure if steam:i386 and steam-launcher:i386 are mutually exclusive, or if there is a 64-bit Linux steam yet. "apt-cache search steam" recently showed "steam" and "steam64", but now lists "steam" and "steam-laucher" (no "steam64"). "dpkg-query -l steam" shows steam as not installed and does not list "steam-launcher". All a bit confusing, since steam runs.
Frogmorton Feb 26, 2013 @ 10:45pm 
Yes my last update on ubuntu confused me a bit with all the steam related things it wanted to remove, but I left it go ahead and it sorted itself out.
Also I updated the graphics driver - found it doesn't work with my oldish nvidia card - reverted back to previous (current) driver - mouse now working ok, problem solved.
eascann Jul 25, 2017 @ 2:50pm 
I've got this mouse problem too. The camera view won't move in TF2. I've tried other mice - same problem. I've tried both AMD and NVIDIA graphics, and even Intel integrated graphics. I came across a mouse problem in Dota before, but otherwise Team Fortress 2 is the only game with this problem.
Operating system - bog standard Ubuntu 16.04.02 - I reinstalled it, to no avail.
Intel G4560, AMD RX460 or NVIDIA GT1050, 8GB DDR4.
I give up on this game!
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Jan 30, 2013 @ 6:38am
Posts: 5