Team Fortress 2
Black screen: Ubuntu / Linux
I was going to play TF2 today. I open Steam, and see there is an update for TF2. It didn't come to my attention when I realized that my screen was black. I tried uninstalling my drivers and reinstalling them. I've tried uninstalling and reinstalling TF2. Those didn't work. I've tried just about everything I can think of. My theory is that some of the files for Linux may be corrupted. I need help supporting my theory if you too use Linux Ubuntu, and have the same problem. This will draw out my problem as an individual problem and press it more towards as an operating system problem.
Last edited by ((((KA-BOOM)))); Oct 2, 2014 @ 9:16pm
< >
Showing 1-15 of 161 comments
some noob Oct 1, 2014 @ 8:55pm 
Me too. And this guy too; https://steamcommunity.com/app/440/discussions/0/616189742701871392/

We're all using the AMD drivers. My friend who has an Nvidia card is playing TF2 right now on his Ubuntu machine in the other room.
((((KA-BOOM)))) Oct 1, 2014 @ 8:57pm 
It may be a problem with AMD drivers.
pontiffx Oct 2, 2014 @ 8:46pm 
Ubuntu 14.04 fglrx drivers for radeon, same problem
((((KA-BOOM)))) Oct 2, 2014 @ 8:53pm 
Originally posted by pontiffx:
Ubuntu 14.04 fglrx drivers for radeon, same problem
If we can get more Linux users reporting the same problem with fglrx drivers for AMD Radeon, then we can conclude that there is a problem on Linux. If you know other linux users, tell them about it. We need at least ten to twenty instances of this happening due to the latest update, so it can be proven that TF2 graphics do not run on AMD Radeon cards.
(THF)dunnomattic Oct 2, 2014 @ 9:07pm 
Ubuntu 14.04.1 LTS, AMD card, same problem

Radeon HD 5770, stock repository fglrx version 2:13.350.1-0ubuntu2

I may be a bit behind on updates, will do a full-upgrade and try again.
((((KA-BOOM)))) Oct 2, 2014 @ 9:13pm 
So far I have recorded ten users with the same problem. I think we can assume there is a problem with Linux.
I'm having this problem too under Fedora 19 64 bit. Running a Radeon R9 290 with the proprietary 14.9 drivers. Even tried a rollback but no go.
ʳᵒᶜᵏ Oct 3, 2014 @ 12:59am 
Ubuntu 12.04 LTS with nvidia geforce gtx760Ti still boots to black screen ..its not just AMD
Last edited by ʳᵒᶜᵏ; Oct 3, 2014 @ 1:00am
Gery Oct 3, 2014 @ 4:46am 
Same here on R9 290 + fglrx 14.9, however it's also pretty much broken on my Nvidia Optimus laptop (only seeing lights there, everything else is black)
spr1n Oct 3, 2014 @ 5:14am 
Its not problem with Linux nor drivers. Same issue appears in other distros with that update, and TF2 version rollback works just fine (apart from version conflict with servers). Its just broken update, wait for the next one to fix this.
((((KA-BOOM)))) Oct 3, 2014 @ 5:32am 
Originally posted by spr1n:
Its not problem with Linux nor drivers. Same issue appears in other distros with that update, and TF2 version rollback works just fine (apart from version conflict with servers). Its just broken update, wait for the next one to fix this.


It may be this. Thank you for catching my error too, i did not realize it. :)
swaggerino Oct 3, 2014 @ 5:40am 
I had the same problem after the 1 oct update on two linux machines, one with AMD, one with Nvidia. How to do a rollback?
spr1n Oct 3, 2014 @ 6:06am 
Originally posted by quincy2002:
I had the same problem after the 1 oct update on two linux machines, one with AMD, one with Nvidia. How to do a rollback?
you wont be able to connect to any servers if you have older version, but if you dont care about that - beta option is what worked for me: TF2 Properties > Betas > pre hwn2013demo ...
((((KA-BOOM)))) Oct 3, 2014 @ 6:27am 
I have contacted Steam Support. I gotten a message sying to refresh Steam files. After that, verify the games files.

I am going to see if this helps. If it does, I will post "FIXED" in the topic.
Last edited by ((((KA-BOOM)))); Oct 3, 2014 @ 6:27am
Thela Oct 3, 2014 @ 9:12am 
https://i.imgur.com/k02gaFp.jpg

That is what my loading screen looks like, very bad picture, but that is sort of like twisted rectangle with loading image as texture.

I have tried different launch options and reinstall tf2, but nothing seems to help.
< >
Showing 1-15 of 161 comments
Per page: 15 30 50

Date Posted: Oct 1, 2014 @ 8:20pm
Posts: 161