Team Fortress 2
Vhaal Aug 12, 2015 @ 3:47am
Does anyone know where the Config file for TF2 is?
I've been trying to find it, can't play with Vsync on nor off, since with it I get terrible lag and without it my FPS is too high it might overheat my components and limiting my FPS would fix that, therefor I need to find the Config file. Any idea where it's located?
Thanks :steammocking:
< >
Showing 1-15 of 19 comments
wiken Aug 12, 2015 @ 3:52am 
Steam\steamapps\common\Team Fortress 2\tf\cfg
If you can't find autoexec.cfg which is the config you want. Just create it by yourself.
Vhaal Aug 12, 2015 @ 3:58am 
Thanks, really helpful :)
So I found two .cfg files, one is the default one and the other one I guess I'll be editing, I've looked through it by opening it with Notpad but I can't seem to find "max_fps" or something like that in the file, any idea on how to fix this. Do I just type it in on my own or?
Mashpit Aug 12, 2015 @ 4:01am 
Don't touch your config file, it tends to have weird commands that nobody understands and can break your game if you ♥♥♥k with it in the wrong way
Just create an autoexec instead, it's functionally the same thing except that you can't ♥♥♥k anything up in the way you can with the config file
...Okay, you can, but the commands aren't there by default so it's somewhat harder to ♥♥♥k everything up.
wiken Aug 12, 2015 @ 4:02am 
Originally posted by Vishalea:
Thanks, really helpful :)
So I found two .cfg files, one is the default one and the other one I guess I'll be editing, I've looked through it by opening it with Notpad but I can't seem to find "max_fps" or something like that in the file, any idea on how to fix this. Do I just type it in on my own or?
Yes, just type in "max_fps" and a number for how much fps you want to cap and it should work.

e.g max_fps 30 should cap the game at 30 or perhaps 29 fps.

Originally posted by Mashpit | Teamplay.tf:
Don't touch your config file, it tends to have weird commands that nobody understands and can break your game if you ♥♥♥k with it in the wrong way
Just create an autoexec instead, it's functionally the same thing except that you can't ♥♥♥k anything up in the way you can with the config file
...Okay, you can, but the commands aren't there by default so it's somewhat harder to ♥♥♥k everything up.
Should mention this as well. But you have a backup file so you can just revert back to old config if you somehow screw it up.
Last edited by wiken; Aug 12, 2015 @ 4:03am
Vhaal Aug 12, 2015 @ 4:04am 
Originally posted by Kor:
Originally posted by Vishalea:
Thanks, really helpful :)
So I found two .cfg files, one is the default one and the other one I guess I'll be editing, I've looked through it by opening it with Notpad but I can't seem to find "max_fps" or something like that in the file, any idea on how to fix this. Do I just type it in on my own or?
Yes, just type in "max_fps" and a number for how much fps you want to cap and it should work.

e.g max_fps 30 should cap the game at 30 or perhaps 29 fps.

That did not work, still way above 300 fps.



Originally posted by Mashpit | Teamplay.tf:
Don't touch your config file, it tends to have weird commands that nobody understands and can break your game if you ♥♥♥k with it in the wrong way
Just create an autoexec instead, it's functionally the same thing except that you can't ♥♥♥k anything up in the way you can with the config file
...Okay, you can, but the commands aren't there by default so it's somewhat harder to ♥♥♥k everything up.

How do I create an autoexec then? never done this before.
lolschrauber Aug 12, 2015 @ 4:05am 
Originally posted by Vishalea:
Originally posted by Kor:
Yes, just type in "max_fps" and a number for how much fps you want to cap and it should work.

e.g max_fps 30 should cap the game at 30 or perhaps 29 fps.

That did not work, still way above 300 fps.



Originally posted by Mashpit | Teamplay.tf:
Don't touch your config file, it tends to have weird commands that nobody understands and can break your game if you ♥♥♥k with it in the wrong way
Just create an autoexec instead, it's functionally the same thing except that you can't ♥♥♥k anything up in the way you can with the config file
...Okay, you can, but the commands aren't there by default so it's somewhat harder to ♥♥♥k everything up.

How do I create an autoexec then? never done this before.
Make a textfile and name it autoexec.cfg

the command is fps_max btw, not max_fps
Last edited by lolschrauber; Aug 12, 2015 @ 4:06am
Vhaal Aug 12, 2015 @ 4:10am 
Originally posted by lolschrauber:
Originally posted by Vishalea:

That did not work, still way above 300 fps.





How do I create an autoexec then? never done this before.
Make a textfile and name it autoexec.cfg

the command is fps_max btw, not max_fps

Tried making a text file and to name it autoexec.cfg, I only put in "fps_max 101" but it still doesn't seem to override the other FPS limit which makes me go over 300 FPS which is abit risky for my taste. Still haven't managed to fix this. Able to guide me any further?
Mashpit Aug 12, 2015 @ 4:19am 
If you have TF2 open then you need to save the autoexec and type "exec autoexec" in the console
wiken Aug 12, 2015 @ 4:22am 
Originally posted by Mashpit | Teamplay.tf:
If you have TF2 open then you need to save the autoexec and type "exec autoexec" in the console
Is that step necessary? I use config as well but i don't remember to type in exec autoexec in console.
Vhaal Aug 12, 2015 @ 4:26am 
Right, so I managed to figure out how to fix it for me atleast. Tell me if this is a bad way to do it or if it's fine, anyway it goes like this. I deleted the "autoexec.cfg" cause that didn't seem to work for me, instead I opened up the default .cfg file and I added a "fps_max "101" line and once completed with that I then enabled (skrivskydd) think it's something like write protection? It's an option in Properties if you right click on the file. And from that point it seems to stay on 101 FPS in-game
Mashpit Aug 12, 2015 @ 4:29am 
if you enable read-only mode for config.cfg then none of your setting changes in-game will save
Vhaal Aug 12, 2015 @ 4:30am 
Originally posted by Mashpit | Teamplay.tf:
if you enable read-only mode for config.cfg then none of your setting changes in-game will save

That's what it translates into yea, but that's the only way for it to stay at the FPS cap that I wish for
wiken Aug 12, 2015 @ 4:31am 
Originally posted by Vishalea:
Originally posted by Mashpit | Teamplay.tf:
if you enable read-only mode for config.cfg then none of your setting changes in-game will save

That's what it translates into yea, but that's the only way for it to stay at the FPS cap that I wish for
Hm? What's the problem if you un-check Read-Only?
Vhaal Aug 12, 2015 @ 4:32am 
Originally posted by Kor:
Originally posted by Vishalea:

That's what it translates into yea, but that's the only way for it to stay at the FPS cap that I wish for
Hm? What's the problem if you un-check Read-Only?
then it reverts the change and goes over 100 FPS again
wiken Aug 12, 2015 @ 4:34am 
Originally posted by Vishalea:
Originally posted by Kor:
Hm? What's the problem if you un-check Read-Only?
then it reverts the change and goes over 100 FPS again
Weird, my file are uncheck and the config works just fine.
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: Aug 12, 2015 @ 3:47am
Posts: 19