Slime Rancher

Slime Rancher

View Stats:
>Fixed< Black Screen On Start - Windows
tl;dr -> Black screen on start, only sound, all what could maybe help you

What it fixed for me, (seems it was an Unity problem):
> Enter the Nvidia system settings (not the experience thingy)
> Switch to "Adjust Screen Size And Position"
> Select "No Scaling"
> Save settings, start the game, have fun

To all those, the Nvidia Control panel only shows 3D Settings and nothing more:
(( thanks to indigoskies7 ))

> Right-click on the desktop and open Graphics Properties (with the Intel icon)
> Click on Display
> Then under Scaling, click on 'Maintain Aspect Ratio' so it has a tick next to it and then tick 'Override Application Settings' when that appears.
> Click Apply, then when it asks if you want to keep the settings click Yes.


If above doesn't help, everything else you could try:

- System restart
- Driver updates
- Force it to run in DX9 ( start parameters "-force-d3d9" )
- Switch from full screen to windowed ("-screen-fullscreen 0")
- Let Steam search for corrupted files
- Start in Safe-Mode
- Reinstall the game
- updated Visual C++ (2010, 12, 13, 15 - both 32 and 64 bit, just to be sure)
- updated .NET Framework,
- updated OpenAL,
- updated Java,
- updated XNA Framework

>> If you run it on Linux this will maybe help - https://steamcommunity.com/app/433340/discussions/0/341537388325433886/


We contacted the devs at support@monomipark.com
So far we got a link to the forum http://forums.monomipark.com/viewtopic.php?f=5&t=858
and the advice to send the log file + pc specs
(We did so, but they never answered -.-)

_________________________________

If you still have trouble, just write it here and I will try to help
Last edited by Stefan Red; Jan 21 @ 9:53pm
< >
Showing 1-9 of 9 comments
Problem solved ...
Hope can help others with it.
Where do I access the Nvidia settings? I'm not very tech-savvy.
Stefan Red Jan 20 @ 11:08am 
Try a right click on your desktop, otherwise maybe in your task bar
OH MY GOD THANK YOU SO MUCH!! I haven't been able to play this and other games for over a month!

I did have to do it slightly differently, because my Intel driver controls my display settings. So in my Nvidia Control panel, all it shows is 3D Settings.
For anyone who also has this:
- Right-click on the desktop and open Graphics Properties (with the Intel icon)
- Click on Display
- Then under Scaling, click on 'Maintain Aspect Ratio' so it has a tick next to it and then tick 'Override Application Settings' when that appears.
- Click Apply, then when it asks if you want to keep the settings click Yes.

There you go, that's all I had to do to make it work again :')
Yeah! Nice ! :D
And thank you for the addition, i put it in up there... I'm really happy we can help others this way :)
Oh thank you, thank you, thank you for these solutions!! I wouldn't have been able to figure out how to fix the display on my own. :'D
Hi I'm running on Windows 10 too but with AMD graphic card. I tried everything listed here and yet nothing helped. I emailed the devs, they asked for my log file, I emailed back with my log file and it has been over 10 days without any response. And a year ago I was able to run this game tho until the fancy updates came out. :steamsad:
Wild Child mentioned
at http://steamcommunity.com/app/433340/discussions/0/1620599015913526389/ that you could fix the scaling at other ways, maybe give it a try.

oh and the devs didn't answer me anymore, too :(
Originally posted by Stefan Red:
Wild Child mentioned
at http://steamcommunity.com/app/433340/discussions/0/1620599015913526389/ that you could fix the scaling at other ways, maybe give it a try.

oh and the devs didn't answer me anymore, too :(

Well but I'm running on AMD instead of Nvidia and I don't see any "scaling" in AMD setting window. :(
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Jan 14 @ 2:43am
Posts: 9