Age of Fear 3: The Legend

Age of Fear 3: The Legend

View Stats:
Tamaster Sep 17, 2017 @ 5:01am
Very bad performance during battle
I am experiencing a serious problem with this game:

During any battle, the performance and responsiveness of the game degrade dramatically, not over time but from the start.

Animations become chopped off and miss frames, for example movement of characters sometimes is just a teleport because it entirely misses all the movement frames. There is a general "lag" in responsiveness, all the UI elements must be often clicked several times in order to make them work, this also applies to units. You can distinctively see all the animations like the circles around selected units or the terrain effects lagging badly, not being smooth, but instead having a very bad frame rate.

This makes the battles not only longer, but clunky and much less enjoyable.

System specs:

i7 4820K 3.7Ghz
Game is on an SSD

I already tried using windowed mode, tried all the rendering engines and graphical settings, manually set process priority to High, all of this has not been useful and still in battle there is terrible performance. I also tried re-downloading the game and checking steam file integrity. All drivers are last version.

That's really a disappointment because it is a good game.
Last edited by Tamaster; Sep 17, 2017 @ 5:01am
< >
Showing 1-6 of 6 comments
Les  [developer] Sep 17, 2017 @ 10:09am 
So sorry, something is wrong if it's so choppy.

Can you please reset settings first and let me know how if works?

Next thing will be to try different rendering engines.

Also, game is capped at 30fts.

I will be recoding GUI and rendering engine to OpenGL - unfortunately, technology we used is outdated. It will take few months and least, thought. Here is post:
Last edited by Les; Sep 17, 2017 @ 10:20am
i_nive Sep 17, 2017 @ 11:06am 
Can one set JVM options for the game, like GC ones?
Blixx Oct 2, 2017 @ 1:12pm 
I am seeing the same problem. NO matter the graphic settingsI am seeing CPU pinging 90%+ and staying there. I can tab in and out of the game and all works fine for a few minutes. then CPU back to 90%+
Les  [developer] Oct 2, 2017 @ 7:01pm 

There was an issue with terrain effects. I have disabled them and it helped in case of Tamaster. I will fix this issue before enabling them again.

Could you please Reset settings (Options -> Reset) and let me know if that helps?
So sorry for issue :-(
Last edited by Les; Oct 3, 2017 @ 5:23am
Blixx Oct 3, 2017 @ 10:40am 
Changes made a differance, proformance is looking good. I did have a problem with artifacting after the patch. I cloed the game, reset the default setting and launched again... All graphics and Lag issuses have cleared up. Thanks the rapid hot fix...
Les  [developer] Oct 3, 2017 @ 12:02pm 
Nice to hear!! Sorry once again for this issue. I need to check code responsible for animations.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50