The Bard's Tale

The Bard's Tale

View Stats:
 This topic has been pinned, so it's probably important
Bard's Tale 1 (classic) save party issues
I've been playing the original game since release in 1985 on various platforms (started on an amstrad cpc 464!) and was pleasantly surprised to see the classics bundled with my Bard's Tale purchase from a while back.

I decided to give this version a try instead of emulating it as I usually do, sank a couple of hours into a party, saved it off as I would normally and thought nothing more of it. Came back today to continue and found that the character disk had no saves on it. Its in its totally unmodified state as if it were a fresh install.

I've tried saving individual characters, full parties, removing characters completely so that they're saved off to disk. It all seems to go fine in game, with a small delay in sound to indicate saving is happening, but reloading the title seems to reset the disk to its initial install state.

Am I doing something wrong, or is there an issue with the current release?

Cheers for any help! Itching to play now and may have to get the emulator out! Or the C64... hmm.

*Windows 10 btw.
Last edited by Omniknight Who Says Ni!; Nov 9, 2017 @ 12:17pm
Originally posted by Jherad:
DING DING DING.

I think I've fixed it! :D

So it looks like the problem is really very simple. When you run BT1 for the first time, it extracts a bunch of required emulator files (config, images etc) to a folder in appdata. It *also* creates a 0 byte flag file called iibt1.

Then, every time you launch BT1, it looks for that flag file, and if it doesn't find it, it re-extracts all the required files to your appdata folder, overwriting anything with the same name that's already there.

One small problem -

It's not looking in appdata for iibt1, it's looking in BT2004's root directory lol.

Simple fix, move (or create) iibt1 (no extension, 0 byte file) in steamapps\common\The Bards Tale
From that point on, BT1 no longer overwrites the image files, and saves work fine. IF you delete the appdata folder, you'll probably also need to delete the iibt file to get it to recreate next time.

From inXile's perspective, all they should need to do to fix this going forward is have BT2004 look in the correct place for iibt1. Should be trivial.
< >
Showing 1-15 of 28 comments
vorik Nov 9, 2017 @ 12:33pm 
try running steam with administrator privileges. hollar if you need help with this. I haven't tried classic on the PC though, so not sure if this will work. Maybe cloud saves could enabled :)
Last edited by vorik; Nov 9, 2017 @ 12:34pm
Thanks for the reply!

I'd tried all the compatibility settings and admin rights with no joy, should have mentioned that.

Cloud saves was a promising idea which I rushed to try, but the game doesn't have an option for it.

The game runs brilliantly otherwise, I'd recommend it thoroughly to anyone looking for nostalgia feels provided the saves work for you.
vorik Nov 9, 2017 @ 2:58pm 
https://forums.inxile-entertainment.com/viewtopic.php?f=44&t=18614

looks like there was an update to the base The Bard's Tale (2004)
Indeed, I'm hoping that's what has caused the issue. Fingers crossed!
vorik Nov 9, 2017 @ 3:59pm 
I think the update to 2004 is an unlikely culprit

but anyway, here's another thread about saves.
https://forums.inxile-entertainment.com/viewtopic.php?f=44&t=15919

You're probably doing the Adventurer's Guild save, with all the experience you have in the game.

Just had a 0kb update on the game, bizarrely. Hasn't changed anything though.

AG saves were ingrained from the start, its my only way out of the game - lol. I guess I could snapshot save it via dosbox, but that'd destroy the purist in me.

Thanks for all your efforts trying to help me out, Vorik.
vorik Nov 12, 2017 @ 2:34am 
Looks like the BT1 emulator overwrites any save files that are made.

Save files are named bt1d1.2mg (game disk), bt1d2.2mg (character disk/save game disk) and stored in C:\Users\<your user name>\AppData\Local\inXile entertainment\The Bard's Tale

After using the Leave Game option, bt1d2.2mg gets updated with the proper timestamp.

Once you start BT1 again in the next session, regardless of closing BT (2004) first or just keeping the same session, the bt1d2.2mg gets overwritten.


Based on prior discussion posts about this, this might be new behaviour, maybe related to Windows 10 differences. The old method was to manually Remove all characters from the party to save. bt1d2.2mg gets overwritten during the new start also.

the bt1d2.2mg file handles remain open while BT1 is running, so there's not an easy way to try and manually swap in a backup copy.

might need to play with the config.kegs.bt1 file also. I tried a few things like trying the BT1 character transfer function via s6d2, by adding the bt1d2.2mg to slot6 disk2, trying to create a s6d2_bt1 file to simulate the existing s5d2_bt1 standard save drive, but they all failed with an I/O error.
Jherad Nov 12, 2017 @ 6:04am 
I am so glad to see it's not just me with this problem heh. I'd actually run the original series just fine through Bard's Tale 2004 a couple of years ago, so it's either Windows 10, or an update to the game that has broken things.

Hope that this bug gets some attention. Thanks for bringing it up.
Jherad Nov 12, 2017 @ 9:26am 
So I downloaded the KEGS emulator (kegs.sourceforge.com), and plugged in the bard's tale image and rom files (bt1d1.2mg, bt1d2.2mg, bttricode)

Everything works fine. Characters save and load with no problem. That's a workaround at least, and shows the problem is probably with this particular implementation of the emulator.

Edit: Scratch that, it's not even an emulator problem. It's probably just that each time you start Old BT from within the game it extracts and overwrites ALL necessary files to the save folder without first checking if they exist. Or if it does check, it's looking in the wrong place.

I'd really like this fixed as while I can launch the images from a downloaded emulator, I haven't figured out yet how to run it in a reasonable resolution (unlike in-game).
Last edited by Jherad; Nov 12, 2017 @ 11:21am
Hey nice, looks like you guys put in some work!

I didn't have the patience with all the emulatable versions around, but you've tickled my interest again.

The idea of the 2004 game .exe extracting new files every time was interesting, so I tried saving the save disk image under a different name and loading that into the emulator.

The character disk loaded up just fine, but still with the default characters. So it doesn't look as though new files are getting extracted each time since the 2004 .exe wouldn't have been looking my image to overwrite. More likely that the emulator is saving, or giving the impression of saving, but nothing is actually getting written to the character disk.

I don't know a thing about programming, but I'd be willing to bet its something to do with Windows 10 being overly protective about a piece of software nested in another piece of software trying to alter a file, based on the experiments that you guys have done so far.

Hopefully those awesome guys at inXile will take a look sometime soon!
It doesn't seem to matter what you do, the file just doesn't get modified at all. The date remains constant, 2013.

I thought I'd stumbled on a solution with the file folder in Users\----\The Bard's Tale being read only, turns out its a quirk of Windows 10 I hadn't noticed before, the read only box is filled in with a black square for EVERY folder, it only has two states, black square and checkmark.

Cruel Microsoft, so cruel!
Jherad Nov 14, 2017 @ 6:56am 
I posted on their forums with a link to this thread, so fingers crossed. :)
phimseto  [developer] Nov 14, 2017 @ 7:01am 
I saw this thread, and passed it along.
Jherad Nov 14, 2017 @ 7:03am 
Thank you! :steamhappy:
Jherad Nov 14, 2017 @ 7:21am 
So yeah, it's definitely overwriting.

If I create a character, then quit the game (important, it's not updated until you do this), the timestamp on bt1d2.2mg is updated.
If I launch the game again, the timestamp is reverted to 2003 - ie. it's overwritten.

If I take a save image (bt1d2.2mg) from a game that I've been playing using the KEGS emulator and put that where 2004's image is, it again gets overwritten immediately upon launch of BT1. *Really* quickly - before BT1 even gets to its splash screen, so it's probably 2004 doing this as part of it's sequence before it hands over to BT1.

Also of note, any changes you make to config.kegs.bt1 or config.kegs are also immediately overwritten.

EDIT:

For bonus points, making bt1d2.2mg READ ONLY actually does prevent the overwrite, allowing you to access the character you created previously. Unfortunately, character changes are then no longer saved, even if you remove the READ ONLY flag. (BT1 throws up a write protect error).
Last edited by Jherad; Nov 14, 2017 @ 7:29am
< >
Showing 1-15 of 28 comments
Per page: 15 30 50