Serious Sam 3: BFE
Holz Dec 15, 2013 @ 10:52am
Regarding the "stuck at loading" issue...
Hi, this is primarily directed at the game's developers but also at others having the same issue.

So I just installed and wanted to play this game. I launch it the first time, it appears to be stuck at "Loading...".

Alright, I suppose that can happen the first time you start a game, let's forcefully close it and reopen it.
Again, same problem. Sam3.log? "[Direct3D] Device lost - waiting for reset.". Well, okay.

Now I noticed that both times, Steam's first-time setup appeared but disappeared again unusually quickly.

So I had a look at the installscript.vdf. It has one entry for DirectXRedist, specifically "%INSTALLDIR%\\Redist\\DirectX\\DXSETUP.exe".
Strange, there's no Redist folder in the game's directory! That explains why the first-time setup disappeared so quickly, and why popped up the second time I launched the game as well.
I then tried verifying the game's files but they were all good.

Now since I already have DirectX installed anyway, I deleted the installscript.vdf, restarted the game, and now it works well.

Edit: Also, the game is hilarious!
Last edited by Holz; Dec 15, 2013 @ 1:14pm
< >
Showing 1-3 of 3 comments
Solais Dec 15, 2013 @ 11:44pm 
Yes, this is a problem the devs know about, they removed the DirectX install files by accident. Will be fixed in a patch.
AlenL  [developer] Dec 16, 2013 @ 1:11am 
Solais ninjaed me here. :)

However, note that the missing DirectX setup is only a problem for users who never installed DirectX 9.0c. (Usually happens to people who installed a fresh Windows8, and never played other games on it before, or only played those requiring DX10/11.) And for them, the problem manifests with "Fatal error: Cannot set display mode."

So, that should not be the cause of your "stuck at loading" issue.

Btw, when the Redist folder is missing, Steam just happily ignores what the installscript.vdf says, so it shouldn't be a problem for installing. (I just tested that here.) So that shouldn't be causing the installation problems either.
I had this same problem and fixed the issue by ding the following: Start game, then hold down ALT and hit ENTER, to make the game go to windowed mode. The game should load now that it is windowed. Then go to video options and turn full screen back on. It should now be fixed.
Last edited by Pvt. Dave of Da feet [FSSF]; Dec 16, 2013 @ 8:43am
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: Dec 15, 2013 @ 10:52am
Posts: 3