Super Meat Boy
BONESTOCK Jan 20, 2014 @ 9:47am
Can't start the game. Error.
I've been able to play this game a long time ago. Wanted to play it again but no luck.
I get the following popup.

"An error occured while updating Super Meat Boy. (disk write error)"

I tried the steam suggested appcache delete and computer restart.

I have no problems playing any other game. What's the deal?

Also on my management of game updates I have only Super Meat Boy and the Super Meat Boy editor that needs to be updated but it won't let me.
< >
Showing 1-5 of 5 comments
icculus Jan 20, 2014 @ 10:24am 
It sounds like one of three things is happening, and none of them are Super Meat Boy's fault:

- Maybe your hard disk is full; if so, clear out some space.
- Maybe your filesystem has some corruption; you should run CHKDSK or whatever.
- Maybe your hard disk is failing. Regardless of what you do with Super Meat Boy, you should seriously consider stopping whatever you're doing right now and make sure you have a backup of files you care about, in case the rest of the disk is about to fail, too.

"disk write error" tends to mean "some serious ♥♥♥♥ is going wrong," and you should not ignore it.
icculus Jan 20, 2014 @ 10:26am 
(Also, I assume that popup error is coming from the Steam Client, which means Super Meat Boy didn't even get to launch yet at this point.)
BONESTOCK Jan 20, 2014 @ 11:39am 
Hmm....I have 1.47TB of space left.

I've dl'd countless other games.

This is a brand new computer I just built. I have 132 other games with no issues. Last time I played this game was back on Jan2013. I put an hour into it with no issues at all back on my old build.

I've tried erasing all Super Meat Boy data and tried the appcache thing. Not sure what else could possibly cause just this game on my library to have issues.

I just don't know.
BONESTOCK Jan 20, 2014 @ 9:40pm 
UPDATE: I got it working. I uninstalled the game and then also the game editor. Re dl'd the game and it worked. Must have been something with the editor because I had already once before uninstalled this game.'s working. I'm happy! :squirtooh:
SeymourGore Jun 6, 2017 @ 6:09am 
Sorry for the necro, but this (uninstalling Super Meat Boy editor alongside Super Meat Boy) corrected my issue as well. To go along with this, I was getting the same issue with Braid and uninstalling Super Meat Boy editor also allowed me to reinstall Braid correctly.

Both games were part of Humble Bundle V, perhaps issue is connected? Anyhow, hope others find their solution here.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Jan 20, 2014 @ 9:47am
Posts: 5