Wasteland 2: Director's Cut

Wasteland 2: Director's Cut

View Stats:
D! Nov 5, 2015 @ 10:01pm
[Linux] Can't save at Ranger Citadel
When I'm trying to save at Ranger Citadel, there are ranger star icon at the upper left corner, I can't move or open inventory, but can rotate camera and open menu by pressing Esc. Saving just never ends. Before the last patch, even autosave in this area don't load (game crashes). Now autosave works fine, but manual save don't. It only occurs in Ranger Citadel. I'm on Ubuntu 15.04. Anyone else have this problem?
< >
Showing 1-15 of 15 comments
D! Nov 8, 2015 @ 6:54am 
Now same problem with Rail Nomads Camp
D! Nov 9, 2015 @ 9:43pm 
Sometimes, disabling shadows allows me to save, but sometimes not. It is strange.
owen Nov 11, 2015 @ 12:26pm 
I'm having the same issue, I'm running ubuntu 5.10 and whenever I try and save the game just stalls out.
Zinga Nov 13, 2015 @ 10:35am 
Same problem
Linux Mint 17.2 x64
D! Nov 14, 2015 @ 11:46pm 
Still here with the last update.
)+(Chickenhead Nov 15, 2015 @ 4:51pm 
DITTO. Hey just for ♥♥♥♥♥ and giggles, try re-loading your old savegames and see if the items you have from your last save are there. That's where I am. Stuff I aquired at the save-game mess-up is there when I reload very old savegames.
Zinga Nov 18, 2015 @ 11:06am 
So I contacted inXile and there's two ways to try fixing:

1. Possible corrupt game install - try verifying your game files using Steam

2. Quoting inXile tech support:
Originally posted by inXile Entertainment:
The other reason (hinted at by the "too many open files"* message in the error) might be that you have run into a file handler bug that we've discovered in the Linux version of the game. This is an engine-level issue in the current Unity version, to our knowledge, and results in multiple copies of the same game files being loaded into memory. Because Linux has max open file limits as defined by the OS, the game hits into those limits and the OS won't let it open more files. This can manifest as all manner of strange behavior, which you may be seeing.

For now, you can try following the instructions above as a workaround to see if this resolves the issue:

Open /etc/security/limits.conf as root, paste the following two lines, replacing "username" with your user name or with * for all users, and reboot afterwards.

username soft nofile 4096
username hard nofile 8192

* - They are referring to "IOException: Too many open files" error message they found in game log

I have tried the above workaround and tested for ~1hr. So far I have had no problems in Ranger Citadel and issue seems to be resolved.

edit: phrasing
Last edited by Zinga; Nov 18, 2015 @ 11:08am
Nobody Nov 18, 2015 @ 1:57pm 
Look like worked for me. Linux Arch with Openbox
Thanks Darth Zinga.
Nightwalker Dec 8, 2015 @ 6:43pm 
Yeah I'm seeing the same issue in places. Looks like the game locks up in an infinite loop and never finishes saving the game.

This is a game breaker for me.
D! Dec 8, 2015 @ 8:35pm 
Does disabling shadows helps?
Nightwalker Dec 10, 2015 @ 2:08am 
Originally posted by D!:
Does disabling shadows helps?

Nope. This was happening with shadows disabled....including an incident where the ranger complex loaded with a bunch of black/blank textures.
D! Dec 10, 2015 @ 5:00am 
Hope inXile will fix it in the next Unity Engine + game update
gibblets Dec 10, 2015 @ 10:38pm 
The 'too many open files' issue listed in post #7 fixed this for me on Arch Linux. If you want to see if you're affected type 'ulimit -n', if the number is 1024 or near there, you probably need to consult your OS documentation to raise the limit or try the limist.conf file mentioned in post #7.
Linux Guy Dec 11, 2015 @ 2:41pm 
Modifying /etc/security/limits.conf on my Gentoo box doesn't do it for me, and my regular user can't modify ulimit -n more than 2048 from the command line, but did find this work-around:

sudo sh -c "ulimit -n 8192 && exec su <username>"

This might wreck your $PATH, but then just type /usr/bin/steam or wherever you have steam installed for your distribution. So far has totally fixed my Ranger Citadel bugs I was getting (not being able to load/save game, couldn't interact with environment, etc.)

If I find a nicer/cleaner work-around I'll post it here.
gibblets Dec 12, 2015 @ 2:10pm 
Originally posted by Linux Guy:
Modifying /etc/security/limits.conf on my Gentoo box doesn't do it for me, and my regular user can't modify ulimit -n more than 2048 from the command line, but did find this work-around:

sudo sh -c "ulimit -n 8192 && exec su <username>"

This might wreck your $PATH, but then just type /usr/bin/steam or wherever you have steam installed for your distribution. So far has totally fixed my Ranger Citadel bugs I was getting (not being able to load/save game, couldn't interact with environment, etc.)

If I find a nicer/cleaner work-around I'll post it here.

I'm on Arch and had similar issues with the limits.conf file. Mine were caused by newer releases of systemd, if you're running systemd you may want to try editing the global system.conf file at /etc/systemd/system.conf. The line should be:

DefaultLimitNOFILE=4096

I chose 4096 arbitrarily, the default is 1024 though which causes issues for Unity. Unfortunately this is a global setting and will affect all users and I believe startup services as well, but I haven't found a better solution.
< >
Showing 1-15 of 15 comments
Per page: 15 30 50