Vikings - Wolves of Midgard

Vikings - Wolves of Midgard

View Stats:
Brenno Mar 25, 2017 @ 1:47pm
Low framerate?
I have a GTX 1070 and the game runs like it's 30fps even with v-sync turned off and framerate on unlimited. Am I the only one with this problem?
< >
Showing 1-15 of 39 comments
Metal Veteran Mar 25, 2017 @ 1:55pm 
Im also having low FPS. Game itself doesnt show up on the GeForce Experience screen. It means it doesnt use NVIDIA card. So I think we need an NVIDIA Driver update
Timeraider Mar 25, 2017 @ 1:56pm 
Same, framerate is far from good. Hope nvidia brings out a driver that fixes it or the developers brin out a fix
Skynetwork111270 Mar 25, 2017 @ 2:22pm 
Same. GTX 1080 @ 4K 30 FPS.
Vlamesneaker Mar 25, 2017 @ 3:57pm 
got an asus strix 1070 oc Driver:378.78 Gsync on, vsync off, frame limit on 140 and have 142 in game. 1080p
Last edited by Vlamesneaker; Mar 25, 2017 @ 3:57pm
Psychoza Mar 26, 2017 @ 8:03am 
GTX 1080 @ 1080p 170fps, works great for me
I'm curious to know why people are running GTX 1070 & 1080s at 1080p resolution.
I cannot believe those cards are required for smooth game play @ 1080p.

I'm running GTX 970 @ 2560x1440p (i7-860 @ 3.8 ghz, 16gb ram)
FPS: 32 - 55
Even then - a single 970 should have no trouble with this particular game. The character models and items are really not that finely detailed at all.

Fluctuating frames creates for a very herky jerky experience.
schroettel Jun 1, 2017 @ 12:30pm 
There is still the same problem. I have a GTX 1080 (Driver 382.33) and about 33 fps @ 4K. Even when i turn down quality to very low, the FPS don't increase to an acceptable level. (abaout 38 FPS)
When I zoom. the FPS drops far under 30.
The release is long time ago and I think we can give up hope. It is a pity...
Last edited by schroettel; Jun 1, 2017 @ 12:31pm
GinJuice Jun 1, 2017 @ 1:58pm 
Most people I think do not have framerate problems. Atleast I havnt seen that many people complain about it. I know I def dont have any fps problems. I-7 w/ GTX 970.
wsgroves Jun 21, 2017 @ 1:51pm 
I am unsure what happened. When the game came out, I played the first two zones with 980 Ti SLI@4k.
I have recently updated my cards to a Strix 1080Ti. Now the framerate is unplayable at 4k.

The two are relatively close enough that the game's performance should not tank.
SiddiusBlack Jun 21, 2017 @ 2:32pm 
1080Ti @3440x1440....Framerate are good between 70-100 but massive performance problems too since update 2.0....the game don't run smooth anymore. Maybe not in or on all maps, i start a new game+ and the performance drops began at the second map in the hunt for the jokul...

I am not to be in the mood to play it further with this drops...

♥♥♥♥ may rain onto the devs for no bringing no UI for 21:9 in the game and ♥♥♥♥ again now for this!
wsgroves Jun 21, 2017 @ 4:16pm 
Siddius, I think I can confirm what you say. I started a new game as well and on that starter map, my framerate at 4k was outstanding. It seems at least that the town (camp) I live in, the framerate tanks there in that zone.
lantern48 🔋 Jun 21, 2017 @ 10:11pm 
780ti and have perfect 60fps at 1080p.
Skynetwork111270 Jun 22, 2017 @ 8:21pm 
Update 2.0: GTX 1080 SLI still 30 FPS @ 4K :( thumbs down.
Rabid Fox Jun 23, 2017 @ 4:37am 
980Ti@2160p here. FPS is an absolute rubbish. Maxed out (during intro mission and after) 35fps, everything at its lowest results in ~38fps.

I tried 1.05 and demo in latest version.
As a blind shot I tried to update GPU drivers, but no improvement.
wsgroves Jun 23, 2017 @ 9:46am 
Thanks for the additional info Vagon. Seems there is def. something wrong. Hopefully the devs will have a look at it.
< >
Showing 1-15 of 39 comments
Per page: 15 30 50

Date Posted: Mar 25, 2017 @ 1:47pm
Posts: 39