Dishonored 2

Dishonored 2

View Stats:
Dishonored 2 > General Discussions > Topic Details
Possible Fps Help/Fix for Nvidia cards
Instructions:

"Manage 3D Settings"
"Program Settings"
-Select Dishonored 2-
"Maximum Pre-rendered Frames"
Make sure you have the Control Panel open and not Nvidia Experience :)

I have Nvidia GTX 970, i7-4790, 3.6Ghz and 12GB RAM. I didn't expect Ultra on this game, but we can all agree the optimization screwed everyone over a little bit - I had 40-80fps on Medium, and even the 80fps felt choppy.
After using the Nvidia control panel to change the program-specific settings for Dishonored 2, and changing the maximum pre-rendered frames to 1, my fps is now a constant 60-150, and it feels massively smoother even in the rooftop parts of Dunwall, etc. even on High graphics settings now!
I hope this fix can work for some other users, as it worked for me!

Source
< >
Showing 1-14 of 14 comments
Boredoms Nov 9, 2016 @ 10:13pm 
Thank you so much. This did the trick. I was getting as low as 22 fps with my 980 ti. Now I'm getting 90+
Eyeless Nov 9, 2016 @ 10:17pm 
tried it, but it didn't help my stutter issue
ccclx Nov 10, 2016 @ 1:16am 
Thank you so much. This is better!
Last edited by ccclx; Nov 10, 2016 @ 1:46am
Better save this topic before I get home. I am having above 30 constantly on my 960 2 GB high, but it still is not comfortable. Thanks.
Yes? Nov 10, 2016 @ 1:22am 
Really appreciate it! :steamhappy:
NRieh Nov 10, 2016 @ 1:37am 
Gonna try this one...
Skorne Nov 10, 2016 @ 1:42am 
Thankyou this helped immensely. It's like the game was rendering about 10 frames in advance before which made the mouse horribly floaty and unresponsive, now it's normal.
TRUMP2024 Nov 10, 2016 @ 1:48am 
Incredibly useful. Went from low 40-30 fps to locked 90 @1440p with my gtx1080. THANKS.
Saxxen Nov 10, 2016 @ 1:48am 
This made a huge difference for me, was dropping extremely low and now getting a solid 60, makes it significantly more playable, thank you.
Hozomeen Nov 10, 2016 @ 1:54am 
nothing change ( gtx760:steamhappy:
Last edited by Hozomeen; Nov 10, 2016 @ 1:54am
Neto Nov 10, 2016 @ 2:18am 
Still couldn't play (game unlocked at 2 am here in Brazil, and today I gotta work, so only at night I'll play), but thank you, I'll try that.
NRieh Nov 10, 2016 @ 4:37am 
2x2gb 650M SLI, there IS a fps improvement, but the game froze dead for me with this config. Can't say if that's related.
Neto Nov 10, 2016 @ 4:41am 
So apparently the problem is more of NVidia control panel thing than the game itself?
FabianBlaha Nov 10, 2016 @ 5:29am 
The problem is in utilization. The game does not use all your GPU power.
I was stuck at about 35% usage until I changed the settings.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Dishonored 2 > General Discussions > Topic Details
Date Posted: Nov 9, 2016 @ 9:49pm
Posts: 14