Planetbase

Planetbase

View Stats:
Planetbase > General Discussions > Topic Details
Traders stuck waiting on one resource
I keep having an issue where I am making trades and they keep getting stuck waiting forever for 1 commodity to get loaded and it never gets loaded. They sit and sit and sit and finally take off and leave all the stuff previously loaded sitting on the landing pad. Getting worse especially with larger missions (multiple starports and lots of colonists, bots).
< >
Showing 1-7 of 7 comments
I've had the same issue. For me, the only time I noticed that it would trigger was when I saved in the middle of a trade occuring and quit out. Once loading back in, it would always cause it to happen. Loading a save prior to the trader is the only way around it, other than waiting for it to time out and leave, which is worse imo.

So yeah... I just stopped saving/reloading in the middle of a trade and always made sure it was finished first.
Last edited by Fanible [PW]; Jun 9 @ 8:39pm
Alternatively, have a power cut while the ship is waiting for delivery. Or even intentionally turn the power to the landing pad off. Sometimes those will trigger the "Forget that. I'm out of here." reaction.
brazil70 Jun 10 @ 1:47am 
Yeah, none of those things are what's doing it. Also it seems that once a starport glitches out the only way to fix it is to dismantle it and rebuild it. Really wierd bug.
Jatlen Jun 10 @ 1:49am 
Originally posted by brazil70:
I keep having an issue where I am making trades and they keep getting stuck waiting forever for 1 commodity to get loaded and it never gets loaded. They sit and sit and sit and finally take off and leave all the stuff previously loaded sitting on the landing pad. Getting worse especially with larger missions (multiple starports and lots of colonists, bots).
Avoid selling spare parts; sometimes there is a bug in the game, that those trades are never completed (if the spare part reserved for the trade is used for maintenance instead). And just to be on the safe side, i recommend to keep at least 5 items of a kind (don‘t sell the last one of them).
Last edited by Jatlen; Jun 10 @ 1:57am
martiño  [developer] Jun 10 @ 3:26am 
Originally posted by brazil70:
I keep having an issue where I am making trades and they keep getting stuck waiting forever for 1 commodity to get loaded and it never gets loaded. They sit and sit and sit and finally take off and leave all the stuff previously loaded sitting on the landing pad. Getting worse especially with larger missions (multiple starports and lots of colonists, bots).

This is usually because of a resource stuck somewhere (Maybe in an inaccesible outdoor area).
Eventually the resource should decay and everything should go back to normal.

If you can find the resource, you can delete it manually and everything should go back to normal quicker.
Last edited by martiño; Jun 10 @ 3:27am
brazil70 Jun 10 @ 3:35am 
Great suggestions all but none of those are it. I never sell spare parts and I've checked with the resource thing. I'm thinking it may be the carrier bot that is taking the resource to the ship breaks down and disintigrates and for some reason none of the others are picking it back up and finishing the trade. No clue how to go about fixing that particular thing.
FM83.7 Jun 12 @ 6:11pm 
All I can add is, that I had the same issue in one of the challenges, where you're the boss of a vegan community. Trading is essential in that challenge, but after a while I just can't get 2 metals to be traded. No matter how many times I restarted the scenario, did things differently or deleted resources, switched off power etc. it just got stuck with 2 metals in queue and couldn't finish the challenge. :/
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Planetbase > General Discussions > Topic Details