ArcaniA > General Discussions > Topic Details
Game not work
I instal game and when i click play i have arcania.exe error, how to fix this?
< >
Showing 1-8 of 8 comments
Grimmpeace Jun 27, 2014 @ 5:37pm 
Same problem here...
Eldyraen Jun 27, 2014 @ 7:21pm 
I just noticed my game won't start either as just felt like jumping back in for a while.

The game was still installed from months back but the name in the Library was blacked out like it wasn't installed (but wouldn't download anything when I tried and checking local files did nothing either). I deleted all files under Steam to redownload it completely and see if it would fix it but no such luck.

Now I'm in the same boat and get an error when I try to open the application (fresh download).
Sparhawk Jul 1, 2014 @ 7:42am 
Same here, any idea?
EmoSnowman Jul 1, 2014 @ 12:33pm 
Same here, demo worked fine few hours ago.
Jorkka Jul 1, 2014 @ 1:49pm 
I had the same problem, i have a nvidia graphics card and downloading an new physx driver did the trick for me.

My only problem is that i cant see the intro movie but the game works.
x_int Jul 1, 2014 @ 2:39pm 
I had the same issue, after installing the game it just crashed when I started it. After removing local content and reinstalling it, it does work for me now. Windows 8.1
Stay Jul 3, 2014 @ 12:35pm 
What to do guys same problem here...
traverza Jul 18, 2014 @ 3:56am 
i have same problem....this is not normal omg STEAM game not function!!
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

ArcaniA > General Discussions > Topic Details