Gridworld

Gridworld

Gridworld > General Discussions > Topic Details
-Drake Feb 8, 2017 @ 7:45pm
pixel format not accelerated
tried everything in the 'can't play read this' section. updated drivers for gtx1060 as well as the intel HD4000 that I don't use. tried running exe as well as java. Nothing works.

Game used to work just fine when I purchased it forever ago.

[edit 02.16.17]
Updated to the just released GeForce Drivers 378.66 released on 02/13/2017 and game is working again.
Last edited by -Drake; Feb 16, 2017 @ 10:53pm
< >
Showing 1-15 of 18 comments
DopplerFrog  [developer] Feb 9, 2017 @ 1:45pm 
I'm sorry about that. unfortunately, it is something I can't fix on my part.
perharps this link may help?
http://hopper.minecraft.net/help/pixel-format-not-accelerated/
-Drake Feb 9, 2017 @ 2:44pm 
I'll check it out, thanks for the link.
Timeslice Feb 12, 2017 @ 2:46pm 
I'm having this same issue. I'm on Windows 7 using a GTX1060 with the latest drivers from a couple of weeks ago, and Java 1.8 v121 that I updated yesterday. I have 29 hours of time into the program where it worked just fine, and now it doesn't.

@DopplerFrog Did you recently (in the last few months) change which version of OpenGL you're building against, change shader models, or change any built-in java parameters?

FYI, minecraft still works for me...

What I can confirm is that it worked on my old GTX 570 the last time I ran the program some time last year. I don't believe I've ever tried it with my new GTX 1060 that I got in August.
Last edited by Timeslice; Feb 12, 2017 @ 5:11pm
-Drake Feb 12, 2017 @ 3:48pm 
I'm playing minecraft as well. I've tried everything on the minecraft link that was sent also and nothing works. I guess this is just a game I don't play anymore.
Angry Wasps Feb 12, 2017 @ 6:19pm 
Getting the same problem. All drivers are up to date.

How do I fix it?
DopplerFrog  [developer] Feb 13, 2017 @ 12:29pm 
Originally posted by Timeslice:
I'm having this same issue. I'm on Windows 7 using a GTX1060 with the latest drivers from a couple of weeks ago, and Java 1.8 v121 that I updated yesterday. I have 29 hours of time into the program where it worked just fine, and now it doesn't.

@DopplerFrog Did you recently (in the last few months) change which version of OpenGL you're building against, change shader models, or change any built-in java parameters?

FYI, minecraft still works for me...

What I can confirm is that it worked on my old GTX 570 the last time I ran the program some time last year. I don't believe I've ever tried it with my new GTX 1060 that I got in August.

I did not change the version of OpenGL or LWJGL I build. The only thing I can think of now is that the memory heap that is allocated is to big which I found after a bit more research might be a cause. The heap size for Gridworld is set in the exe launcher file. This exe btw does not use your java but a java run time environment I packed with Gridworld.
Since you have installed java, please try to go to the Gridworld folder and try to run either Gridworld.bat or Gridworld.jar. Since you wont be using the heapsize from the exe file, it should work if this was the problem.
I have also uploaded two new exe files on my itch.io page
https://dopplerfrog.itch.io/gridworld
Please try to replace your exe file with the new exe file.
Also, are you using the exe file when launching? (this is the default)

Originally posted by Ebon Drake:
I'm playing minecraft as well. I've tried everything on the minecraft link that was sent also and nothing works. I guess this is just a game I don't play anymore.

Originally posted by Sol:
Getting the same problem. All drivers are up to date.

How do I fix it?

If you have installed java you can try the same thing as I replied to Timeslice.
If not, please go to my itch.io page,
https://dopplerfrog.itch.io/gridworld

download the exe file

Gridworld_32b.exe (for testing) or
Gridworld_64b.exe (for testing)

I uploaded there and replace the exe file in the Gridworld folder with the new exe file.

Also try this,
1. go to Gridworld/Options/options_settings
2. if the option fullscreen = true, change it to fullscreen = false

I don't know if this will work, please let me know.


Last edited by DopplerFrog; Feb 13, 2017 @ 1:19pm
-Drake Feb 13, 2017 @ 12:47pm 
I'll give that a try when I get home tonight. Thanks again for trying to help.
Timeslice Feb 13, 2017 @ 3:04pm 
Dangit, I thought for sure it would be the heapsize change. I tried running the jar file and the batch file, with the same results. I then tried the 64-bit exe from your itch.io page and ran that directly - still no joy.

FYI, mine is already set to fullscreen false; setting it to true didn't work either.

At this point I have to wonder if the problem is exclusive to the GTX 10X0 (or even 1060) line, or if it was a recent change in the drivers. I wish there was a way to determine if it was working for any 1060 users.

Is anyone in this thread *not* using a 1060 but getting this error?
Timeslice Feb 13, 2017 @ 3:09pm 
If I drop a version of LWJGL into the same folder as the executable will it use that over the built-in library? And are you using version 2 or 3?
Last edited by Timeslice; Feb 13, 2017 @ 3:11pm
Angry Wasps Feb 13, 2017 @ 4:06pm 
im not using a gtx 1060 and still get the error
-Drake Feb 13, 2017 @ 5:21pm 
I'm home. I've tried running the .bat and the .jar file. Neither worked. I tried downloading the 64b executable from the site, that did not work. I tried playing around with the settings text file as suggested and that didn't work either.

I do have multiple Monitors, no idea if that has anything to do with it.
Velvet Torpedo Feb 15, 2017 @ 9:42am 
It plays fine for me on my win10 lenovo laptop, but I get the pixel error on my racing sim pc. Single screen, gtx960 4gb card. nothing I've tried has resolved the issue either
Last edited by Velvet Torpedo; Feb 15, 2017 @ 9:43am
mu Feb 15, 2017 @ 10:36pm 
It now works again with version 378.66 of GeForce driver.
-Drake Feb 16, 2017 @ 10:53pm 
I can confirm, updated to the just released GeForce Drivers 378.66 released on 02/13/2017 and game is working again.
Timeslice Feb 17, 2017 @ 7:00am 
Working here now as well.
< >
Showing 1-15 of 18 comments
Per page: 15 30 50

Gridworld > General Discussions > Topic Details