X4: Foundations

X4: Foundations

View Stats:
EGO_zav  [developer] Dec 1, 2018 @ 1:12pm
Game not starting on Laptops - Investigating
There are quite a few reports from users which all have in common that they are playing on laptops with TWO graphic cards: Usually one integrated one from Intel or AMD and one dedicated often from NVidia or AMD.

The game currently seems to sometimes "guess" wrong which one to open with by default and the game then crashes because the integrated graphiccard does not support our game.

Manually forcing a graphiccard
Starting with version 1.21 there is a new commandline parameter
-gpu:x
where x =
0 = autodetect card (default)
1=1st graphics-card
2=2nd card etc

So you could try for example:
X4.exe -gpu:2
and if that doesn't work, try
X4.exe -gpu:1

You can also add this same setting in config.xml in the games settings folder:
Adding:
<gpu>0</gpu>
in the root section would be default, any other number would fix a selection.

Be careful when editing the config.xml. If it breaks, delete this file entirely to go back to default settings.

Listing of graphic card in settings menu

Note that the game may list the currently does not show which card it is using in the graphics settings. It shows the name of the adapter the monitor is connected to, which is potentially misleading and will be fixed in 1.30.


Power consumption setting

Some users have noted that changing the POWER MANAGEMENT MODE from NVidias 3d settings from "Optimal power" to "Maximum Performance", helped to improve stability on laptops.
Last edited by EGO_zav; Dec 6, 2018 @ 3:05pm
< >
Showing 1-15 of 126 comments
Engine Dec 1, 2018 @ 1:18pm 
Thank you, it doesn't start on my Laptop fitting in mentioned criteria. :)
Xautos Dec 1, 2018 @ 1:25pm 
Keep up the good work Egosoft.
Micknator Dec 1, 2018 @ 1:35pm 
It helped for me to force the nvidia card as a preference in the nvidia control panel. Hope that helps.
SiN Dec 1, 2018 @ 1:56pm 
i noticed this in settings before i started my game. I tried forcing the nvida card but the selection from the game menu continues to use the intigrated card with no option of selecting another card. my game works fine my assumption was that the nvida card was being slaved to run physix's for the game. I guess if this is a known bug then the intigrated card for me must be a beast. go go ASUS ROG's ftw.
timon37  [developer] Dec 1, 2018 @ 2:00pm 
The ingame selection is actually the monitor and the gpu the monitor is connected to. It doesn't select nor reflect the selected vulkan device. Until we fix these issues you can verify which gpu is used by checking utilization or memory consumption for example using "gpu-z".
Last edited by timon37; Dec 1, 2018 @ 2:02pm
Nitack Dec 1, 2018 @ 2:23pm 
Originally posted by timon37:
The ingame selection is actually the monitor and the gpu the monitor is connected to. It doesn't select nor reflect the selected vulkan device. Until we fix these issues you can verify which gpu is used by checking utilization or memory consumption for example using "gpu-z".
This doesn't seem true. I'm getting all sorts of low graphic quality, lag, and glitches, and I have a Nvidia GeForce 970M. It ain't the newest or most powerful GPU, but it shouldnt' be having these kinds of problems, the game is definitely using the integrated card.
Damaelyon Dec 1, 2018 @ 2:33pm 
Originally posted by Nitack:
This doesn't seem true. I'm getting all sorts of low graphic quality, lag, and glitches, and I have a Nvidia GeForce 970M. It ain't the newest or most powerful GPU, but it shouldnt' be having these kinds of problems, the game is definitely using the integrated card.

I totally agree. I try to run GPU-Z and I can tell you "GPU LOAD" never reach more than 10% with a 970M and Intel HD 4600. Vulkan simply don't detect the 970M.
Muri Dec 1, 2018 @ 2:48pm 
Thank you so much for looking into this so quickly I swear, big ups Egosoft 💝 LETS GO TO THE MOON BOIS
MacPage Dec 1, 2018 @ 3:09pm 
keep them coming,good work
bscedarblade Dec 1, 2018 @ 3:32pm 
Yep.... I just bought the game only to find out that it won't launch... Thanks for getting this figured out!
m-tomschi Dec 1, 2018 @ 3:53pm 
It is not only a problem on Laptops, I ve got two graphic cards in my system. The game take the slowest (secondary card), loops the signal through the other Garphic Card (primary) to my primary monitor. The results is nearly unplayable.
MechaTiblisi Dec 1, 2018 @ 4:31pm 
I'm surprised because I have a 960M which was released AFTER the 970 (if I'm reading the release dates on wikipedia correctly) and the game wouldn't run with either the integrated card or just the 960M until I updated to the latest drivers (I tested this by disabling first the integrated card, than the 960M). Once I upgraded it will run on the integrated card, but if I disable that, it won't recognize the 960M...very confused.
Noli_timere Dec 1, 2018 @ 6:42pm 
So from my testing on 3 laptops, all using Integrated and a secondary, It seems that only the intel HD card is found by the game.

My GPU watching app on all 3 laptops does say it is doing something, but it doesnt go past 20%, meaning it isnt doing much at all, so even if the other card is doing something the HD cards are the only ones being used for the bulk.

i will mention all the laptops i have tested on use Nvidia cards, i havent tested AMD, the cards in use are 1050TI, 1060TI, and 1080TI, the 1080TI was the only one that at one point had the 1080TI listed, however that was short lived, and it resumed the same issue as the other 2.

Also all 3 laptops have I7's, and SSD.

Im thinking these people crashing dont have a well suited Intel HD internal, which is what the game looks for in these laptop issues, however i have also tested disabling said Intel card, and on my windows 10 the built in Ram to video app which is basicly a software "FAKE" card, seems to work, if said people want to try and use that, the fake card will partially use your working nvidia or amd card to do the harsh stuff but it wont use it to the full extent, however it may make it playable.

Basicly just disable the internal intel HD card, dont touch your secondary card, this however only works on windows 10, as i dont think 7 had the software in it.

my 2 cents.


edit: the software fake card does need more then 8 gigs of ram to play on low my laptops all have 32 gigs, so i cant say what the minimum it needs, but id guess 10-16 gigs for low to medium.
Last edited by Noli_timere; Dec 1, 2018 @ 6:48pm
xenapior Dec 1, 2018 @ 11:08pm 
NvOptimusEnablement or the likes overrides device information at system level, before starting the program. What interested me is, on my laptop the game always shows the integrated gpu despite it is actually using the dedicated one. Some of my friends also encountered the same "problem" (barely a problem because the game actually runs smoothly).
Last edited by xenapior; Dec 1, 2018 @ 11:21pm
ruojility Dec 2, 2018 @ 1:00am 
For your reference:

Iris Pro P580 (Vulkan supported)
Quadro M2000M (Vulkan supported)

game start
gets to main menu with very low FPS, not rendering all objects at first, then renders and freezes
crash to desktop with no dump message.

tried force nvidia, same result

tried disabling P580, game wont start at all. Dump occurs saying X4 has stopped working, checking for solution, then disappears.

Would have to refund if fix cant be expected soon.



update: Disabling IGC from BIOS did the trick, FPS Is considerably high. Game recognize my M2000M. But A fix Is still necessary, egosoft please dont disappoint us.
更新:通过bios系统关闭集成显卡可以进入游戏。

注:我是强制独立显卡输出视频 不在通过集成卡输出信号。
Note that my Discrete Graphics now handles signal output directly.
Last edited by ruojility; Dec 2, 2018 @ 6:59am
< >
Showing 1-15 of 126 comments
Per page: 15 30 50

Date Posted: Dec 1, 2018 @ 1:12pm
Posts: 126