Planet Centauri

Planet Centauri

Daeminos Jun 9, 2016 @ 5:44pm
Planet Centauri Has Stopped Working
Game crashes immediately after I try to run it. I am running windows 10 pro
Last edited by Daeminos; Jun 10, 2016 @ 11:03am
< >
Showing 1-15 of 40 comments
james3rdeye Jun 9, 2016 @ 6:33pm 
Same here, playing on Mac, OS 10.8.5
ehyder Jun 9, 2016 @ 6:42pm 
I am not having that problem, Mac OS 10.9.5. Have you tried verifying the files through Steam? Every now and again, rarely, I have to also delete a game and reinstall.
james3rdeye Jun 9, 2016 @ 7:00pm 
Tried both verifying and re-installing, and unfortunately it still crashes immediately after clicking play. Oh well, looks like I'll be getting a refund on this one.
onilink_  [developer] Jun 10, 2016 @ 12:51am 
Try to open it with the command line, if there is any log paste it here please.
james3rdeye Jun 10, 2016 @ 1:51am 
as far as I'm aware I can't open it with a command line as I'm using a Mac. I can post the crash log in here if you want but I warn you - it's absolutely massive!
onilink_  [developer] Jun 10, 2016 @ 2:33am 
You have a terminal in osx (try terminal in the finder), you just need to
cd centauri_folder
./PlanetCentauri

For the crash log you can post it in http://pastebin.com/ , but with the bbcode code markup it's also ok :)
Last edited by onilink_; Jun 10, 2016 @ 2:33am
Daeminos Jun 10, 2016 @ 9:50am 
I have a pc so 1 how to you use the command line to start the game?, 2 how do you use pastebin to transfer the crashlogs?
onilink_  [developer] Jun 10, 2016 @ 12:56pm 
Go into the folder of planet centauri (on steam right click on the game, browse local files), then shift + right clic and Open Command Prompt.
Write PlanetCentauri.exe and press Enter.
For pastebin go here http://pastebin.com/
Paste the content of the console and press Create New Paste.
Daeminos Jun 10, 2016 @ 2:23pm 
ok I figured the command prompt out but it is still crashing. But I dont understand what "place the content of the console" means what is the console and where do I find it?
Last edited by Daeminos; Jun 10, 2016 @ 2:29pm
Desolator Jun 10, 2016 @ 4:29pm 
The console is the command window. there should be lines of white text being generated when the game is being launched, you can copy that text with control+C and then paste it where it needs to go.
james3rdeye Jun 11, 2016 @ 1:38am 
Originally posted by onilink_:
You have a terminal in osx (try terminal in the finder), you just need to
cd centauri_folder
./PlanetCentauri

For the crash log you can post it in http://pastebin.com/ , but with the bbcode code markup it's also ok :)

Cheers for the info. Here's the crash log from when I try to open via Steam:

http://pastebin.com/zNuVw0Bi

I tried to open with Terminal but it said there was "no such directory" or something!
Last edited by james3rdeye; Jun 11, 2016 @ 1:39am
onilink_  [developer] Jun 11, 2016 @ 1:52am 
Thank you, but I need also the log of the game.
"no such directory": Maybe you have mistyped the planet centauri folder.
To find the planet centauri folder go into your steam library, right click on planet centauri, and select "browse local files".
james3rdeye Jun 11, 2016 @ 2:17am 
OK great but I'm really not clear on exactly what I need to type into Terminal to get the app to launch from there... could you please give me the exact command to copy/paste into Terminal? It's not a common operation for us Mac users :) I do know however where the Planet Centauri app is located on my HD if that helps.
Last edited by james3rdeye; Jun 11, 2016 @ 2:18am
james3rdeye Jun 11, 2016 @ 2:20am 
It's alright I think I've got it. The error returned by Terminal is here: http://pastebin.com/XPsxQKZU

onilink_  [developer] Jun 11, 2016 @ 6:39am 
Strange, seems to your system don't find the SDL2 dylib (however provided with the game).
In your Planet Centauri steam folder, there is a subfolder lib with libSDL2-2.0.0.dylib ?

You can try to reinstall the game if not. Or to install SDL2 manually.

To install SDL2 manually, the simple way to install libs in mac that I know is brew: http://brew.sh/
When installed go in your command prompt and type:
brew install sdl2
brew install freetype
< >
Showing 1-15 of 40 comments
Per page: 15 30 50

Date Posted: Jun 9, 2016 @ 5:44pm
Posts: 40