Empyrion - Galactic Survival

Empyrion - Galactic Survival

View Stats:
This topic has been locked
EmpyrionGame  [developer] Jan 20, 2016 @ 9:39am
Eleon Studios - Official Public Server
Hi everyone,

we have launched our own public test server. It is called "Eleon Studios - Official Public Test Server."

We are running this public server to gather better data for bug fixing and optimization. Everybody is welcome to join.

Please report any issue / bug you encounter directly below. In particular, if you lose a structure (CV, SV, BA, HV) please report the time and playfield where it got lost.

Thanks for participating and helping to improve the game

- Eleon Game Studios -
< >
Showing 1-15 of 60 comments
Termi Jan 21, 2016 @ 12:45am 
Just started a thread without realizing this topic had been remade and pinned, but after the update, all vehicles in akua orbiit were erased, quite possibly other orbits too, but was unable to check due to logging in to empty space instead of the cockpit of my CV lol
Jalopy Jan 22, 2016 @ 10:13pm 
1. Exiting the hover, found pieces of earth, bushes ect floating in all directions, colours were almost white. Had to exit the game and re-open. once open all was normal I could get back into the hover. This dose not happen every time its random.
2. when opening the Constructor and mousing over an item the info panel dose not come to the front but sits behind and is not readable.
3. Steering the hover is very difficult, Q and E dont work including the arrow buttons. Please can someone assist with this, may be im doing somthing wrong.
Many thanks.
atlana Jan 23, 2016 @ 12:01pm 
v5.2.1 Build 0290 - Win 8.1, 24 GB Ram, i7 core, Nvidia GTX 770

I can't get into Eleons official test server...after clocking CONNECT, it's connectiong, then it seems to load the map (since it is not visible what it's doing in the background) then I get the typical "an internal error occured - continue or Quit & Mail" - If I click Quit & Mail, Empyrion quits and an empty browser window opens (Chrome in my case)

It worked peachy yesterday, logged out w/o a problem nor crash. I can get into other's dedicated servers w/o errors. My GF tried to enter too, as a new chr, with the same error. Issue must be with the Eleon Server

Problem is, I do not have any mail client installed, this is 2016, a lot of people are using the cloud based services for this. You Dev guys need to implement an internal solution that flings a log-file via HTTP to your own servers on its own.
Last edited by atlana; Jan 23, 2016 @ 12:11pm
Foyva Jan 23, 2016 @ 12:20pm 
v5.2.1 Build 0290 - Win10,16 GB Ram, i7 6700k, AMD 390x
I am having the exact same problem as atlana above me. I played fine yesterday then about 30 mins into playing today, as i was coming in from orbit to land on akura is was disconnected(internal error,continue or Quit & Mail,Chrome does not display anything) and i can't get back in. I am able to connect to other servers without issue
Runeshadow Jan 23, 2016 @ 1:15pm 
Same. Can't get in today.
Samuray WildCats Jan 23, 2016 @ 2:31pm 
The day before yesterday was playing on the same server:
1. Have all the items of the four small container SV. Objects are preserved in a small constructor. Field Akua Orbit.
2. After the loss of the cargo containers SV, I flew to the planet Akua. He landed on the island near his home.
I saw the name of his house, but the house has become invisible. I went with the server and went at it again.
I saw my house, but half became invisible ST. I started it and it became visible.
3. I flew to the Akua Orbit. As soon as I appeared at the Akua Orbit, I fell through the cabin.
I was dying, and will choose next, but appeared under the cab. I chose to start on a new, but appeared in the air without pretyazheniya planet and I could fly myself.
I flew on Akua Orbit and found himself under the cab SV. After restarting the server, my SV disappeared.
4. I flew to the planet Omicron (CV) I left the game (one minute) and went again. Half of my ship is gone.
atlana Jan 24, 2016 @ 6:41am 
my Bug's I've encountered (will expand with edits):
Factions:
- if in a faction, self-built SV's can't switch to PUBLIC nor PRIVATE. Choices missing in menu.
Hummel-o-War Jan 24, 2016 @ 11:21am 
Originally posted by atlana:
my Bug's I've encountered (will expand with edits):
Factions:
- if in a faction, self-built SV's can't switch to PUBLIC nor PRIVATE. Choices missing in menu.
Not a bug, but a feature waiting for a "refinement" ;-)
atlana Jan 24, 2016 @ 11:35am 
Originally posted by Hummel-o-War:
Originally posted by atlana:
my Bug's I've encountered (will expand with edits):
Factions:
- if in a faction, self-built SV's can't switch to PUBLIC nor PRIVATE. Choices missing in menu.
Not a bug, but a feature waiting for a "refinement" ;-)
but yet, the options are present if a vehicle is built by the vehicle-factory (F6)
ChrisGail Jan 24, 2016 @ 2:12pm 
I have tested the public server and i have to build two times the needed resources to build a core block and other components. after i hade finished building the needed components some of them dissapear, just gone from the inventory of both my char and the constructor. it has happen to me several times.

You are makeing a good game, continue with your work with the game and fix the buggs that appear.

Thank you.
atlana Jan 27, 2016 @ 2:10pm 
crashed out of server while launching from Omicron Moon into space - can't get in anymore - sorry Neiro, can't pick you up from Akua, i know you're stranded now :(


6595:IOCR, ID_OPEN_CONNECTION_REQUEST
27-23:09:20.793 Playfield 'Omicron Orbit' with seed 33091 loaded.

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Error in reader RPC: ch=1

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

OutOfMemoryException: Out of memory
at (wrapper managed-to-native) object:__icall_wrapper_mono_array_new_specific (intptr,int)

at Assembly-CSharp.OutlineService.AllocateTemplate (Int32 ) [0x00000] in <filename unknown>:0

at Assembly-CSharp.DirectoryContext.AllocateTemplate (System.IO.BinaryReader , WindowScope , Nullable`1 ) [0x00000] in <filename unknown>:0

at Assembly-CSharp.ProjectEditor.AllocateAspect (System.IO.BinaryReader , UInt32 , Boolean ) [0x00000] in <filename unknown>:0

at Assembly-CSharp.ProjectEditor.AllocateAspect (System.IO.BinaryReader , UInt32 ) [0x00000] in <filename unknown>:0

at Assembly-CSharp.ControlType.CleanServer (System.IO.BinaryReader ) [0x00000] in <filename unknown>:0

at Assembly-CSharp.ContextInfo.JoinAddin (System.IO.BinaryReader , Assembly-CSharp.StubLoader ) [0x00000] in <filename unknown>:0

at Assembly-CSharp.ProcessManager.UpdateSymbol (Assembly-CSharp.DeploymentHelper ) [0x00000] in <filename unknown>:0
UnityEngine.Debug:Internal_LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
Assembly-CSharp.RegistryType:CloneActivator(Exception)
Assembly-CSharp.PageType:PrintDevice(Exception)
Assembly-CSharp.ProcessManager:UpdateSymbol(DeploymentHelper)
Assembly-CSharp.PcitureStack:AddWindow(Object)

(Filename: Line: -1)

Connection on channel 1 to server lost

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

27-23:09:43.444 Playfield saving

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

27-23:09:43.449 Unloading playfield 'Omicron Orbit'

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Can't send RPC function since no connection was started.

(Filename: Line: 2480)

Unloading 1 Unused Serialized files (Serialized files now loaded: 2)

Unloading 115125 unused Assets to reduce memory usage. Loaded Objects now: 48838.
Total: 200.253586 ms (FindLiveObjects: 16.925850 ms CreateObjectMapping: 26.232073 ms MarkObjects: 103.863480 ms DeleteObjects: 53.229618 ms)
Last edited by atlana; Jan 27, 2016 @ 2:23pm
Alo Jan 27, 2016 @ 2:25pm 
I'd really like to see the slot-size increased a little. In my experience the smaller servers suffer far less from bugs than larger, more populated servers.

So if it's data you're after; getting more players would help I'd say.
Dobbs Jan 30, 2016 @ 5:09pm 
Just tried out the server everything looked great untill I tried to put down my starter base. It would not let me max bases allowed 90 you need more test servers or increase the number of bases but its nice to see official servers even if it is just a test:steamhappy:
666 Jan 30, 2016 @ 7:21pm 
This baselimit which was reached here forbids building of bases, HV:s SV:s haven't tried CV. Begins to be a big problem on popular servers. Perhaps there should be a few days (realtime) limit after which buildings & vehicles of nonvisiting user are purged? Resetting server tend not to help.
atlana Feb 2, 2016 @ 11:47am 
tried to decent onto the planet Zeyhines in my CV, with "internal Error" results.
after getting back on the server, I'm falling out of the high sky on Zeyhines. made a safe landing in my suit only.
killed my self to get back into CV via "respawn in medicbay" - which i didn't got, only "respawn at death location" or "fresh start"
since it seems that each gamestart deletes the error.log file anew (how about a check, that deletes only, say, log entried every gamestart PAST the last fifth) i have nothing to copy/paste in here

anyhoo, since I lost it all (seems my CV and all that was docked on it disappeared), and you can't copy/paste into 'savegames' on a dedicated server, nor have any other options of retrieval
good bye
fare well
and thanks for the fish!
:steamsalty:
< >
Showing 1-15 of 60 comments
Per page: 15 30 50

Date Posted: Jan 20, 2016 @ 9:39am
Posts: 60