Ver estatísticas:
Psychonauts > Discussões gerais > Detalhes do tópico
Woody 10/fev/2013 às 10:35
Psychonauts Linux - Fails to Start
After downloading then launching the Linux version of Psychonauts, a black window opens momentarily then closes.
I receive the following error(s) in the console:

PSYCHONAUTS UNIX FILENAME: corrected 'workresource/sounds/commonfx.isb' to 'WorkResource/Sounds/commonfx.isb'
GameApp::StartUp InitSoundFiles() completed in 0.13 seconds
GameApp::StartUp Load some common textures completed in 0.00 seconds
WARN: ENGINE: Lua garbage collection starting
FreeUnusedBlocksInBuckets released 0 Kb
ERROR: Assert in /home/icculus/projects/psychonauts/Source/game/luatest/RTEngine/AnimManager.cpp, line 529

Encountered Error:
Psychonauts has encountered an error

/home/icculus/projects/psychonauts/Source/game/luatest/RTEngine/AnimManager.cpp, line 529

Please contact technical support at

Trace/breakpoint trap (core dumped)
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Game removed: AppID 3830 "Psychonauts", ProcID 14992

With lines and lines of "PSYCHONAUTS UNIX FILENAME: corrected ..." before the above console output (seems to be for every asset file for whatever reason).

System Info:
Processor Information:
Vendor: AuthenticAMD
Speed: 3411 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu Raring Ringtail (development branch) (64 bit)
Kernel Name: Linux
Kernel Version: 3.8.0-5-generic
X Server vendor: The X.Org Foundation
X Server release: 11302000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 465/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 313.09
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x6c4
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1680 x 1050
Desktop Resolution: 1680 x 1050
Primary Display Size: 17.05" x 10.67" (20.08" diag)
43.3cm x 27.1cm (51.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: VIA VT1708S

RAM: 7985 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 461263 Mb
Largest Free Hard Disk Block: 216005 Mb

Any ideas or suggestions on getting it working would be greatly appreciated.
< >
Exibindo comentários 16 de 6
Woody 13/fev/2013 às 18:35 
This problem has been moved to the Double Fine forums:
DeadWire 14/fev/2013 às 22:32 
The fact is only 12.04 is currently supported...
Woody 15/fev/2013 às 19:05 
I understand that and am not complaining that it's not working.

I was just seeing if anyone has it working and/or has a solution to the problem.

Also, it may be helpful for the devs if it's not working correctly on an up-coming Ubuntu release.

Aoi Blue 16/fev/2013 às 19:21 
It's now working in Linux as of the latest update. However, it still doesn't support achievements yet. It is now listed on the known bugs for the Linux version.

Edit: Or at least it is for me. I've heard a few people still have issues.
Última edição por Aoi Blue; 23/fev/2013 às 17:11
skitz0frantic13s 24/fev/2013 às 21:56 
I have the latest Steam client (Feb 24, 2013) , Latest Nvidia drivers, Ubuntu LTS 12.04, and the package cache validates. ldd ./Psychonauts reports no missing libraries. Still getting the same issue as woody. Has there been any solution, or does anyone have more recommendations?
skitz0frantic13s 25/fev/2013 às 14:46 
ok... i had initially copy my install from windows and then validated so that it wouldn't have to download the whole game. I "deleted the local content" and installed the whole game through the linux steam client. Now it works. Hope this solution may help others.
< >
Exibindo comentários 16 de 6
Por página: 15 30 50

Psychonauts > Discussões gerais > Detalhes do tópico
Publicado em: 10/fev/2013 às 10:35
Mensagens: 6