Vis statistikk:
nerseus (Dan) 22. des., 2012 @ 19:49
Keyboard misbehaving (always running, esc won't work, etc.)
I'm running Psychonauts under Windows 8 64bit. Game starts, shows intro movie(s) then goes to "Create Profile." The character Ras seems stuck in "forward running" mode as-if I'm pressing forward on my keyboard (this is my best guess). I can press left/right and switch views from empty bed to empty bed, and sometimes I'll see "press space" to create a new profile, but no keys on my keyboard are working. I can't press esc to go to an options menu (assuming there is one?) and I can't press space or enter - heck, I've tried pressing every button on my keyboard, one at a time. My keyboard has a function lock button that I've tried toggling but no help. I can press Alt-Tab to switch back to Windows but that's it. I've tried running the psychonauts.exe manually, from Explorer, with various compatability options (run as Admin, Windows XP mode, and combos).

Googling for answers I've seen others having a similar issue when running under Linux. The common options to fix are: A) go to options and change the input device and B) go into the O/S and disable gaming devices or tweak an O/S ini file to make sure the keyboard acts like a keyboard. It sounds as-if the game sometimes, at least under Linux, thinks the keyboard is a joystick and just acts wonky. As I can't press Esc to go to any sort of options menu, I can't do option A and option B is specific to Linux so no help there either.

I've looked in my Device Manager and I have no game controllers listed - just my usb mouse and usb keyboard. This mouse and keyboard works everywhere else, for windows and games and so on.

I'm at a loss as to what else to try. Suggestions? Maybe a way to manually tweak settings for the game through a file or registry, since I can't access *anything* in-game?
< >
Viser 1-6 av 6 kommentarer
Aoi Blue 25. des., 2012 @ 17:20 
Regardless of platform this is the same set of issues.

First, the game has some issues that the control options seem not to be saving on some people's computers (annoying bug). Go into the game options and hit "set game to default"

Second, the controller may be miscallibrated. If you have a controller plugged in, unplug it, and plug it back in. If the problem persists, press up on the joystick and let it slide back to nutral to reset the forward range.
nerseus (Dan) 25. des., 2012 @ 18:48 
Thanks for the reply although it doesn't help my situation. That is - I can't get to any menu, such as Options, as mentioned previously. Pressing Esc or any key on my keyboard (other than left and right which seems to behave) has no effect. Also, I have no game controller plugged in - joystick or otherwise. I looked under Device Manager to confirm this - it only shows the usb keyboard and mouse.

I'm still looking for a solution to this issue. The details on what I've tried are in the original post.

026 Райдер 18. feb., 2013 @ 5:51 
I have this same issue, is there a fix? I feel ripped off!!
y4747 2. nov., 2013 @ 4:45 
Same issue here - no outside controller, never was. only mouse and keyboard (microsoft), though with windows 7 64bit. same thing happens with another game (anodyne).
IamIamI 22. feb., 2014 @ 2:02 
Did anyone find a fix already? I'm running Windows 8 64bit and keyboard doesn't respond with or without my controller plugged in... and the dude just keeps on running through the beds :S it's like the whole game is bugged instead of just the controls....
nerseus (Dan) 26. feb., 2014 @ 14:36 
I never found a solution. I believe it IS, in fact, the extra controller being detected but I never found a way to disable it. That is, I went to Device Manager and tried disabling various USB and/or game and/or input devices but always had the same result. My computer is jam-packed with add-on cards for music, games, and more.

I did install steam/Psychonauts on a 2nd computer that I know had NO additional game or input controllers and the game worked fine. Doesn't help anyone exactly, but shows that the game does work - just a bit picky about what hardware it is detecting. Would have been great if there were a command line parameter that could specify the exact controller somehow.
< >
Viser 1-6 av 6 kommentarer
Per side: 15 30 50

Dato lagt ut: 22. des., 2012 @ 19:49
Innlegg: 6