Eco
In Single-player /serverui disconnects the game
Yes, your eyes are not playing tricks on you.
So I set up my single-player in a fairly beneficial fashion toward my end, large stacks, long range, the good stuff. However, the day after when I hit continue, many of these options which I had set with these sliders the day before weren't active (thanks for defaulting server configs every ♥♥♥♥♥♥♥ update btw (sarcasm)). So I tried to use the /serverui only to get a angry-red disconnect logo on the lower right corner of my screen, a minute or so passed and I ended up in the main menu.

I hope somebody knows a fix to any of these issues other then to make the configs read only because that is a poor option.
< >
Showing 1-7 of 7 comments
SLG-Dennis  [developer] May 5 @ 3:08am 
Eco does not overwrite configs on updates since several versions, only the .template files are overwritten, so whatever changes your configs, it's not Eco. (Also make sure that you actually press the save button if you change stuff via the Server UI and note that the settings are global for all worlds, so if you create a new world with different settings, the old worlds will also have these)

In regards to the disconnect symbol for /serverui I'll have some tries to reproduce made, thanks for the report. Did you tab out of the game to check if the UI did open nontheless?
Last edited by SLG-Dennis; May 5 @ 3:08am
Thanks for the fast response. The UI never opened. Also the game is unmodified except for the sliders in the create new world settings.
SLG-Dennis  [developer] May 5 @ 4:11am 
Thanks for the additional info. I have tried to reproduce but was not able to, the Server UI correctly popped up immediately and the game tabbed out to display it, while the server was continuing to run fine. What operating system do you use and is there anything else that could be special for your system?
I run windows 10 pro. I reinstalled the game and the /serverui works now. Seems to have been a corrupted file in the previous install, which is strange since I haven't edited any files. However the previous install was from when the game first came out on steam early access. That could be a clue.
SLG-Dennis  [developer] May 6 @ 1:26am 
Oh, then it is very likely that Steam didn't correctly update it, there had been several issues over the years where Steam was unable to correctly update, so full reinstalls were required. Thanks for noting!
As for the other issue where range multipliers where reset on loading, it seems the cause might be related to load order of the files, as the range of the stockpiles are multiplied when they are replaced, but loading default values when loading the game after they have been placed. The stack multiplier seems unaffected by this. However, if you load the game while carrying example 200 food with a weight of 0.01, you will be overburdened, even if you remove everything in your inventory, and it requires you to reload the game with empty inventory in able to reset the weight gauge and be able to pick up things.

Also, I would like to apologize for my outburst in my original post, I was in the wrong and I'm sorry.
SLG-Dennis  [developer] May 8 @ 10:48pm 
In the meanwhile, there is known issues with the storage link range multiplier after restarts which are already fixed for an upcoming minor update. We also found issues relating to the weight multiplier that occur when especially high or low values have been used and other circumstances come together, this is also solved for the next minor update, may entail a limit on the range of the options for now, though, as the problem behind it is a bit bigger than we can fix for a minor update without danger of introducing bigger problems. So, these are actual bugs, do not seem to reset the actual configuration files though, which led me on a wrong track.

Also no worries, all good, really appreciating it though.
< >
Showing 1-7 of 7 comments
Per page: 1530 50