Kingdom Come: Deliverance

Kingdom Come: Deliverance

View Stats:
Deadshot-89 Feb 13, 2018 @ 12:00pm
FIX for micro-stutter & freezes in towns. HOW TO disable V-sync & more. Read!
First, a little bit of background. I was experiencing performance problems in populated areas, with my GTX 1070 and latest drivers. I would get (small) freezes in towns, and also big and weird framerate drops. Half second long annoying drops, that repeat itself. Game runs fast and smooth for a while, then a fps drop. Then smooth for a little while, another drop. Then smooth, oh wait now it freezes for a second. There was micro-stutter in populated areas. I noticed the framerate tried to lock itself to 60 with V-sync, and immediately suspected that that was causing all these issues. I searched for a V-sync toggle in the in-game menus, but found none. So, I had to disable V-sync in a different way.

+++ ESSENTIAL GUIDE FOR DISABLING V-SYNC +++

Do this to disable V-sync for Kingdom Come: Deliverance, and enjoy a great improvement in how fluidly the game runs. The below instructions also cover how to set an FPS cap:

- in-game, make sure to select the Fullscreen display option (so not borderless, or windowed). Now exit the game.
- go to the install directory (by default, this is: C:\Program Files (x86)\Steam\steamapps\common\KingdomComeDeliverance)
- make a new file called user.cfg, place it in the install directory
- open the new file in notepad
- write the following in the file:

r_VSync = 0
sys_MaxFPS = 75 **(or a different value of your choosing)**

- save the file and then close it (make sure the file is called user.cfg, and NOT user.cfg.txt)
- start the game. Make sure the game runs in fullscreen mode, and verify that you can see some tearing here or there (if you have no G-sync, like me), since V-sync is off

sys_MaxFPS = 75 sets the maximum fps, choose a value to your liking. I have a 60 Hz display and I set it to 75. Works well for me. I recommend against setting it to 60 for a 60Hz display, as that causes crazy tearing in a lot of games (didn't test it here though). I don't have Gsync.

If you only want to disable Vsync, and don't want to enforce an FPS cap, just skip the second line. You only need to put r_VSync = 0 in the file.

+++ DOES IT WORK? +++

Yes, the fix works amazingly well. Almost all the micro-stutter in populated areas has disappeared for me. The (small) freezes have gone away completely. No more weird framerate drops, where it runs fast for a while, then slow for half a second and so on. The performance is pretty consistent now, and it looks really fluid. I'm very happy with the end-results.
Is there a catch? Not really. But disabling V-sync can of course lead to a little bit of tearing here and there, if you have no G-sync monitor like me.


PS. In-game, you can quickly bring up the console with tilde (~), and use the following commands:
r_VSync 0
sys_MaxFPS 75
This doesn't stick though, restart the game and the changes are gone. Therefore I recommend putting the changes in the user.cfg file, since those changes persist. But the console is good enough for some quick experimentation, for example with different cap values.

PPS. Warhorse Studios should add the V-sync toggle to the in-game menus, as soon as possible! The game runs so much better with V-sync disabled. It's quite an oversight not to include the option in the menus...
Last edited by Deadshot-89; Feb 13, 2018 @ 12:08pm
< >
Showing 1-15 of 79 comments
Player#1 Feb 13, 2018 @ 12:03pm 
Yes, this method works :Likes:
I have got GTX 960 2Gb and I locked FPS to 30 by Bandicam. Micro-stutters has gone.
Last edited by Player#1; Feb 13, 2018 @ 12:08pm
ApoKGG Feb 13, 2018 @ 12:07pm 
I have huge freezies in first village, like for 3-4 sec, will try this later
Deadshot-89 Feb 13, 2018 @ 12:23pm 
Originally posted by ApoKGG:
I have huge freezies in first village, like for 3-4 sec, will try this later

Make sure to report back!! Hope it helps you out!

Do note that these things also depend on your system's specs, and your in-game settings, of course. On a weakly specced machine, you want to run way lower settings than on a monster machine. And the game released a bit buggy, so this fix will not solve all issues. But it's still a really important fix, and it should help all users who have fps drops below 60 fps. The fix can remove micro-stutter and freezes etc.
Goim Feb 13, 2018 @ 12:30pm 
didnt do the trick for me , still got those anoying freezes :/
Homeless. Feb 13, 2018 @ 12:50pm 
Nope, the same for me, fps is stable but I'm constantly freezing on whatever setting I choose. Even in cutscenes/conversations/looking at the damn wall...
Scientist Feb 13, 2018 @ 12:52pm 
Drivers ? I still use the nvidia 390.65 and i have no problems
Bane Feb 13, 2018 @ 12:53pm 
Don't work for me :/ Just menu fps 60 to 120 but in game stuttering same.
TheProScout Feb 13, 2018 @ 12:53pm 
Originally posted by Boogreen:
How do you create a user.cfg file that is not .txt too?
in notepad go to Save as, and under Save as type: choose All Files, and then rename it to user.cfg
Last edited by TheProScout; Feb 13, 2018 @ 12:56pm
Deadshot-89 Feb 13, 2018 @ 12:57pm 
Originally posted by Bane:
Don't work for me :/ Just menu fps 60 to 120 but in game stuttering same.

Did you try different and lower values for the FPS cap? Especially on slightly weaker machines, putting a lower FPS cap in place can alleviate stuttering.

Try:

r_VSync = 0
sys_MaxFPS = 50

Or:

r_VSync = 0
sys_MaxFPS = 45

Or:

r_VSync = 0
sys_MaxFPS = 40

Lowering settings (try medium or low f.e.) can also help alleviate stuttering.
Goim Feb 13, 2018 @ 1:02pm 
i´ve got the newest driver , lowerd anything , tried different MaxFPS ,Fullscreen,Window,Borderless, also tried another fix by changing physx to either GPU or CPU - still unplayable :rcry:
Deadshot-89 Feb 13, 2018 @ 1:05pm 
Originally posted by ⎛ CatWeazel - Elec-Trickery ⎞:
Originally posted by Boogreen:
How do you create a user.cfg file that is not .txt too?
in notepad go to Save as, and under Save as type: choose All Files, and then rename it to user.cfg

Correct.

An alternative:
- right click in windows explorer, on white space. Choose "New" and then "Text document". Remove everything, including the extension (.txt). Now simply type user.cfg and enter. Now simply open the file with notepad, which can also be done by means of drag and drop.

It's really important that you get this right, guys. The file doesn't work if it's called user.cfg.txt. I've already had feedback from someone in a different thread, who said the fix didn't work, and this was the mistake that he made... The extension he used was .txt.
Goim Feb 13, 2018 @ 1:07pm 
nope i´ve made a cfg :/ - the fps were locked so it should had worked :|
pflaumenkuchen1 Feb 13, 2018 @ 1:30pm 
worked wonderful thank you dude.
SerPrizes Feb 13, 2018 @ 2:11pm 
This worked for me!
I have 1080 ti and 8700k, getting good fps now!
Also a tip: when writing the document file, rename it as user.CFG with the capitalized CFG. It didn't work for me until I did that.
Deadshot-89 Feb 13, 2018 @ 2:41pm 
Originally posted by pflaumenkuchen1:
worked wonderful thank you dude.

I'm glad!!

Originally posted by a lost 10mm socket:
This worked for me!
I have 1080 ti and 8700k, getting good fps now!

Awesome!

Now it's really up to the devs to just put that Vsync option in the in-game menu, where it belongs!
< >
Showing 1-15 of 79 comments
Per page: 15 30 50

Date Posted: Feb 13, 2018 @ 12:00pm
Posts: 79