Kingdom Come: Deliverance

Kingdom Come: Deliverance

View Stats:
saiint Feb 13, 2018 @ 9:22am
a tip for all those with FPS issues.
It seems that this game really struggles with RAM allocation. If you have 16 or more gb, use the command "-heapsize 2097152" in launch options. If you have 8gb use "-heapsize 1048576". this will allocate ram to be used as a cache for the game. For me it nearly doubled FPS and made it near constant (IE there were little to no lag spikes). Hope this helps!

jfc dont set a cache that''s bigger than about an 1/8th of your overall ram, it'll likely lower FPS rather than increase it.
< >
Showing 1-15 of 268 comments
G.Strategos Feb 13, 2018 @ 9:31am 
A question if I may. How to use the command ?
Cheers.
Transflux Feb 13, 2018 @ 9:33am 
Originally posted by G.Strategos:
A question if I may. How to use the command ?
Cheers.
Typically console commands are entered by pressing the ~ key (left of 1 on a QWERT keyboard). Though could be different for this game.
G.Strategos Feb 13, 2018 @ 9:35am 
Yeah...I haven't tried it yet, so I just wanna to be sure.
Wardiaper Feb 13, 2018 @ 9:37am 
Originally posted by G.Strategos:
A question if I may. How to use the command ?
Cheers.
Right click game > properties
Under general tab click "set launch options"
Put saint's command above in that box
Gromak Feb 13, 2018 @ 9:38am 
Hes talking about launch options, you have to do it in the Properties of the games .exe
G.Strategos Feb 13, 2018 @ 9:38am 
Originally posted by Wardiaper:
Originally posted by G.Strategos:
A question if I may. How to use the command ?
Cheers.
Right click game > properties
Under general tab click "set launch options"
Put saint's command above in that box

Originally posted by Gromak:
Hes talking about launch options, you have to do it in the Properties of the games .exe

Thank you both. I appreciate it. Do you know if it's really working ?

Cheers.

Last edited by G.Strategos; Feb 13, 2018 @ 9:40am
This should be stickied. Now I get <50 FPS even in pretty populated areas. Awesome!
G.Strategos Feb 13, 2018 @ 9:48am 
So it works..Yeap it should be stickied then.
Definitely needs to be stickied. Took me from low 20's to constant 60.
FX 8350
GTX 1070TI
16GB DDR3

Shadows physics etc at medium (Weaker CPU)

Object detail, Shader, Water Detail, Textures etc etc at ultra.
Dead4Life Feb 13, 2018 @ 9:51am 
well thanks man! I now have 60 fps as well!
Bucket Feb 13, 2018 @ 9:54am 
Hmm, tried this but still getting the same performance (I have 16gb RAM) think it'd be worthwhile trying the 8gb setting instead?
twitch.tv/BurdBurd Feb 13, 2018 @ 10:00am 
@Bucket, reset the in-game settings, then re-apply them manually.
Don't be overzealous with the settings either. Even at medium the shadows and other effects are what other games would classify as "Ultra"
Basil Feb 13, 2018 @ 10:00am 
bump, people need to see this
Slimdragoon Feb 13, 2018 @ 10:01am 
Putting in the code for 16G of ram dropped my fps by like 8 and im still getting 2 second freezes every minute or so. How do I reset back to normal?
Last edited by Slimdragoon; Feb 13, 2018 @ 10:02am
Jiāng-shī 殭屍 Feb 13, 2018 @ 10:02am 
For 12 gb?
< >
Showing 1-15 of 268 comments
Per page: 15 30 50

Date Posted: Feb 13, 2018 @ 9:22am
Posts: 268