Hadean Lands

Hadean Lands

Hadean Lands > General Discussions > Topic Details
Game will not start
I've tried running this game, and it just will not start for me. I've looked for forums about the issue, run on administrator, verified integrity, uninstalled and reinstalled. All I get is a command box that pops up for a couple seconds and then closes out. I'd really love to try the game and not have to ask for a refund. Any suggestions or ideas?
< >
Showing 1-8 of 8 comments
zarf_home  [developer] May 8 @ 7:02pm 
I haven't seen this sort of problem reported. What OS?

What do you mean by "command box"? Does it contain the opening text of the game? (The Mandeville quote.)
Arikail May 9 @ 1:48am 
OS is Windows 10 Home, 64 Bit.

COmmand Box I mean the Windows command interface, as in the black box with white letters where it asks you to enter commands, like "Change directory", as an example.
And I have no idea what it actually is, as it flashes up for half a second before it closes down. That's all I get when I try to do anything with the game. It's rather disappointing, but I'm hoping we can find some way to get it going.

I've looked in the file structure, and it looks like it has some html pages. Could I potentially use one of those to run the game?

Edit: When I try running the one that says "Play.html" in Google Chrome and in Firefox, all it does is give me a "loading" graphic.

Last edited by Arikail; May 9 @ 1:55am
zarf_home  [developer] May 10 @ 12:36pm 
Thanks for the details.

> Could I potentially use one of those to run the game?

The interpreter is written in Javascript, but it uses Node.js so it won't run in a regular web browser.

There's a file in there called "HadeanLands.gblorb". This is a portable IF game file; it will run in most major IF interpreters. (You'll just be missing the game-specific UI features -- the interactive map and journal windows.)

You can try Gargoyle, which is a bit old but should work: https://github.com/garglk/garglk/releases

There's also WinGlulxe: http://ifarchive.org/indexes/if-archiveXprogrammingXglulxXinterpretersXglulxe.html

The third option is Lectrote: https://github.com/erkyrath/lectrote/releases . The HL app is a customized version of Lectrote, so you might see the same bug. But could you test it anyway? If Lectrote *does* run on your machine, then I can probably upgrade the HL app to get the fix in.

Sorry you're having trouble.
Arikail May 10 @ 7:04pm 
Thank you!!! Tried Lectrote first, the Lectrote-1.2.5-win32-x64.zip download, and that works. Opened up and ran just fine after finding the Hadean Lands glulx file (one of the only ones it let me click on when I ran the file).
zarf_home  [developer] May 11 @ 12:03pm 
Okay! That's useful to know. Updating the Lectrote engine in the HL app was a low priority, but I'll kick it up the queue.

(Of course, no guarantees -- the problem might be a weird interaction between the Steam app and the HL app. I don't have any real idea what's going on, I'm just trying things.)
Arikail May 11 @ 4:31pm 
Totally understand that. And greatly appreciate it.
zarf_home  [developer] May 14 @ 1:21pm 
I've posted a new release (2.1.0) in the beta release channel. I'm hoping it fixes the problem you were having...
Arikail May 15 @ 12:28am 
That absolutely fixed it!!!!
Thank you. Now I get to go enjoy your game. :)
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Hadean Lands > General Discussions > Topic Details