The Isle

The Isle

View Stats:
The Isle > Bugs/Troubleshooting > Topic Details
Outdated Client? Check this!
Have you received an error when connecting to a server, that says your client is outdated? There's probably a good reason and an easy solution for this. First, check the version of the game you're running. You can find this on the main menu of the game. At the time of writing this, that will normally say 0.1.51.8. In order to connect to a server, your game version must be the same as the server's. If you're not able to connect, they might be different. Again, at the time of writing this, there are actually two game versions available: 0.1.51.8 and 0.1.51.9.

"But Sour," you ask. "Why are there two versions and how do I get the newer one?" That's good. That means we're learning.

0.1.51.8 in this case is part of what's called the Public or Live Branch of the game. 0.1.51.9 is (currently) part of the Development Branch. Dev branch is usually a version or two ahead of the public branch, and is used to help develop the game. It is more prone to having bugs, server crashes, etc and this version of the game helps the developers iron out these problems. Once everything is fixed and they're satisfied with it, this version is then pushed to the public branch and becomes the main version of the game.

You can freely switch between these two versions. To do so, simply:

1) Right-click The Isle in your Steam library.
2) Select Properties.
3) Select the Betas tab in the menu.
4) Use the drop-down menu on this screen to select the version of the game you want. "NONE" is the standard public branch. Development branch is, obviously, the developement branch. Legacy is an extremely outdated version of the game that is no longer officially supported but can be used if you wish.

... And you're done! The only catch is, like I said, you can't play on a server with a different game version than yours. Just keep this in mind and enjoy the game!
Last edited by Souretsu; Jan 13 @ 6:21pm
< >
Showing 1-15 of 128 comments
21leighton_ski Apr 19, 2018 @ 2:01pm 
Outdated Client???
Every time I try to join any server it keeps saying I need to restart Steam, update the game and try again, but there doesn't appear to be any update available even after what I think I restarted Steam. Someone tell me what I'm doing wrong because I would really like to play the game but I haven't been able to for weeks because of this.
Punchpacket  [developer] Apr 19, 2018 @ 3:12pm 
What operating system are you on?
SilverThrace Apr 20, 2018 @ 12:02am 
I have a similar issue. When I try to start the game it says I am on version 1.33 and the client is on 1.369. I don't see a way to update it. The error says your game is out of date. Please restart steam and update and try again. I have restarted steam but there is no update. I play on a Mac version Mac is high Sierra version 10.13.3 on a MacBook pro.
Punchpacket  [developer] Apr 20, 2018 @ 7:42am 
Originally posted by SilverThrace:
I have a similar issue. When I try to start the game it says I am on version 1.33 and the client is on 1.369. I don't see a way to update it. The error says your game is out of date. Please restart steam and update and try again. I have restarted steam but there is no update. I play on a Mac version Mac is high Sierra version 10.13.3 on a MacBook pro.

Ah, that'd be why. Mac support is temporarily halted while we solve some issues with the Mac builds, as well as an Unreal Engine rendering issue. It was mentioned in our patchnotes not too long ago.
21leighton_ski Apr 20, 2018 @ 8:43am 
Ah ok, so there isn't anything I can do at the moment. Guess I'll just wait for it to be fixed then. Thank you!
SilverThrace Apr 21, 2018 @ 7:54am 
Oh okay thank you Punch I had just gotten the game yesterday so I was unaware Mac had been halted. I'll just hang tight till it is fixed, have a good day
Mr. Diversity Dec 29, 2018 @ 8:20am 
The isle says I have an "outdated client"
I've tried everything, tried switching from dev to normal then back, tried restarting my computer, tried restarting steam, tried uninstalling and reinstalling, PLEASE HELP ME
Mountain Head Dec 29, 2018 @ 8:40am 
I'm having the same problem and it's really annoying because I really wanna play this game. Do the developers know about this?
Salt® Dec 29, 2018 @ 8:40am 
Yeah same to me, with only few servers though, that are those in which i have my progress.
I have no mac, playing in pub/dev branch and tried running steam as admn.
What's this problem?
Drakourn Dec 29, 2018 @ 9:00am 
i am having the same issue
Punchpacket  [developer] Dec 29, 2018 @ 9:12am 
Originally posted by Saltysfied®:
Yeah same to me, with only few servers though, that are those in which i have my progress.
I have no mac, playing in pub/dev branch and tried running steam as admn.
What's this problem?

What server were you trying to join while playing on Dev Branch? If your game is set to Dev Branch I believe the only servers you'll have available are the official dev ones. Servers like Official EU are still on public.
Last edited by Punchpacket; Dec 29, 2018 @ 9:12am
juleskelly888 Dec 29, 2018 @ 9:13am 
having the same problem here
Zentrik Dec 29, 2018 @ 9:21am 
I'm having the Same problem but cannot connect to any servers
Jormungand Dec 29, 2018 @ 9:58am 
Originally posted by Punchpacket:
Originally posted by Saltysfied®:
Yeah same to me, with only few servers though, that are those in which i have my progress.
I have no mac, playing in pub/dev branch and tried running steam as admn.
What's this problem?

What server were you trying to join while playing on Dev Branch? If your game is set to Dev Branch I believe the only servers you'll have available are the official dev ones. Servers like Official EU are still on public.
im having the same issue as well i cant get onto and of the servers that say 0.1.51.9 it tells me my game is out of date but i havnt seen any update for my game in event reinstalled it still same issue im still able to get on the older version of servers though
Originally posted by Punchpacket:
Originally posted by Saltysfied®:
Yeah same to me, with only few servers though, that are those in which i have my progress.
I have no mac, playing in pub/dev branch and tried running steam as admn.
What's this problem?

What server were you trying to join while playing on Dev Branch? If your game is set to Dev Branch I believe the only servers you'll have available are the official dev ones. Servers like Official EU are still on public.
i might try getting on public... ive tried so many things trying desperatly to get on servers and only 1 server worked
< >
Showing 1-15 of 128 comments
Per page: 15 30 50

The Isle > Bugs/Troubleshooting > Topic Details
Date Posted: Jan 13 @ 10:51am
Posts: 128