Concealed Intent

Concealed Intent

View Stats:
 This topic has been pinned, so it's probably important
jarrahtech  [developer] Nov 8, 2015 @ 2:55am
Problems/Issues/Bugs
If you find something that doesn't look right, please let me know in here! I'll keep a list of common issues/fixes.

  • On Linux, some combinations video card and driver cause problems with Unity and prevent the game starting. If on Linux the game refuses to start try adding the launch parameter -force-opengl. This can be done in the Steam client by right-clicking on Concealed Intent in the library -> Properties -> Set Launch Options and then adding the parameter above into the text box.
  • On some Macs the Steam Overlay causes problems on startup and freezes the game. If this occurs please turn off the Steam Overlay for just Concealed Intent. On your Mac open Steam and go to your library, select and right-click on Concealed Intent and choose Properties. On the General tab of Properties is a checkbox for Steam Overlay - ensure it is unchecked.
  • Avast anti-virus may mark the game executable as a threat. This is definitely incorrect and a false-positive. The game will not do anything unexpected in a game. A quick check online shows there are many reports of false positives with Avast, but there is solution (supposedly). In the Avast program, click on "Setting" under the "Options" menu, there should be an Exclusions list that allows certain folders or file to be removed from checking - add Concealed Intent to this list. The process is described on page 40 of the manual: http://files.avast.com/files/manuals/user-manual-home-eng.pdf
Last edited by jarrahtech; Oct 22, 2016 @ 7:25pm
< >
Showing 1-15 of 39 comments
geegii Nov 24, 2015 @ 1:19pm 
I just bought the game, I am under Win 7 SP1 with GTX680 video card 16 Mb RAM with Core i7-3930 on 64 bits and when lauching the game, turining for 1 or 2 minutes and then Steam shut up. Tried several times, restarted PC and still the same. Please help....
jarrahtech  [developer] Nov 24, 2015 @ 4:02pm 
Hi, I have run it on slower PCs so that should not be a problem.

Can you please send me the log. It should be in C:\Program Files\Steam\steamapps\common\Concealed Intent\ConcealedIntent_Data\output.log (assuming you installed Steam to the standard place on the C drive, adjust as appropriate.

Also, what was the game doing at the time of the crash? Showing the main menu, in a tutorial, mission or skirmish?

What do you mean by "Steam shut up"? Did the game hard crash to desktop? Did it just hang unresponsive to input? Did Steam crash too?

Thanks for your help.

[Update:] A better way to find the log file is go to your library in Steam, right-click on Concealed Intent, choose Properties from the menu and then go to Local Files tab. From there click the Browse Local Files button and then under the COncealedIntent_Data folder should be the output_log.txt file (which is what I need). Thanks.
Last edited by jarrahtech; Nov 25, 2015 @ 5:30pm
FridayBiology Nov 24, 2015 @ 5:35pm 
I'm not able to actually load the game, when I attempt to launch steam and first time launch window become unresponsive. :worker:

output.log not found/generated
jarrahtech  [developer] Nov 24, 2015 @ 5:54pm 
Are you using a Mac? If so please turn off the Steam Overlay. Right-click on the game in your library -> Properties -> General & un-tick "Enable the Steam Overlay while in-game"
Last edited by jarrahtech; Nov 24, 2015 @ 6:10pm
FridayBiology Nov 25, 2015 @ 9:16am 
Originally posted by jarrahtech:
Are you using a Mac? If so please turn off the Steam Overlay. Right-click on the game in your library -> Properties -> General & un-tick "Enable the Steam Overlay while in-game"

Windows 10, :'(
jarrahtech  [developer] Nov 25, 2015 @ 5:24pm 
FridayBiology,

Ok, how far do you get?
Do you see the "Preparing to Launch" dialog box that Steam pops up?
Do you see the Concealed Intent splash screen?
Do you see anything if you try to run the ConcealedIntent.exe from the command line?
Could you try turning off the overlay anyway?

Can you try verifying the integrity of the game cache (Library -> right-click ConcealedIntent -> Properties -> Verify … button on the Local Files tab)?

The output_log.txt is created before my code is reached (it is written by the engine I use). So my first thought is there is some incompatibility between Steam, Win10 and/or that engine (Unity3D). The problem is getting some kind of error message to narrow down the possibilities.

Other suggestions from people online are:
* try windows 8 compatibility mode
* "I turned off the DVR and Live tile wrapper or whatever it's called from the Xbox app"

I see you sent me an email - would you prefer we work on this that way? Fine by me either way.
FridayBiology Nov 25, 2015 @ 9:19pm 
fixed, right click steam, launch steam in windows 8 compatible mode for first time launch.
something up with that first time start as seems to be good running without the compatible mode now.

:worker:
jarrahtech  [developer] Nov 26, 2015 @ 1:18am 
FridayBiology, thanks and glad to hear it is all sorted. I'll add your workaround to the top section, but continue to look for the deeper solution so the workaround is not necessary. It can't just be Win10, I found another person to give it a try, so must be something more complex.
Scorpius Aug 3, 2016 @ 3:45am 
hi! my mousewheel does not work. neither in the menu nor the game itself. i'm on the latest macOS. nice game mechanics, but interface feels a little "clunky" without the mousewheel.
Last edited by Scorpius; Aug 3, 2016 @ 3:46am
jarrahtech  [developer] Aug 3, 2016 @ 5:53am 
Hi Scorpius (that was a good show),

Thanks for the bug report. My mac doesn't have a mouse wheel. That will be why I didn't spot it earlier. My apologies. Can you tell me what sort of mac and mouse you have and I'll see if I can get the hardware to recreate the issue.

Are you using the mouse wheel for scrolling the component lists & missions in the menus and zooming in/out in the scenarios, or in some other manner?

Also, did you leave in-game feedback for that bug? I can see someone did, but it is anonymous so I don't know who.

Thanks,
Charles.
Last edited by jarrahtech; Aug 3, 2016 @ 5:55am
ÜberSomething Aug 7, 2016 @ 3:06am 
Encountered a blocking bug in the campaign selection. I played the tutorials and the "Scatter" mission, then quit the game when the second mission started (after the intro IIRC - when I would have started playing).

After restarting the game, the campaign screen looks like this:

http://steamcommunity.com/profiles/76561197993446283/screenshot/1617175662592180123

Selecting one of the "same" missions still shows different texts on the right side.

Starting "Scatter" again works normally, starting any other mission gives me an empty 3D view. I can rotate the grid, but nothing else works. I also can't bring up the menu, the only way out is to terminate the game with Alt-F4.
ÜberSomething Aug 7, 2016 @ 3:21am 
I also encountered an issue trying to play a skirmish game. The match seems to start normally, but a lot of the UI elements seem to be missing, for example the selection markers, movement lines, and a lot of the info in the bottom panels:

http://steamcommunity.com/profiles/76561197993446283/screenshot/1617175662592215064

I can select ships using tab, and the camera moves to them, but they are not marked as selected. In the bottom left, sometimes their names are shown, sometimes they only flash briefly and then disappear. I don't know the game well enough to say what else is missing, but it's a lot different.

Restarting the game does not change anything, and all files validate successfully in Steam.
ÜberSomething Aug 7, 2016 @ 4:46am 
Here's the log file (username redacted): http://pastebin.com/p4S58Rkk
ÜberSomething Aug 7, 2016 @ 4:58am 
Not a bug, but something I noticed: The user's profile seems to be located in Appdata\LocalLow.... shouldn't it be in AppData\Roaming or similar? I'm not an expert on Windows conventions, but I always thought LocalLow was for throwaway data like caches, temp files etc.
jarrahtech  [developer] Aug 7, 2016 @ 5:30am 
Hi UberSomething,

That is definitely a bug! Many thanks for reporting it and sending through the log - that is just what I needed. Taking a look at the log, it seems that the profile has been corrupted somehow. How did you quit the game after the Scatter mission? I guess the profile was being written at the time of the quit, and got messed up. That should not happen no matter how you quit, and I will investigate.

In the meantime, you can remove your profile safely without issue. As long as you don't mind it being restart to the start. Hopefully this is not a problem for you since you are only one mission in (and that first one can be skipped anyway). The only problem will be that Steam's cloud save will keep putting the file back. Here is how to get rid of it permanently:

1) Start the game in Steam
2) go to LocalLow (as you have found) and delete default.dat (under Jarrah Technology/Concealed Intent)
3) Now quit the game - steam should detect the file is gone and remove it from its servers.
4) Restart the game and a new one should be created.

Does that make the problem disappear?

Thanks,
Charles.

---

The use of LocalLow. The location of the file is set by the game engine I'm using (Unity3D) as the game just uses the default data location set. However, I have also set Steam Cloud Save, so the data can be wiped (when the game is not playing) and Steam will replace it when it starts again. So I think it should be fine if its is treated like a cache. As another plus, if you play Concealed Intent on a new computer, Steam should copy down your profile so you can continue where you left off on the first computer.
Last edited by jarrahtech; Aug 7, 2016 @ 6:27am
< >
Showing 1-15 of 39 comments
Per page: 15 30 50