Halcyon 6: Starbase Commander (CLASSIC)

Halcyon 6: Starbase Commander (CLASSIC)

View Stats:
Schnitzelfee Apr 21, 2016 @ 3:13am
The game starts on the wrong monitor/no way to select output monitor
Hi guys,

I have the problem that the game only starts on my secondary monitor and not my primary.

I can of course use windowed mode an just move the game over to the other monitor, but cause my secondary monitor is used in portrait mode the game only lets me choose vertical resolutions and the aspect ratio is all wrong.

Long story short, please ad a option to select the monitor in game or please change it so that the game starts always on the primary monitor.

edit: got the game to show me horizontal resolution options after some restarts, but something is still not working right with two monitor setups :)
Last edited by Schnitzelfee; Apr 21, 2016 @ 3:20am
< >
Showing 1-8 of 8 comments
cassentra Apr 21, 2016 @ 12:55pm 
We've heard that and unfortunately, it's something we haven't addressed yet, Schnitzelfee. Nefron kindly posted a workaround in another thread that might help?

Originally posted by Nefron:
Multiple monitors fix: (Generally works with any Unity game)
  1. Right click the game in your steam library and click properties.
  2. On the General tab click the "Set launch options" button
  3. Enter "-popupwindow" (without the quotes)
  4. Click OK and close the properties window
  5. Launch game and uncheck the full screen option in graphics

This allows the user to click out of the game without it automatically minimizing and also places it on your primary monitor instead of straddling both monitors on startup.
Cobell Apr 21, 2016 @ 12:59pm 
I've got another work around for you guys as I've encountered this problem in other games and applications.

Windows has the following shortcut to move the current active window between different monitors:
Windows Key + Shift Key + Left/Right Arrow


Note: I believe this shortcut started in Windows 7; I can only personally confirm Windows 8.1 and 10

Last edited by Cobell; Apr 21, 2016 @ 1:04pm
wahwah Apr 21, 2016 @ 2:08pm 
Noticed the same thing, just switched to windowed in the game options, dragged the window on to my main screen, switched back to fullscreen and it stayed there
This is Cyp Apr 21, 2016 @ 7:00pm 
windows + shift + left/right arrow worked. It would be nice if there was a way to change the monitor in game through the UI. Thanks. I also have a second and third monitor that are in landscape and portrait
Schnitzelfee Apr 22, 2016 @ 3:37am 
Thanks for the tips guys :)
my second monitor is in portrait mode and the resolutions cannot be changed to landscape.

I see the patch notes and I will wait for an update. game seems like it will be funs.
Last edited by BoDC.C | Never Makes My Steaks™; May 11, 2016 @ 5:39pm
hurleybird Jun 18, 2016 @ 8:21pm 
Hey guys, this is an issue with quite a few Unity applications where the default launcher is disabled. In windows, you can set the launch options of Unity apps in the registry:

  1. Open Regedit
  2. Navigate to HKEY_CURRENT_USER\SOFTWARE\MASSDMG\Halcyon6
  3. Change the value of UnitySelectMonitor to whatever is appropriate

Cheers!
Last edited by hurleybird; Jun 18, 2016 @ 8:27pm
Originally posted by hurleybird:
Hey guys, this is an issue with quite a few Unity applications where the default launcher is disabled. In windows, you can set the launch options of Unity apps in the registry:

  1. Open Regedit
  2. Navigate to HKEY_CURRENT_USER\SOFTWARE\MASSDMG\Halcyon6
  3. Change the value of UnitySelectMonitor to whatever is appropriate

Cheers!

thank you! i deleted my redundant thread. thank you so much and damn i should of found this. i will remember this next time a unity game gives me this trouble.
Last edited by BoDC.C | Never Makes My Steaks™; Jun 20, 2016 @ 3:55pm
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Apr 21, 2016 @ 3:13am
Posts: 8