The Enchanted Cave 2

The Enchanted Cave 2

View Stats:
dustinaux  [developer] Apr 3 @ 8:18am
Version 3.0 MEGA UPDATE Open Beta Testing
The new MEGA UPDATE and all the content that comes with it is now available for open beta testing! The announcement with details on the new content is here, so read that first if you haven't already. If you'd like to try out the new features and help me iron out any remaining bugs that I may have missed, then you're in the right place.

To use the beta build:
Right click on The Enchanted Cave 2 in your steam library
Click Properties
Click the Betas tab
Select the beta from the drop-down box, and steam should automatically update your build.

IMPORTANT! Backup your saves!

The update saves game data in a way that is incompatible with older versions, so it is highly recommended that you backup your saves first in case you need to roll back to the current live version.

On Windows your save files are the .sol files located at C:\Users\YOUR_USERNAME\AppData\Roaming\okshur\Enchanted Cave 2
(The AppData folder is hidden so you’ll have to show hidden files or just go to the full path)

On Mac the files are located at /Users/USERNAME/Library/Application Support/Enchanted Cave 2

On Linux the files are located at ~/.config/com.okshur.enchantedCave2

Copy all the files there into a new folder for safe keeping.

This update is big, and adds a lot of new stuff! Here are some things to consider:

  • The new controller support is probably the biggest change, and there are likely some bugs I've missed. The intention is to be fully plug-and-play where you can connect or disconnect a controller at anytime and things should work automatically. The GUI will update to show controller buttons when the controller is plugged in, and not when there is no controller connected. At all times standard keyboard and mouse controls should still work whether or not a controller is connected. A special note here - there are bound to be plenty of places where going from mouse/keyboard to gamepad and vice versa results in very minor issues like the cursor not being in quite the right spot, jumping around a bit, or the wrong button being displayed until a button or key press is made. These are so small and likely fairly numerous that I'm not too concerned with these unless the problem doesn't fix itself after gameplay resumes normally or if a crash occurs.
  • The import/export feature can be tested on the same device by just importing the data to a different slot, since the beta is currently unavailable on mobile, but if you have multiple computers with steam installed it'd be extra helpful to test the transfer process between those computers.
  • Steam achievements are set as the same for all builds, so to avoid having a handful of achievements shown that cannot be unlocked for the 4 weeks of beta for all players, I will be adding those the day of the live launch.
  • The beta is live on pc, mac, and linux. Be sure to let me know which platform you're on when reporting bugs.

You can post right here or email me at dustinaux@gmail.com with any bugs you find. I'll work on them and get the beta updated with new builds as soon as I can.



Last edited by dustinaux; Apr 4 @ 5:18am
< >
Showing 1-15 of 72 comments
Wow, I just randomly checked the forum, and boy was I pleasantly surprised :)

Thank you very much! I really didn't expect that this game would receive such a major content update this long after release.

Anyway, don't know how much time I'll have to playtest, but nevertheless I tried opting in to the beta. The Steam downloaded something (~7 MB or so), the game shows up as "The Enchanted Cave 2 [beta]" in the game list, but opening it up it doesn't seem to be updated? The top-left of the in-game Credits screen says "version 2.16 premium". The same if I run it directly from the game directory. The multiple save slots are not shown, there is only a single save and it is chosen automatically. The save file is named "TheEnchantedCave2.sol", instead of "TECSlot0.sol", "TECSlot1.sol" etc.

So, my first feedback would be: is Steam being weird again, or did you upload the wrong release to the beta channel? :)
Last edited by piccolo255; Apr 3 @ 9:57pm
dustinaux  [developer] Apr 4 @ 12:12am 
Wow that is very weird... 2.16 is an ancient version! Even the up-to-date live version is currently 2.27. Maybe try a full uninstall and reinstall?
Hm, nope. Unistalling and reinstalling didn't work. Neither did returning to main channel and then again to beta channel. I'm still getting 2.16 as "beta". Disabling the beta returns me to the proper 2.27.

I also tried restarting the Steam client, nope. Uninstalling, restarting the client, reinstalling: nope. The game is redownloaded every time I reinstall it or switch channels, so it shouldn't be a cache problem on my end.

Are you certain you didn't upload the wrong version? Are you able to start the beta on your own Steam account? If so, Steam is being weirder than usual, and I'll just have to try again in a few days or wait for full release.
dustinaux  [developer] Apr 4 @ 4:47am 
Ok, try it out now!

So steam does this silly thing with "depots" when you submit builds where some are dev only and make things appear perfectly fine when I'm logged into steam but other users are given an older version, even if I place them in the correct branches that you unlock with a password.

So anyways it should work now, sorry for the delay. :)
Thanks, it works perfectly!

I don't know if I'll have time to play before weekend, but some quick observations from five minutes of testing:
- Character selection is great
- Gamepad works, but sword-cursor jumps around way too much. When moving around menus, the movement animation is in the wrong place, and when it finishes the cursor jumps to the correct location. Looks weird, but you mentioned it'd be difficult to fix, so meh.
- Bug: when opening "Loot" menu while in town with a newly created character, it appears to show artifacts (and only artifacts) from the last run of the previous character.

BTW, is there any particular reason why you set up a password for beta? Are you just trying to make sure that people read your post before trying it out? :)
dustinaux  [developer] Apr 4 @ 5:17am 
Good to hear!

Yeah there are some instances of the cursor not being in the right position, maybe caused by some transitions, but it usually corrects itself on the next move. If you can reproduce the problem from a specific action I'll see what I can do to fix the positioning.

Thanks for the loot bug, I'll get that one fixed!

The beta branch was originally closed beta for some new features early on so the password was left over from that. But yeah it doesn't make much sense to have one with an open beta now so I'll remove it!
Originally posted by dustinaux:
Yeah there are some instances of the cursor not being in the right position, maybe caused by some transitions, but it usually corrects itself on the next move. If you can reproduce the problem from a specific action I'll see what I can do to fix the positioning.
So far, it happens only in menus -- including the main menu, both on fresh start and after quitting from in-game menu. It didn't improve after walking a bit around town. Maybe after I enter the cave? I'll do more tests later, maybe make a few screenshots to show you what's happening.

For the time being, I really gotta go to sleep, so if you'll excuse me :)
dustinaux  [developer] Apr 4 @ 8:18am 
Hm I don't think I've had it happen on the main menu before. In any case thanks for your help!
jmdeb Apr 5 @ 4:36pm 
I haven't played the game in a while, but was excited to when I saw the update. Im having a big problem, though: I cant enter the cave from the town. Old saves start inside the cave, but with new games after being stopped by the guard, when I try to enter the cave, the screen blackens like Ive gone inside but my character is still at the mouth of the cave. Seems like a bug unless Ive forgotten some important step for starting the game?
jmdeb Apr 5 @ 4:47pm 
Just tried to play a old save. Things work normally on the floor it started on, but the same thing happens as it does in town...it wont let me go to the next floor...the screen blackens but then my character is still on the same floor.
dustinaux  [developer] Apr 5 @ 5:59pm 
@jmdeb
Thanks for letting me know! To make sure I understand, the screen goes completely black in both situations and then the nothing happens? And this still happens if you start a new game in a new slot?

If you don't mind, can you email me your save files so I can take a look? I may have missed something in making sure old saves are correctly updated in newer versions. My email is dustinaux@gmail.com and your save file locations are listed at the beginning of this thread.

Also are you on PC, Mac, or Linux?
jmdeb Apr 6 @ 4:07am 
So the going black thing: you know how, in transitions between the town and inside the cave and between one floor and the next floor you have that sort of cinimatic fade to black that starts at the edges and heads towards the center of the screen? Well that happens, as it should but then when the screen is revealed again and the character is now supposed to be inside the cave or on the next floor, it isnt, its still in town at the mouth of the cave or still on the floor it was on. I hope that makes sense. I will email you my save files now. And Im using a PC
dustinaux  [developer] Apr 6 @ 1:36pm 
OK! Thanks for the save files! I got the same issue when I used them.

Turns out there is a bug that causes this when you have fps set to 30 in the options. Changing that to 60 fixes it. That option was added a while back to fix lag on some computers so it's possible it's not even needed anymore since a lot of things have been updated. Regardless I'll get a fix for this out soon. Thanks for your help!
dustinaux  [developer] Apr 6 @ 4:41pm 
Just uploaded a new build!

This fixes the 30fps freeze problem and also the "loot this run" from another save file displaying when you start a new file.
Jsyk fullscreen isn't working quite right with the cursor from controllers on the main menu - it moves with an offset, then snaps into the right place when it gets there. Haven't tested in more places yet.

EDIT: I can't reproduce it for some reason. I'll try more later, though. One bug I can reproduce, though, is fullscreening the windowed mode then changing to fullscreen requires you to toggle fullscreen off twice
Last edited by Golden Epsilon; Apr 7 @ 7:38am
< >
Showing 1-15 of 72 comments
Per page: 15 30 50