CrossCode

CrossCode

View Stats:
CrossCode > General Discussions > Topic Details
WakaLaka May 19, 2019 @ 8:11am
Gamepad controls are totally messed up
Cannot play because the controls are totally wonky. RT is mapped to start button and many other weird things. Changing layouts in Steam did not help.
< >
Showing 1-6 of 6 comments
R.Heart May 19, 2019 @ 3:19pm 
I'm afraid to ask what kind of controller you're using. o.O You might have to un-install then re-install drivers or something, Steam is 'usually' pretty good about resolving conflicts if say, you have both Microsoft's XBox Accessories driver on top of Steam's controller drivers.
Frankstar May 28, 2019 @ 7:27am 
i have the same problem on Linux and with a Xbox One S Controller.
Google says - alot of people have - even back in 2018. so i guess there is no fix for this ...
Houtworm May 28, 2019 @ 11:05am 
It works great for me, Have you guys tried turning Steam Controller Configuration on and off? check game properties :)
Novi May 30, 2019 @ 9:54am 
There is a thread here somewhere that explains it, but I will summarize. Crosscode being a web technology based game uses a web rendering engine to put everything on the screen where is is supposed to go. That engine is based on chromium and the controller "plugin" for is was broken by google and no one has bothered to fix it.
Sorry to necro a very old thread but i had this problem on 19.10 Ubuntu and figured out how to fix it this morning. This is a linux gamepad driver setting problem and has nothing to do with steam controller settings. So if anyone has linux & an xbox one s and still needs this info. The default ubuntu driver settings are awful and dont map the controller correctly for some indie games, Crosscode being one of them. If you have this issue run these terminal commands in order:
sudo apt install sysfsutils
sudo nano /etc/sysfs.conf
place the following at the end of the sysfs.conf file: /module/bluetooth/parameters/disable_ertm=1
Lastly ctrl+x to quit and save from nano editor, then reboot and try it again. :)
Houtworm Mar 13 @ 9:26am 
Originally posted by Khlamydia:
Sorry to necro a very old thread but i had this problem on 19.10 Ubuntu and figured out how to fix it this morning. This is a linux gamepad driver setting problem and has nothing to do with steam controller settings. So if anyone has linux & an xbox one s and still needs this info. The default ubuntu driver settings are awful and dont map the controller correctly for some indie games, Crosscode being one of them. If you have this issue run these terminal commands in order:
sudo apt install sysfsutils
sudo nano /etc/sysfs.conf
place the following at the end of the sysfs.conf file: /module/bluetooth/parameters/disable_ertm=1
Lastly ctrl+x to quit and save from nano editor, then reboot and try it again. :)

Hey Retransmission Mode has nothing to do with the mapping of the controller.

This setting is needed for the Xbox one S controllers to work with Bluetooth tho, The connection will break immediately otherwise.

What you probably did was turning off Steam Input Per-Game Setting in the game properties. It should then work great out of the box with the default kernel gamepad driver.

Oh and to disable etrm you don't need sysfutils, You can add the following line to /etc/modprobe.d/xbox_bt.conf

options bluetooth disable_ertm=1

Last edited by Houtworm; Mar 13 @ 9:29am
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

CrossCode > General Discussions > Topic Details