Black Mesa

Black Mesa

View Stats:
Black Mesa > General Discussions > Topic Details
[BMS] Adam-Bomb  [developer] Jul 8, 2016 @ 11:17pm
Crashes or Not Starting Fix (Over Dark Issue Too!)
Most crashes or game not starting issues should be fixed. All the latest betas have been pushed to the retail version of the game, so feel free to switch back. If you still have a crash issue, please post here to remind us.

To fix the crashing issue:
1. Verify your game cache once.
2. Launch the game with -autoconfig launch option for the first time after verifying cache.

https://support.steampowered.com/kb_article.php?ref=1216-JMTZ-0860#autoconfig

To Fix The Over Darkening Issue
Type the following two commands into console

mat_hdr_level 2
mat_tonemapping_occlusion_use_stencil 1

As always please post your system specs. Thanks and sorry for the troubles!
Last edited by [BMS] Adam-Bomb; Aug 10, 2016 @ 3:56am
< >
Showing 1-15 of 78 comments
AleXX Jul 9, 2016 @ 1:24am 
Really impossible to play. The game crashes when I turn on the flashlight or I see an explosion, a flame, a bright light or on loading

Acer Aspire v3-571g

Operating System
Windows 7 64-bit SP1
CPU
Intel Core i5 3210M @ 2.50GHz 55 °C
Ivy Bridge 22nm Technology
RAM
6,00ГБ Dual-Channel DDR3 @ 665MHz (9-9-9-24)
Motherboard
Acer VA50_HC_CR (U3E1)
Graphics
1366x768@60Hz
Intel HD Graphics 4000
1023MB NVIDIA GeForce GT 630M
ForceWare version: 368.39
SLI Disabled
Storage
698GB Western Digital WDC WD7500BPVT-22HXZT3 (SATA)
Optical Drives
LADMVMN TENKTIB85A SCSI CdRom Device
PIONEER DVD-RW DVRTD11RS
Audio
Realtek High Definition Audio
OGONek Jul 9, 2016 @ 4:46am 
Opting into the public beta solved the crashes, but I can't enable CSM, is this a feature of beta?
GordonFreeman  [developer] Jul 9, 2016 @ 8:26am 
Originally posted by OGONek:
Opting into the public beta solved the crashes, but I can't enable CSM, is this a feature of beta?

CSM has not been removed but it has been disabled completely on integrated cards and some low end dedicated graphics cards due to stability issues.
GordonFreeman  [developer] Jul 9, 2016 @ 8:33am 
Originally posted by AleXX:
Really impossible to play. The game crashes when I turn on the flashlight or I see an explosion, a flame, a bright light or on loading

Acer Aspire v3-571g

Operating System
Windows 7 64-bit SP1
CPU
Intel Core i5 3210M @ 2.50GHz 55 °C
Ivy Bridge 22nm Technology
RAM
6,00ГБ Dual-Channel DDR3 @ 665MHz (9-9-9-24)
Motherboard
Acer VA50_HC_CR (U3E1)
Graphics
1366x768@60Hz
Intel HD Graphics 4000
1023MB NVIDIA GeForce GT 630M
ForceWare version: 368.39
SLI Disabled
Storage
698GB Western Digital WDC WD7500BPVT-22HXZT3 (SATA)
Optical Drives
LADMVMN TENKTIB85A SCSI CdRom Device
PIONEER DVD-RW DVRTD11RS
Audio
Realtek High Definition Audio

Please switch over to public beta version of the game and verify your game cache once.
Also launch the game with -autoconfig launch option for the first time after verifying cache.

https://support.steampowered.com/kb_article.php?ref=1216-JMTZ-0860#autoconfig


If your game keeps crashing even after that please let us know.
AleXX Jul 10, 2016 @ 3:13am 
Originally posted by chetanjags:
Originally posted by AleXX:
Really impossible to play. The game crashes when I turn on the flashlight or I see an explosion, a flame, a bright light or on loading

Acer Aspire v3-571g

Operating System
Windows 7 64-bit SP1
CPU
Intel Core i5 3210M @ 2.50GHz 55 °C
Ivy Bridge 22nm Technology
RAM
6,00ГБ Dual-Channel DDR3 @ 665MHz (9-9-9-24)
Motherboard
Acer VA50_HC_CR (U3E1)
Graphics
1366x768@60Hz
Intel HD Graphics 4000
1023MB NVIDIA GeForce GT 630M
ForceWare version: 368.39
SLI Disabled
Storage
698GB Western Digital WDC WD7500BPVT-22HXZT3 (SATA)
Optical Drives
LADMVMN TENKTIB85A SCSI CdRom Device
PIONEER DVD-RW DVRTD11RS
Audio
Realtek High Definition Audio

Please switch over to public beta version of the game and verify your game cache once.
Also launch the game with -autoconfig launch option for the first time after verifying cache.

https://support.steampowered.com/kb_article.php?ref=1216-JMTZ-0860#autoconfig


If your game keeps crashing even after that please let us know.

My problem is solved. I have set lowest shadow details and now the game works perfect.:steamhappy:
The beta allows to set medium shadows but completely disallows the cascading shadow map and the game still works stable.
Kerosel Jul 10, 2016 @ 10:39am 
Hi Adam. PIcked up the BM mod long ago, recently saw it was official on Steam and picked it up. Lovin' it all over again and I love all the details that have gone in since the mod. I could sit and read the whiteboards for hours... but I digress.

I'm in "Questionable Ethics" at the point where you meet the guard that tells you the place is locked down but you could find some scientists to let you though. I walk down the hallway, turn the corner, hit the level load-point and then after some hard drive activity, the game crashes to the desktop without a beep or a message or anything.

Before this point while playing I had a few crashes, some to the desktop with an "Out of Memory" dialog box and some back to the desktop with no message. When those happened, I could immediately re-load the game and pick up from my last save point. This one in "Questionable" happens every time and reloading/restarting or even waiting a day doesn't seem to make a difference.

On the advice from this thread, I subscribed to the Public Beta, verified the cache and ran with the -autoconfig launch option. The only thing that looked different in the video settings was the resolution (down a click or two) but that didn't solve the problem. Also before going to the beta, I took the texture resolution and model resolution down to "medium" to see if that had any effect, but no change. Heh, obviously I'm leaning toward some sort of video/graphics problem, but it could be something else entirely!

Basic System Specs:
AMD Athlon 7750 Dual Core 2.75GHz
4GB RAM (3.25GB usable)
Windows XP Pro SP3 32-bit
ATI HD4850 512MB
Creative Labs Audigy2 ZS

I hope this can be solved... I'm really having fun re-living the Black Mesa nightmare. If there's any more information I can provide or any tests I can run, please let me know. I'd be happy to do them.
[BMS] Adam-Bomb  [developer] Jul 10, 2016 @ 11:31am 
Originally posted by Kerosel:
Basic System Specs:
AMD Athlon 7750 Dual Core 2.75GHz
4GB RAM (3.25GB usable)
Windows XP Pro SP3 32-bit
ATI HD4850 512MB
Creative Labs Audigy2 ZS

This seems like you are just running out of RAM. Restart before you play the game and make sure absolutely everything is closed int the background (Antivirus, dropbox, un-needed Windows services). If you haven't already, make sure you set everything as low as it possibly can go and turn of the additional graphics features under the "Black Mesa" options tab.
GordonFreeman  [developer] Jul 10, 2016 @ 10:06pm 
@Kerosel
Incase you havent already, try switching over to public beta version of the game and then try those workarounds mentioned by Adam.
Forgive me but please clarify, what you're saying is this will work for people like me who can only run the crossfire update? I've had to reinstall the whole game about 7 times now, so before I switch over to another beta/version, I wanna be sure this is proven to work.
(I tried the "cl_depth_enable 0" thing you suggested in another thread and it had no effect)
Gecko-[GER] Jul 11, 2016 @ 8:03am 
I get a black screen after the crowbar screen. Audio is working and you can hear the menu sounds. My specs

i5 6600
GTX 1070
16 GB Ram
G-Sync Monitor 2560x1440
NVidia Driver v368.39
OS Win 10 Pro
Sez Jul 11, 2016 @ 8:13am 
Originally posted by Gecko-GER:
I get a black screen after the crowbar screen. Audio is working and you can hear the menu sounds. My specs.
OS Win 10 Pro

The fix for Black Screen on Windows 10 that also improves fps is to run in windowed mode.
Go to Black Mesa's "Properties" and then Set launch options.
Enter "-window -noborder".
GordonFreeman  [developer] Jul 11, 2016 @ 10:32am 
Originally posted by A Deep Commitment To Konata:
Forgive me but please clarify, what you're saying is this will work for people like me who can only run the crossfire update? I've had to reinstall the whole game about 7 times now, so before I switch over to another beta/version, I wanna be sure this is proven to work.
(I tried the "cl_depth_enable 0" thing you suggested in another thread and it had no effect)
We are sorry to hear that you are facing issuses with our game. Yes the updates on beta branch should help everyone who were facing issues after crossfire update. There's no need to do cl_depth_enabled 0 on beta version anymore. Just launch the game with -autoconfig once. Depending on your system specs you might want to keep shadow settings to medium, turnoff CSM and turnoff godrays.
Also switching over to beta version from the main version should be <50 mb in download.


GordonFreeman  [developer] Jul 11, 2016 @ 10:42am 
Originally posted by Gecko-GER:
I get a black screen after the crowbar screen. Audio is working and you can hear the menu sounds. My specs

i5 6600
GTX 1070
16 GB Ram
G-Sync Monitor 2560x1440
NVidia Driver v368.39
OS Win 10 Pro

Although it shouldnt matter for users with high end cards but try switching over to beta version of the game and launch the game with -autoconfig once.
Please also try updating your drivers.
Originally posted by chetanjags:
Originally posted by A Deep Commitment To Konata:
Forgive me but please clarify, what you're saying is this will work for people like me who can only run the crossfire update? I've had to reinstall the whole game about 7 times now, so before I switch over to another beta/version, I wanna be sure this is proven to work.
(I tried the "cl_depth_enable 0" thing you suggested in another thread and it had no effect)
We are sorry to hear that you are facing issuses with our game. Yes the updates on beta branch should help everyone who were facing issues after crossfire update. There's no need to do cl_depth_enabled 0 on beta version anymore. Just launch the game with -autoconfig once. Depending on your system specs you might want to keep shadow settings to medium, turnoff CSM and turnoff godrays.
Also switching over to beta version from the main version should be <50 mb in download.
I appreciate the response, I'll try it, but I fear the worst. If it doesn't work I'll post my own specs I suppose...
Kerosel Jul 11, 2016 @ 12:25pm 
Originally posted by BMS Adam-Bomb:
This seems like you are just running out of RAM. Restart before you play the game and make sure absolutely everything is closed int the background (Antivirus, dropbox, un-needed Windows services). If you haven't already, make sure you set everything as low as it possibly can go and turn of the additional graphics features under the "Black Mesa" options tab.

True enough, I unchecked all the "Black Mesa" graphics features and turned everything down to low and it loaded okay. Once the firefight in the lobby was over, I started turning things back up and after a crash and stopping a few background processes, I got back to all the default levels I had been running before (including the additional graphics features) and it was stable with no further crashes. I made it all the way out of the lab without incident. Well, without programmatical issues, at least... there were plenty of incidents going on in the lab.

Those processes didn't seem to be taking a lot of memory, but maybe that little bit made the difference. I plan to devote a few slices of time to going back and seeing if it will crash again and if so, trying to figure out exactly what might have been causing it. Even if only for my own curiosity.

I know I'm not running the latest and greatest hardware or software and that XP is ancient history these days, so I appreciate the support and ideas on how to keep things working.

Cheers!
< >
Showing 1-15 of 78 comments
Per page: 15 30 50

Black Mesa > General Discussions > Topic Details
Date Posted: Jul 8, 2016 @ 11:17pm
Posts: 78