RPG Maker 2003

RPG Maker 2003

 This topic has been pinned, so it's probably important
Archeia  [developer] Aug 4, 2015 @ 5:50am
Windows 10 Keyboard Hotfix
An awesome user brought this to our attention:


I have Windows 10 release (build 10240) and I happen to have this issue where keyboard won't respond at all. It happens with both RPG Maker 2000 and RPG Maker 2003 games. However, I have found a workaround that happens to do the trick for a couple reboots I think. It happens to be a tool that resets the keyboard or something, and it is made by Cherry himself, so I think it is a trusted source.
Here is the link: http://share.cherrytree.at/showfile-2704/kbdreset.exe
 
Whenever you have the issue, just run this tool, try running the game again and voilá! This has worked for me, at least until Microsoft or RPG Maker devs find a definite fix to the issue...
 
Last edited by Archeia; Aug 4, 2015 @ 5:50am
< >
Showing 1-13 of 13 comments
CherryDT Aug 16, 2015 @ 3:25pm 
What's the funny thing about this: Actually, I added exactly this functionality in RM itself, so that it does this "reset" when the game starts. I'm not sure why it's not working for you (but works if you run the tool instead).
Archeia  [developer] Aug 17, 2015 @ 12:08pm 
Maybe it's because of the admin settings?
clyde Oct 2, 2015 @ 11:49am 
The tool also works for me; simply running the game does not.
johndoek May 28, 2016 @ 11:51am 
Thank you so much fr this fix, Archeia! Solved it perfectly!
athenian200 Jun 16, 2016 @ 8:00am 
I was having a similar issue with the Play Test feature just now. The keyboard sort of worked, but all the arrow/movement keys were dead and some of the others were mapped improperly.

This ended up fixing it. Thanks.
StarryMight Aug 27, 2016 @ 12:56pm 
I *JUST* encounted this issue in "RPG Maker 2003", and the program you provided worked (at least for now)! Thanks! ^_^
HopelessDecoy May 7, 2017 @ 6:17am 
I am having this problem, I will try the tool but running the playtest button will not respond to key presses.
JAGIELSKI Nov 9, 2017 @ 4:59am 
Funny thing: This is something that happened prior to Win10 as well. I remember having the issue way back with RPG Advocate's version when RMXP was just being developed on a WinXP box. Don't remember how did I fix it, because Cherry's tool wasn't around back then, but somehow I did get it working. Also heard some people in the Polish RM scene on a long defunct site mentioning similar issue with RM2k.

Dunno why did this issue not came up as much in the intermediate versions (or maybe it came and that's why Cherry made the tool and I just don't know) of Windows, but my bet is that it was fixed as one of Vista's various fixes, then rebroke again (reggression).
DazedConfused Dec 30, 2017 @ 6:25am 
Rising the forum back from the dead: But then, this issue appears only to developers, or people I distribute my game for example, have to install Cherry so?
JAGIELSKI Dec 30, 2017 @ 7:43am 
Anyone who expereinces the issue so most likely players may as well have to. Keep in mind that RM2k3 popularity is probably surprising even for Enterbrain. This software simply wasn't designed to run past Vista and it's a marvel that it does even work on modern systems.

If you want to make a commercial game with RM, using one of the newer releases would be a better bet - you can still achieve "pixelated" look with x2 (or x3 in case of MV) scaling of 16x16 tiles and charsets, and it would work better on modern systems. 2k3 is mostly for hobbyists who like to challenge themselves with lack of any scripting system aside of events (which itself is a turing-complete programming language).
DazedConfused Dec 30, 2017 @ 10:06am 
I think I will give up of RM2k3. It's been a nice relationship through the years but I think it's time to move on :'(
Sahone Nov 11, 2018 @ 3:59pm 
I got same problem with my up arrow key been "autopressed".

I have vJoy driver (a virtual controller software) for Smash Bros on PC, I went in Configure Vjoy and remove the option "Enable vJoy".

Now it works fine! :)
Rodro May 23 @ 5:15pm 
Originally posted by Sahone:
I got same problem with my up arrow key been "autopressed".

I have vJoy driver (a virtual controller software) for Smash Bros on PC, I went in Configure Vjoy and remove the option "Enable vJoy".

Now it works fine! :)

THANK YOU so much, I had this exact same proble. thank you very much now i can continue to work on my game!
< >
Showing 1-13 of 13 comments
Per page: 1530 50