ASTRONEER

ASTRONEER

View Stats:
ASTRONEER > General Discussions > Topic Details
Zuluknob Dec 17, 2016 @ 5:04am
Performance improvement
Add


[/script/engine.renderersettings]
r.DefaultFeature.MotionBlur=False
r.AmbientOcclusionLevels=0
r.postprocessAAQuality=0
bSmoothFrameRate=False

to engine.ini located in C:\Users\NAME\AppData\Local\Astro\Saved\Config\WindowsNoEditor

You may want to uncap your framerate in GameUserSettings.ini too
Last edited by Zuluknob; Feb 17, 2017 @ 9:06am
< >
Showing 1-15 of 99 comments
>5Cip< Dec 17, 2016 @ 5:07am 
Cap to how much fps ?
Zuluknob Dec 17, 2016 @ 5:10am 
Originally posted by <<Unr43l>>:
Cap to how much fps ?
I set mine to 500 while i test a bunch of commands, am getting 160fps in 4k on the titlescreen and between 90 and 160 ingame
Wyvyrias|ttv Dec 17, 2016 @ 5:50am 
Pretty awesome catch! Works fine.
Donauwelle Dec 17, 2016 @ 5:53am 
ehm all the ini are emtpy , execpt one game ini and some resulutionen ini ?? Is that normal ?
Zuluknob Dec 17, 2016 @ 5:54am 
Originally posted by Donauwelle:
ehm all the ini are emtpy , execpt one game ini and some resulutionen ini ?? Is that normal ?
My engine.ini now contains

[Core.System]
Paths=../../../Engine/Content
Paths=%GAMEDIR%Content
Paths=../../../Engine/Plugins/2D/Paper2D/Content



[/script/engine.renderersettings]
r.DefaultFeature.MotionBlur=False

r.AmbientOcclusionLevels=0
r.AmbientOcclusionRadiusScale=1.7

r.postprocessAAQuality=0
Donauwelle Dec 17, 2016 @ 6:08am 
I am Sorry , i did mean Game user Ini and the engine Ini.. all others are empty.

I did search that because i wanted to force the game to use my Intel HD instead the AMD. Because in AMD center i changed it. And the game use still my AMD.. . With the Windows Shop Version, it used from start the Intel HD.. confusing.

But is it normal that others are emtpy ? Like Hardware Ini and such things ?
Donauwelle Dec 17, 2016 @ 6:09am 
[Core.System]
Paths=../../../Engine/Content
Paths=%GAMEDIR%Content
Paths=../../../Engine/Plugins/2D/Paper2D/Content

[WindowsApplication.Accessibility]
StickyKeysHotkey=True
ToggleKeysHotkey=True
FilterKeysHotkey=True
StickyKeysConfirmation=True
ToggleKeysConfirmation=True
FilterKeysConfirmation=True

thats what my Engine Ini in have
Zuluknob Dec 17, 2016 @ 6:10am 
Other unreal games i have looked at have those ini fil;es filled out. No idea if its needed or not though.
Zuluknob Dec 17, 2016 @ 6:12am 
Originally posted by Donauwelle:
[Core.System]
Paths=../../../Engine/Content
Paths=%GAMEDIR%Content
Paths=../../../Engine/Plugins/2D/Paper2D/Content

[WindowsApplication.Accessibility]
StickyKeysHotkey=True
ToggleKeysHotkey=True
FilterKeysHotkey=True
StickyKeysConfirmation=True
ToggleKeysConfirmation=True
FilterKeysConfirmation=True

thats what my Engine Ini in have
Ah yeh, i removed the windows access part as stikky keys is annoying and added

[/script/engine.renderersettings]
r.DefaultFeature.MotionBlur=False

r.AmbientOcclusionLevels=0

r.postprocessAAQuality=0
Donauwelle Dec 17, 2016 @ 6:21am 
well for me it didnt change anything. Stutters , and drops when moving. And Freeze :/ but ok. It was a try
Zuluknob Dec 17, 2016 @ 6:25am 
Originally posted by Donauwelle:
well for me it didnt change anything. Stutters , and drops when moving. And Freeze :/ but ok. It was a try
Well you can go through https://docs.unrealengine.com/latest/INT/Engine/Performance/Scalability/ScalabilityReference/index.html#anti-aliasing
testing settings to see if you can fix your problem. You can see what they are currently set to in gameusersettings.ini(you cant alter them in there though)
#E Rac Mac Dec 17, 2016 @ 6:27am 
I was able to get a fractional fps improvement to allow me to move a small amount and experience some game play. Thanks for this find. My limited graphics understanding tells me has to do with the 3D redrawing. If I stop, it catches up and I jump to 40-60. But if I try and run, it will lock up and crash.
Donauwelle Dec 17, 2016 @ 6:36am 
Originally posted by Zuluknob:
Originally posted by Donauwelle:
well for me it didnt change anything. Stutters , and drops when moving. And Freeze :/ but ok. It was a try
Well you can go through https://docs.unrealengine.com/latest/INT/Engine/Performance/Scalability/ScalabilityReference/index.html#anti-aliasing
testing settings to see if you can fix your problem. You can see what they are currently set to in gameusersettings.ini(you cant alter them in there though)


i dont think thats the problem. Maybe i will change some settings in there to test ^^
I am just wondering that i have in this ini no funktion to force the game to use Intel HD.. ^^

Since the patch , the game prefer to freeze faster. Yesterday i had like 10 Minutes, with stuttering. First i thought its the AMD GPU, but i saw alot of other threads that had same issues , and no AMD.

I will wait a bit. And hope the Dev can alter the problems.
GoofyZ (NL) Dec 17, 2016 @ 7:00am 
I have GTX980TI and I7 3930K @ 3.2 GHz ( 6 cores i believe) , and 16 gig intern memory. Only get 17 FPS. But i have already everything researched and have 5 vehicles. It started bad when i discovered alot and went into caves. Restarting game does not help.
Tetshio Dec 17, 2016 @ 7:48am 
Thank you. Finally, no more motion sickness
< >
Showing 1-15 of 99 comments
Per page: 15 30 50

ASTRONEER > General Discussions > Topic Details
Date Posted: Dec 17, 2016 @ 5:04am
Posts: 99