Tom Clancy's Rainbow Six Siege

Tom Clancy's Rainbow Six Siege

View Stats:
LENOVO LEGION Y520: LOW FPS in all games
initially when i bought this laptop i had no issues with performance (i used to get easily 70-80 fps on RAINBOW SIX SIEGE at very high graphics) but now after like 1 year and 3 months im getting low fps on every game at lowest graphics (about 20-50fps). i installed a benchmark software called novabench and when i ran the test i got a RESULT OF ONLY 1525 (other laptops of my specs had a score of 3000-4000).

these are individual scores:

CPU: 707 GPU:558 RAM:237 DISK:23

these are the specs of my laptop :

GPU: geforce gtx 1050 ti

CPU: 7700hq

RAM: 16gb

HDD: 1tb and SSD: 25gb

i tried all of the following

1)reinstalling the games

2)reinstalling nvidia drivers (clean installation)

3)formatted the laptop 4 times now (it worked the first 2 times but dint work from the 3rd time onwards)

4)i gave my laptop for servicing and got all the fans cleaned

5) tried installing the nvidia drivers that was on the lenovo pc support website ( nvidia drivers v391.25 --> default nvidia driver)

6) tried changing priority of the games to high

7) tried to update my system drivers using the lenovo pc support site by allowing the lenovo site to detect if my drivers need to be updated but it said "all your drivers are up to date"

8) tried to disable and enable graphic driver in device manager

Anyone got any suggestions on how to fix this issue? what should i do ?
< >
Showing 1-6 of 6 comments
Ubi-Bandicoot  [developer] Jan 11 @ 12:37am 
Hey,

You mentioned enabling and disabling your graphic driver and have you made sure your games are running from your high-power dedicated gaming GPU and not the integrated graphics card?

We have more steps here you can try too: https://support.ubi.com/en-GB/faqs/000025947/Basic-PC-Troubleshooting/

- Ubisoft Support Team
yes, i have selected NVIDIA GPU as my global settings
UbiRedbeard  [developer] Jan 13 @ 1:01am 
Can you please head to the .exe file in your Steam directory, right-click it, select Properties, Compatibility and select to 'Disable fullscreen optimizations'.

Please let me know if this resolves your issue.

Thanks.

- Ubisoft Support
yes i already did this like 3 months back ....
Frute Jan 15 @ 6:28pm 
Clean out your vents
ive already given my laptop for servicing like a month ago
< >
Showing 1-6 of 6 comments
Per page: 15 30 50