SteamVR Developer Hardware

SteamVR Developer Hardware

IRIS VR Sep 2, 2015 @ 11:22am
60fps lock in UE4 builds
When you run the VR preview in editor for the first time, the framerate is solid at 90fps. Trying to run the VR preview in editor a second time results in the framerate getting locked at 60fps. Even if no changes have been made to the scene. This means you get one good preview in editor before having to shutdown UE4 and restart it.

All builds locked at 60fps.
Is it locking the framerate to the primary monitor? Any ideas would be appreciated. We're running a beast system with a 980ti.

Thanks in advance.
< >
Showing 1-15 of 20 comments
dustums Sep 3, 2015 @ 4:17pm 
I'm seeing the same thing. Not only that, there is something very wrong with the 60fps, in that the world is "jittery", making it's look like it running way lower that 60fps. I'm on a regular 980.
Last edited by dustums; Sep 3, 2015 @ 4:28pm
Illusionweaver Sep 4, 2015 @ 2:41pm 
I'm seeing the same thing and when I do get smooth fps , I have a weird vertical line rolling over the screen when I move the hmd (Vive) in a up/down motion, anyone knows what could be the cause of this? Tried everything and havent found a a solution so far.....

Runnig UE4 4.9 + Nvidia gameworks drivers + Win10
lfl_ben_peck Sep 8, 2015 @ 11:11am 
Do you folks ever get this when running standalone, or is this only when using preview? I haven't experienced this in 4.8/Win7 . I get intermittent graphics driver crashes when using vr preview, but no 60 fps lock, etc.

Make sure there are no windows overlapping the compositor & make sure the resolution of the window matches the resolution of the Vive panels.
toneStark_ Sep 9, 2015 @ 11:49am 
We're seeing something similar. When first starting up Unreal the initial VR Preview is fine.

One thing I'm noticing that hasn't been mentioned is the fact that the headset now shows my editor viewport blended with the compositor. This leads me to believe it is locking to the main monitor as well. I can see myself moving around in the editor on the headset. On a fresh boot of unreal the compositor room displays as normal.
dustums Sep 9, 2015 @ 1:16pm 
Good call. I see the same thing. Fresh reboot has headset show a clean white compositor room, but subsequent PIE leaves the headset looking at an editor blended view. When I "stat unit", Game and GPU are in the 16 ms range, hence why framerate isn't 90, but when I "profile gpu" in this state, it's showing my GPU at normal levels of 9 ms. Is the compositor and Unreal Editor not playing nicely together?
IRIS VR Oct 15, 2015 @ 8:40am 
It was the preview screen position overlap thing. Works now. Thanks for the help. :)
ukPRINT Oct 18, 2015 @ 3:36am 
Interesting... I did the above, moving Vive display to bottom left / right of the main screen and made sure the compositor is at full screen. Then I started a new Minimal_default level, no additional works and straight to VR preview running VR preview. From ~stat fps it is constantly at 45fps. It did show 60fps momentarily, but only for 2-3 frames only.

I got the preview screen showing on my main screen, does it mean it is not overlapping? Little bit confused.

Im using UE4.9.2, GTX970.
Grizzlywares Oct 19, 2015 @ 2:05pm 
ukPrint, I would probably trying going into Project Settings>Engine>Framerate and checking to make sure you haven't accidentally set a limit on the FPS.
ukPRINT Oct 21, 2015 @ 2:13pm 
Grizzlywares, I made sure no silly mistakes like this... I'm not sure what is causing such low framerate... but then I tried setting everything to Low in the Engine Scalability Settings, then I got a constant 60fps. This is just a UE4 Minimal_Default level and I have GTX970, it shouldn't be a performance issue I guess?
Grizzlywares Oct 21, 2015 @ 2:48pm 
You check if it's a performance issue by entering the command "stat unit" and seeing what you're bound by. If it looks like GPU, you can enter "Profile GPU", which will open a profiler in another window where you can check for performance issues. If the total GPU profile is much lower than your fps, then you are likely being bound by something else.
ukPRINT Oct 21, 2015 @ 3:25pm 
Thanks Grizzlywares for the tips.

I got 16.67ms in the GPU visualiser and in VR Preview stat fps shows 45.06fps and 22.19ms

Please see the image here -> http://adobe.ly/1NophMm It's a screenshot of UE4 default map at Epic setting.

I know the 970 is probably not ideal for VR dev, but surely it should be OK to manage such as simple scene, also I just upgraded the RAMs to 32GB 2400MHz on the 3rd gen i7 3770.

On this note, would you recommend 980ti or 970SLI?
Eli_Tayrien Oct 21, 2015 @ 4:57pm 
UE4 VR doesnt' support SLI yet. If you need a solution right now, I'd recommend 980ti.
Last edited by Eli_Tayrien; Oct 21, 2015 @ 4:57pm
ukPRINT Oct 21, 2015 @ 5:02pm 
Further to this, I've been testing running 2 graphics card non SLI, so I have 1 card taking care of the desktop display (UE4 and desktop) and the better GTX970 to run the Vive. So far.. I got all 3 displays running but seems like the VR compositor is unable to accept VR images. ie. It is stuck in the white room even when a demo is running.
Grizzlywares Oct 21, 2015 @ 5:32pm 
A good way to optimize your visual latency might be to go through the GPU Profiler and look at what various things are costing you. By default UE4 has a ton of post-processing, and you will probably want to disable at least some of it for VR development.
< >
Showing 1-15 of 20 comments
Per page: 15 30 50

Date Posted: Sep 2, 2015 @ 11:22am
Posts: 20