SteamVR Developer Hardware

SteamVR Developer Hardware

View Stats:
Base Station Non Functional After Firmware Update
There was a base station firmware update tonight which I installed following the directions. After the firmware update was complete, when the base station started back up it was malfunctioning. It has a red light, and some kind of jumbled text appears where you would usually see "a, b, c". Did the firmware update fail? What should I do?
< >
Showing 1-15 of 105 comments
BoFHay  [developer] Mar 18, 2016 @ 8:32pm 
Both bases or only one?
BoFHay  [developer] Mar 19, 2016 @ 2:50am 
Please email me alany (at) valvesoftware (dot) com I may have a fix for you.
[TW]Ramm-Jaeger Mar 19, 2016 @ 7:46am 
It was only one base station that stopped working after the firmware update. I'll send you an e-mail.
STANLEY! Mar 19, 2016 @ 3:24pm 
We had this issue as well - will drop you a line too!
Same problem...updated one, said firmware was good. Connected power and now red light with cycling letters.
brandonnn Mar 19, 2016 @ 4:42pm 
I'm having the same problem -- emailing BoFHay! PyrO: let me know if you've got any other help!
brandonnn Mar 19, 2016 @ 4:59pm 
For anyone else that runs into this & finds the thread later, here's the error message it's cycling for me.
Me4502 Mar 20, 2016 @ 2:57am 
Mine arrived like this, but without the cycling letters.

I fixed it by installing the most recent firmware in the archive folder.
VRLINES Mar 21, 2016 @ 2:26am 
Same issue here: the base station used to work well then after a "successful" firmware update one is working fine and the other has a red light with the same message brandonnn shows in his video.
Miedemantus Mar 21, 2016 @ 6:46am 
We're experiencing a similar, but different issue with our unit:

Both base stations seem to be working. We've put them in b and c mode. The LED's are showing white, and do not take an abnormal amount of time to do so.

However, in SteamVR, only one of the base stations shows up as available. The other one remains grayed out, even though the base station itself seems to be functioning and synchronized with the other unit.

We've tried updating both base stations, Switching b and c modes, Using the sync cable, re-installing the software and even switching systems. This does not seem to have any impact.

Any suggestions on what to do?
XeviaN Mar 21, 2016 @ 11:12am 
Hi all, same here.
One station was updated successfully. The other not. Red led, cycling symbols on the display, motor not running.
If we try the update firmware procedure (usb cable to the pc, button pressed and connecting the power cable), nothing happens: a very fast white blink and the base station shuts down, all black. Nothing on the pc.
I'm just writing an email to Alany.
Last edited by XeviaN; Mar 21, 2016 @ 11:12am
[TW]Ramm-Jaeger Mar 21, 2016 @ 4:02pm 
AlanY has a fix for this issue. It has to do with a problem with the configuration software on some of the base stations which causes them to get in a failed state on firmware updates. His fix worked for me, perhaps he can post that fix here. He has to send over some firmware files.
BoFHay  [developer] Mar 21, 2016 @ 10:27pm 
I am sorry to hear some people are experiencing upgrade problems. The latest firmware is an important update, it fixes a nasty configuration corruption bug in previous versions (older than 220) which can leave bases with subtle problems that go unnoticed. These upgrade issues are generally the result of this bug and this fix can correct the corruption and upgrade a base to the latest version so the problem will not recur. The problem does not occur in mass-production or VDK1 bases, only PRE and some PVT units are affected.

The fix has worked successfully for several users, so we shipped the required files in the latest beta. You can find the files under your SteamVR install directory. The easiest way to get there is to right click on SteamVR in Steam, select Properties, click on the Local Files tab and Browse Local Files... Once there the firmware files live in:

tools\lighthouse\firmware\lighthouse_tx\archive\htc_2.0

You will need two files:

* lighthouse_tx_htc_2_0-calibration-rescue-244.bin
* lighthouse_tx_htc_2_0-244-2016-03-12.bin

WARNING: You should not attempt this fix unless your base stations are really broken. While it *should* be harmless, there is a non-zero chance it could make things worse. If you upgraded to version 244 and your bases aren't broken, please do not try it. This fix also applies only to HTC base stations, it will not work with older VDK1/Robin or the red laser Batman units.

The procedure is much like upgrading manually, but you do it twice, once with the fix-up firmware which will try to fix the base station, then once it has completed the fix, again with the current latest firmware.

1. With the base station unpowered, connect via a micro-B USB cable to your PC.
2. Hold the mode button down and plug in the power lead.
3. You can release the button once it enumerates as a USB mass storage device.
4. The drive will be called “CRP_DISABLED” and contain one file “firmware.bin”, delete that file.
5. Copy over onto the drive the “lighthouse_tx_htc_2_0-calibration-rescue-244.bin” file.
6. Once the copy is complete, pull out the power lead.
7. Wait a few seconds then plug in the power again. Be sure not to press the mode button while powering it up this time.
8. In a couple of seconds it should rapidly flash green or red. Green means it succeeded.
9. If it is flashing red that means it couldn’t automatically fix it and I’ll need to look at the unit to work out why.
10. Unplug the power again.
11. Repeat steps 1 thru 7 but using the “lighthouse_tx_htc_2_0-244-2016-03-12.bin” firmware file instead of the rescue one.
12. The base should now be working again, confirm by setting its mode to "A" and tracking with it alone (the other base turned off). Once it is confirmed working you can add back the other base.

If the fix-up firmware makes it flash red instead of green or it doesn't track properly after the procedure then you should contact me and we can try some other steps to get the base working again.
Last edited by BoFHay; Mar 21, 2016 @ 10:29pm
Miedemantus Mar 22, 2016 @ 12:37am 
@BoFHay - Could we try to perform these actions in case of this issue as well? (https://steamcommunity.com/app/358720/discussions/0/385428458167915520/)
BoFHay  [developer] Mar 22, 2016 @ 5:07pm 
Yes, this procedure is worth a try if you are experiencing lock problems too, it can repair many ills.
< >
Showing 1-15 of 105 comments
Per page: 15 30 50